]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- Up to 8.2.5
authorBartosz Świątek <shadzik@tld-linux.org>
Mon, 24 Apr 2023 09:59:55 +0000 (11:59 +0200)
committerBartosz Świątek <shadzik@tld-linux.org>
Mon, 24 Apr 2023 09:59:55 +0000 (11:59 +0200)
php-ini.patch
php-silent-session-cleanup.patch
php.spec

index f03462ab5c80e902b07ea7cca7eaec1dffea7860..e86eb5f4bde0ce7892638fe541e042130e8dc477 100644 (file)
@@ -1,5 +1,5 @@
---- php-8.2.2/php.ini  2023-01-31 14:31:55.000000000 +0100
-+++ php-8.2.2/php.ini  2023-02-08 22:05:00.850660744 +0100
+--- php-8.2.5/php.ini.orig     2023-04-11 18:16:23.000000000 +0200
++++ php-8.2.5/php.ini  2023-04-24 11:40:19.022838620 +0200
 @@ -82,6 +82,16 @@
  ; much more verbose when it comes to errors. We recommend using the
  ; development version only in development environments, as errors shown to
@@ -53,7 +53,7 @@
  
  ;;;;;;;;;;;;;;;;;;;
  ; Resource Limits ;
-@@ -762,7 +772,7 @@
+@@ -767,7 +777,7 @@
  ; https://php.net/extension-dir
  ;extension_dir = "./"
  ; On windows:
@@ -62,7 +62,7 @@
  
  ; Directory where the temporary files should be placed.
  ; Defaults to the system default (see sys_get_temp_dir)
-@@ -774,64 +784,6 @@
+@@ -779,64 +789,6 @@
  ; https://php.net/enable-dl
  enable_dl = Off
  
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -996,19 +948,19 @@
+@@ -1001,19 +953,19 @@
  ; Use of this INI entry is deprecated, use global input_encoding instead.
  ; If empty, default_charset or input_encoding or iconv.input_encoding is used.
  ; The precedence is: default_charset < input_encoding < iconv.input_encoding
  
  [imap]
  ; rsh/ssh logins are disabled by default. Use this INI entry if you want to
-@@ -1178,6 +1130,9 @@
+@@ -1187,6 +1139,9 @@
  ; https://php.net/mysqli.default-socket
  mysqli.default_socket =
  
  ; Default host for mysqli_connect() (doesn't apply in safe mode).
  ; https://php.net/mysqli.default-host
  mysqli.default_host =
-@@ -1331,7 +1286,7 @@
+@@ -1340,7 +1295,7 @@
  
  [browscap]
  ; https://php.net/browscap
  
  [Session]
  ; Handler used to store/retrieve data.
-@@ -1754,7 +1709,7 @@
+@@ -1763,7 +1718,7 @@
  
  ; Sets the directory name where SOAP extension will put cache files.
  ; https://php.net/soap.wsdl-cache-dir
  
  ; (time to live) Sets the number of second while cached file will be used
  ; instead of original one.
-@@ -1775,160 +1730,6 @@
+@@ -1784,165 +1739,6 @@
  [dba]
  ;dba.default_handler=
  
 -;opcache.file_cache_fallback=1
 -
 -; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
--; This should improve performance, but requires appropriate OS configuration.
--;opcache.huge_code_pages=1
+-; Under certain circumstances (if only a single global PHP process is
+-; started from which all others fork), this can increase performance
+-; by a tiny amount because TLB misses are reduced.  On the other hand, this
+-; delays PHP startup, increases memory usage and degrades performance
+-; under memory pressure - use with care.
+-; Requires appropriate OS configuration.
+-;opcache.huge_code_pages=0
 -
 -; Validate cached file permissions.
 -;opcache.validate_permission=0
index 1c004a31a5014b8e310355b7b1730f793a549a9b..0d37d8d8a0a7c1229b2b2b725a24805394a00cd7 100644 (file)
@@ -1,10 +1,10 @@
---- php-8.2.0RC2/ext/session/mod_files.c~      2022-09-14 12:42:49.000000000 +0300
-+++ php-8.2.0RC2/ext/session/mod_files.c       2022-09-29 01:26:03.341783642 +0300
+--- php-8.2.5/ext/session/mod_files.c.orig     2023-04-24 11:42:37.515845438 +0200
++++ php-8.2.5/ext/session/mod_files.c  2023-04-24 11:45:46.013854719 +0200
 @@ -287,7 +287,6 @@
  
        dir = opendir(ZSTR_VAL(dirname));
        if (!dir) {
 -              php_error_docref(NULL, E_NOTICE, "ps_files_cleanup_dir: opendir(%s) failed: %s (%d)", ZSTR_VAL(dirname), strerror(errno), errno);
-               return (0);
+               return -1;
        }
  
index 20c7c5edc80c5c15bff58e408a949c075a2d8780..26963a7760e560d82c311aa0b9a107e37e7e0a50 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -124,7 +124,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.2.3
+Version:       8.2.5
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -133,7 +133,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: cb768cf744184e64d48b15305c437336
+# Source0-md5: 802ddeb65a32362a739326eddd1c172f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini