]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 5.5.25
authorMarcin Krol <hawk@tld-linux.org>
Tue, 2 Jun 2015 11:31:30 +0000 (11:31 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Tue, 2 Jun 2015 11:31:30 +0000 (11:31 +0000)
php-systzdata.patch
php.spec
suhosin.patch

index f841e9bb609264de40e464dc596f0773af4cb02d..aa3277c03fda8786cfa584a6beff65d0faec6987 100644 (file)
@@ -2,10 +2,14 @@ Add support for use of the system timezone database, rather
 than embedding a copy.  Discussed upstream but was not desired.
 
 History:
+r12: adapt for upstream changes for new zic
+r11: use canonical names to avoid more case sensitivity issues
+     round lat/long from zone.tab towards zero per builtin db
+r10: make timezone case insensitive
 r9: fix another compile error without --with-system-tzdata configured (Michael Heimpold)
 r8: fix compile error without --with-system-tzdata configured
 r7: improve check for valid timezone id to exclude directories
-r6: fix fd leak in r5, fix country code/BC flag use in 
+r6: fix fd leak in r5, fix country code/BC flag use in
     timezone_identifiers_list() using system db,
     fix use of PECL timezonedb to override system db,
 r5: reverts addition of "System/Localtime" fake tzname.
@@ -16,9 +20,10 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
 r2: add filesystem trawl to set up name alias index
 r1: initial revision
 
---- a/ext/date/lib/parse_tz.c
-+++ b/ext/date/lib/parse_tz.c
-@@ -24,6 +24,16 @@
+diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/lib/parse_tz.c
+--- php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata     2015-04-30 00:00:18.000000000 +0200
++++ php-5.6.9RC1/ext/date/lib/parse_tz.c       2015-04-30 06:36:47.019617321 +0200
+@@ -20,6 +20,16 @@
  
  #include "timelib.h"
  
@@ -35,7 +40,7 @@ r1: initial revision
  #include <stdio.h>
  
  #ifdef HAVE_LOCALE_H
-@@ -35,7 +45,12 @@
+@@ -31,7 +41,12 @@
  #else
  #include <strings.h>
  #endif
@@ -48,25 +53,18 @@ r1: initial revision
  
  #if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
  # if defined(__LITTLE_ENDIAN__)
-@@ -55,9 +70,14 @@
- static void read_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -53,6 +68,10 @@ static int read_preamble(const unsigned
  {
--      /* skip ID */
--      *tzf += 4;
--      
-+        if (memcmp(tzf, "TZif", 4) == 0) {
-+                *tzf += 20;
-+                return;
-+        }
-+        
-+        /* skip ID */
-+        *tzf += 4;
-+                
-       /* read BC flag */
-       tz->bc = (**tzf == '\1');
-       *tzf += 1;
-@@ -260,7 +280,397 @@ void timelib_dump_tzinfo(timelib_tzinfo
+       uint32_t version;
++      if (memcmp(*tzf, "TZif", 4) == 0) {
++              *tzf += 20;
++              return 0;
++      }
+       /* read ID */
+       version = (*tzf)[3] - '0';
+       *tzf += 4;
+@@ -296,7 +315,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
        }
  }
  
@@ -80,7 +78,7 @@ r1: initial revision
 +#endif
 +
 +/* System timezone database pointer. */
-+static const timelib_tzdb *timezonedb_system = NULL;
++static const timelib_tzdb *timezonedb_system;
 +
 +/* Hash table entry for the cache of the zone.tab mapping table. */
 +struct location_info {
@@ -98,13 +96,14 @@ r1: initial revision
 + * prevent too many collisions. */
 +#define LOCINFO_HASH_SIZE (1021)
 +
++/* Compute a case insensitive hash of str */
 +static uint32_t tz_hash(const char *str)
 +{
 +    const unsigned char *p = (const unsigned char *)str;
 +    uint32_t hash = 5381;
 +    int c;
 +    
-+    while ((c = *p++) != '\0') {
++    while ((c = tolower(*p++)) != '\0') {
 +        hash = (hash << 5) ^ hash ^ c;
 +    }
 +    
@@ -163,7 +162,7 @@ r1: initial revision
 +    /* Round to five decimal place, not because it's a good idea,
 +     * but, because the builtin data uses rounded data, so, match
 +     * that. */
-+    *result = round(v * sign * 100000.0) / 100000.0;
++    *result = trunc(v * sign * 100000.0) / 100000.0;
 +
 +    return p;
 +}
@@ -291,7 +290,7 @@ r1: initial revision
 +{
 +        const timelib_tzdb_index_entry *alpha = first, *beta = second;
 +
-+        return strcmp(alpha->id, beta->id);
++        return strcasecmp(alpha->id, beta->id);
 +}
 +
 +
@@ -429,6 +428,26 @@ r1: initial revision
 +      return S_ISREG(st->st_mode) && st->st_size > 20;
 +}
 +
++/* To allow timezone names to be used case-insensitively, find the
++ * canonical name for this timezone, if possible. */
++static const char *canonical_tzname(const char *timezone)
++{
++    if (timezonedb_system) {
++        timelib_tzdb_index_entry *ent, lookup;
++        
++        lookup.id = (char *)timezone;
++        
++        ent = bsearch(&lookup, timezonedb_system->index,
++                      timezonedb_system->index_size, sizeof lookup,
++                      sysdbcmp);
++        if (ent) {
++            return ent->id;
++        }
++    }
++
++    return timezone;
++}
++
 +/* Return the mmap()ed tzfile if found, else NULL.  On success, the
 + * length of the mapped data is placed in *length. */
 +static char *map_tzfile(const char *timezone, size_t *length)
@@ -442,7 +461,7 @@ r1: initial revision
 +              return NULL;
 +      }
 +
-+      snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
++      snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
 +      
 +      fd = open(fname, O_RDONLY);
 +      if (fd == -1) {
@@ -465,11 +484,11 @@ r1: initial revision
  {
        int left = 0, right = tzdb->index_size - 1;
  #ifdef HAVE_SETLOCALE
-@@ -299,36 +709,128 @@ static int seek_to_tz_position(const uns
+@@ -335,21 +765,87 @@ static int seek_to_tz_position(const uns
        return 0;
  }
  
-+static int seek_to_tz_position(const unsigned char **tzf, char *timezone, 
++static int seek_to_tz_position(const unsigned char **tzf, char *timezone,
 +                             char **map, size_t *maplen,
 +                             const timelib_tzdb *tzdb)
 +{
@@ -481,15 +500,14 @@ r1: initial revision
 +              if (orig == NULL) {
 +                      return 0;
 +              }
-+              
++
 +              (*tzf) = (unsigned char *)orig ;
 +              *map = orig;
-+                
-+                return 1;
++              return 1;
 +      }
-+       else
++      else
 +#endif
-+       {
++      {
 +              return inmem_seek_to_tz_position(tzf, timezone, tzdb);
 +      }
 +}
@@ -504,11 +522,10 @@ r1: initial revision
 +              tmp->data = NULL;
 +              create_zone_index(tmp);
 +              system_location_table = create_location_table();
-+                fake_data_segment(tmp, system_location_table);
++              fake_data_segment(tmp, system_location_table);
 +              timezonedb_system = tmp;
 +      }
 +
-+                      
 +      return timezonedb_system;
 +#else
        return &timezonedb_builtin;
@@ -532,38 +549,54 @@ r1: initial revision
 -      return (seek_to_tz_position(&tzf, timezone, tzdb));
 +
 +#ifdef HAVE_SYSTEM_TZDATA
-+        if (tzdb == timezonedb_system) {
-+            char fname[PATH_MAX];
-+            struct stat st;
++      if (tzdb == timezonedb_system) {
++              char fname[PATH_MAX];
++              struct stat st;
 +
-+            if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
-+              return 0;
-+            }
-+            
-+            snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
-+            
-+            return stat(fname, &st) == 0 && is_valid_tzfile(&st);
-+        }
-+#endif
++              if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
++                      return 0;
++              }
 +
++              if (system_location_table) {
++                      if (find_zone_info(system_location_table, timezone) != NULL) {
++                              /* found in cache */
++                              return 1;
++                      }
++              }
++
++              snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
++
++              return stat(fname, &st) == 0 && is_valid_tzfile(&st);
++      }
++#endif
 +      return (inmem_seek_to_tz_position(&tzf, timezone, tzdb));
  }
  
+ static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -374,24 +870,54 @@ static void read_64bit_header(const unsi
  timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
  {
        const unsigned char *tzf;
 +      char *memmap = NULL;
 +      size_t maplen;
        timelib_tzinfo *tmp;
+       int version;
  
 -      if (seek_to_tz_position(&tzf, timezone, tzdb)) {
 +      if (seek_to_tz_position(&tzf, timezone, &memmap, &maplen, tzdb)) {
                tmp = timelib_tzinfo_ctor(timezone);
  
-               read_preamble(&tzf, tmp);
+               version = read_preamble(&tzf, tmp);
                read_header(&tzf, tmp);
                read_transistions(&tzf, tmp);
                read_types(&tzf, tmp);
+-              if (version == 2) {
+-                      skip_64bit_preamble(&tzf, tmp);
+-                      read_64bit_header(&tzf, tmp);
+-                      skip_64bit_transistions(&tzf, tmp);
+-                      skip_64bit_types(&tzf, tmp);
+-                      skip_posix_string(&tzf, tmp);
+-              }
 -              read_location(&tzf, tmp);
 +
 +#ifdef HAVE_SYSTEM_TZDATA
@@ -591,14 +624,22 @@ r1: initial revision
 +              } else
 +#endif
 +              {
++                      if (version == 2) {
++                              skip_64bit_preamble(&tzf, tmp);
++                              read_64bit_header(&tzf, tmp);
++                              skip_64bit_transistions(&tzf, tmp);
++                              skip_64bit_types(&tzf, tmp);
++                              skip_posix_string(&tzf, tmp);
++                      }
 +                      /* PHP-style - use the embedded info. */
 +                      read_location(&tzf, tmp);
-+              }
++              }
        } else {
                tmp = NULL;
        }
---- a/ext/date/lib/timelib.m4
-+++ b/ext/date/lib/timelib.m4
+diff -up php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata php-5.6.9RC1/ext/date/lib/timelib.m4
+--- php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata     2015-04-30 00:00:18.000000000 +0200
++++ php-5.6.9RC1/ext/date/lib/timelib.m4       2015-04-30 06:32:08.549500385 +0200
 @@ -78,3 +78,17 @@ stdlib.h
  
  dnl Check for strtoll, atoll
index e2851edd0817ae01457fc1bee9b2b11732cdbb7b..71e6b3e72f168c856c3374733f5a5a2a1862b978 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -140,13 +140,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.5.23
+Version:       5.5.25
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: 9a8fa2ac24ba40f6a837a7e1b436ce60
+# Source0-md5: b3c38f0a12e27722585d962d86dfdd16
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
index 8608d1fa03c626f35e2a50c698d7e5bd834a89cd..5f1109bb0fcab3aa12063df6fb02eb87066de005 100644 (file)
@@ -876,7 +876,7 @@ the following modifications have been made:
                        heap->cache[index] = best_fit->prev_free_block;
                        ZEND_MM_CHECK_MAGIC(best_fit, MEM_BLOCK_CACHED);
 -                      ZEND_MM_SET_DEBUG_INFO(best_fit, size, 1, 0);
--      
+-
 +                      ZEND_MM_SET_DEBUG_INFO(best_fit, size, 1, 0);                           
 +#if SUHOSIN_PATCH
 +                        SUHOSIN_MM_SET_CANARIES(best_fit);