]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 8.2.8
authorMarcin Krol <hawk@tld-linux.org>
Mon, 10 Jul 2023 17:18:44 +0000 (19:18 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 10 Jul 2023 17:18:44 +0000 (19:18 +0200)
openssl.patch
php.spec

index 125637074a12c4df3745f8f64b8e1dcb1597f4ae..f6748f12f08d570264c879046667cb7f46f1dca2 100644 (file)
@@ -2,7 +2,7 @@ diff --git a/ext/openssl/xp_ssl.c b/ext/openssl/xp_ssl.c
 index 5564bf6f08..423f696c76 100644
 --- a/ext/openssl/xp_ssl.c
 +++ b/ext/openssl/xp_ssl.c
-@@ -1286,6 +1286,10 @@ static int php_openssl_set_server_specific_opts(php_stream *stream, SSL_CTX *ctx
+@@ -1349,6 +1349,10 @@ static int php_openssl_set_server_specif
        zval *zv;
        long ssl_ctx_options = SSL_CTX_get_options(ctx);
  
@@ -13,9 +13,9 @@ index 5564bf6f08..423f696c76 100644
  #if defined(HAVE_ECDH) && PHP_OPENSSL_API_VERSION < 0x10100
        if (php_openssl_set_server_ecdh_curve(stream, ctx) == FAILURE) {
                return FAILURE;
-@@ -1628,6 +1632,10 @@ int php_openssl_setup_crypto(php_stream *stream,
-       ssl_ctx_options = SSL_OP_ALL;
- #endif
+@@ -1686,6 +1690,10 @@ int php_openssl_setup_crypto(php_stream
+       method = sslsock->is_client ? SSLv23_client_method() : SSLv23_server_method();
+       sslsock->ctx = SSL_CTX_new(method);
  
 +#ifdef SSL_OP_IGNORE_UNEXPECTED_EOF
 +      ssl_ctx_options |= SSL_OP_IGNORE_UNEXPECTED_EOF;
index dc3051cc18282a36f5e494aa467ada7aa17a5505..3597740d4722e2c761333eeeea04f3349fa8d367 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -124,7 +124,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.2.7
+Version:       8.2.8
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -133,7 +133,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: e0b4a8b8e3c4d0891520424359c33127
+# Source0-md5: 6c28be716abf829779f009bc020a44fe
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini