]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- missed this one when TLDizing
authorMarcin Krol <hawk@tld-linux.org>
Mon, 15 Sep 2014 11:17:22 +0000 (11:17 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 15 Sep 2014 11:17:22 +0000 (11:17 +0000)
php.spec

index dbc89eb675571b5ddba559dce066e305b84730c7..a3681f98062188e324b3653a67bfdcbec93c2a79 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2626,8 +2626,15 @@ cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
 # versioned suffix is always installed
 libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php%{ver_suffix}
 cp -p sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/php%{ver_suffix}.1
+
+%if %{with default_php}
+# man for php
 echo ".so php%{ver_suffix}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
+# link as /usr/bin/php
 ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
+# php.cli link for backward compatibility
+ln -sf php $RPM_BUILD_ROOT%{_bindir}/php.cli
+%endif
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini