]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 5.6.35, fix libs problems
authorMarcin Krol <hawk@tld-linux.org>
Thu, 12 Apr 2018 11:30:01 +0000 (11:30 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 12 Apr 2018 11:30:01 +0000 (11:30 +0000)
fpm-conf-split.patch
php-mod_php.conf
php.spec

index 3d4bd92a238d65fc4d263c9e1e3f1014df9b1005..083fbf05e6698f23a9f0310b76b7b933a1e56a40 100644 (file)
@@ -1,5 +1,6 @@
---- php-5.6.5/sapi/fpm/php-fpm.conf.in~        2015-02-04 19:22:00.000000000 +0200
-+++ php-5.6.5/sapi/fpm/php-fpm.conf.in 2015-02-04 19:23:22.109298245 +0200
+diff -urNpa php-5.6.35.orig/sapi/fpm/php-fpm.conf.in php-5.6.35/sapi/fpm/php-fpm.conf.in
+--- php-5.6.35.orig/sapi/fpm/php-fpm.conf.in   2018-03-28 21:28:58.000000000 +0000
++++ php-5.6.35/sapi/fpm/php-fpm.conf.in        2018-04-12 10:03:34.184687949 +0000
 @@ -6,14 +6,6 @@
  ; prefix (@prefix@). This prefix can be dynamically changed by using the
  ; '-p' argument from the command line.
@@ -15,7 +16,7 @@
  ;;;;;;;;;;;;;;;;;;
  ; Global Options ;
  ;;;;;;;;;;;;;;;;;;
-@@ -115,415 +115,3 @@
+@@ -123,421 +115,3 @@
  ; ports and different management options.  The name of the pool will be
  ; used in logs and stats. There is no limitation on the number of pools which
  ; FPM can handle. Your system will tell you anyway :)
 -; Default Value: no set
 -; process.priority = -19
 -
+-; Set the process dumpable flag (PR_SET_DUMPABLE prctl) even if the process user
+-; or group is differrent than the master process user. It allows to create process
+-; core dump and ptrace the process for the pool user.
+-; Default Value: no
+-; process.dumpable = yes
+-
 -; Choose how the process manager will control the number of child processes.
 -; Possible Values:
 -;   static  - a fixed number (pm.max_children) of child processes;
 -;php_admin_value[error_log] = /var/log/fpm-php.www.log
 -;php_admin_flag[log_errors] = on
 -;php_admin_value[memory_limit] = 32M
---- /dev/null  2007-02-13 18:29:53.000000000 +0200
-+++ php-5.6.5/sapi/fpm/php-fpm.conf-d.in       2015-02-04 19:23:20.709225773 +0200
-@@ -0,0 +1,411 @@
+diff -urNpa php-5.6.35.orig/sapi/fpm/php-fpm.conf-d.in php-5.6.35/sapi/fpm/php-fpm.conf-d.in
+--- php-5.6.35.orig/sapi/fpm/php-fpm.conf-d.in 1970-01-01 00:00:00.000000000 +0000
++++ php-5.6.35/sapi/fpm/php-fpm.conf-d.in      2018-04-12 10:04:12.417687518 +0000
+@@ -0,0 +1,417 @@
 +; Start a new pool named 'www'.
 +; the variable $pool can we used in any directive and will be replaced by the
 +; pool name ('www' here)
 +; Default Value: no set
 +; process.priority = -19
 +
++; Set the process dumpable flag (PR_SET_DUMPABLE prctl) even if the process user
++; or group is differrent than the master process user. It allows to create process
++; core dump and ptrace the process for the pool user.
++; Default Value: no
++; process.dumpable = yes
++
 +; Choose how the process manager will control the number of child processes.
 +; Possible Values:
 +;   static  - a fixed number (pm.max_children) of child processes;
 +;php_admin_value[error_log] = /var/log/fpm-php.www.log
 +;php_admin_flag[log_errors] = on
 +;php_admin_value[memory_limit] = 32M
---- php-5.5.7/sapi/fpm/config.m4~      2013-12-16 17:57:03.000000000 +0200
-+++ php-5.5.7/sapi/fpm/config.m4       2013-12-16 18:00:34.936527309 +0200
-@@ -609,7 +609,7 @@
+diff -urNpa php-5.6.35.orig/sapi/fpm/config.m4 php-5.6.35/sapi/fpm/config.m4
+--- php-5.6.35.orig/sapi/fpm/config.m4 2018-03-28 21:28:58.000000000 +0000
++++ php-5.6.35/sapi/fpm/config.m4      2018-04-12 10:02:48.432688464 +0000
+@@ -667,7 +667,7 @@ if test "$PHP_FPM" != "no"; then
  
    PHP_ADD_BUILD_DIR(sapi/fpm/fpm)
    PHP_ADD_BUILD_DIR(sapi/fpm/fpm/events)
    PHP_ADD_MAKEFILE_FRAGMENT([$abs_srcdir/sapi/fpm/Makefile.frag])
  
    SAPI_FPM_PATH=sapi/fpm/php-fpm
---- php-5.6.2/sapi/fpm/Makefile.frag~  2014-10-15 15:59:32.000000000 +0300
-+++ php-5.6.2/sapi/fpm/Makefile.frag   2014-10-27 08:12:57.402883790 +0200
-@@ -11,8 +11,9 @@
+diff -urNpa php-5.6.35.orig/sapi/fpm/Makefile.frag php-5.6.35/sapi/fpm/Makefile.frag
+--- php-5.6.35.orig/sapi/fpm/Makefile.frag     2018-03-28 21:28:58.000000000 +0000
++++ php-5.6.35/sapi/fpm/Makefile.frag  2018-04-12 10:02:48.432688464 +0000
+@@ -11,8 +11,9 @@ install-fpm: $(SAPI_FPM_PATH)
        @$(INSTALL) -m 0755 $(SAPI_FPM_PATH) $(INSTALL_ROOT)$(sbindir)/$(program_prefix)php-fpm$(program_suffix)$(EXEEXT)
  
        @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
index a5f5f592dc5771496ad51bbc8bafd3ae5cfec4bf..056479779573e91f4a6b779614f785f66631f328 100644 (file)
@@ -1,4 +1,4 @@
-LoadModule php5_module modules/libphp5.so
+LoadModule php5_module modules/libphp56.so
 
 <IfModule mod_php5.c>
        <Files *.php>
index 9a0fb8817cb7ff5dffbae050adb78db7c6f222b5..71f0b4fcbfd0f87fcaa51498c10d23cb3e874947 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -148,8 +148,8 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.34
-Release:       2
+Version:       5.6.35
+Release:       0.1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -157,7 +157,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: dd28a659b88ad60797a7c102307f2edb
+# Source0-md5: 50afbbc745ad433b9f368c5885bd73bf
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -2430,7 +2430,6 @@ for sapi in $sapis; do
        cp -f main/php_config.h php_config.h.$sapi
        cp -f config.log config.log.$sapi
 done
-
 # as we build each SAPI in own make, adjust php-config.in forehead
 sapis=$(%{__sed} -rne 's/^PHP_INSTALLED_SAPIS = (.+)/\1/p' Makefile.* | tr ' ' '\n' | sort -u | xargs)
 %{__sed} -i -e "s,@PHP_INSTALLED_SAPIS@,$sapis," scripts/php-config.in
@@ -2752,6 +2751,9 @@ if [ $1 -eq 0 ]; then
        update-alternatives --remove php %{_bindir}/php || :
 fi
 
+%post  common -p /sbin/ldconfig
+%postun        common -p /sbin/ldconfig
+
 %post devel
 update-alternatives \
        --install %{_bindir}/phpize phpize %{_bindir}/phpize%{php_suffix} %{php_suffix} \