]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- remove unused patches
authorMarcin Krol <hawk@tld-linux.org>
Wed, 8 Feb 2017 14:11:38 +0000 (14:11 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 8 Feb 2017 14:11:38 +0000 (14:11 +0000)
php-imap-annotations.patch [deleted file]
php-imap-myrights.patch [deleted file]
php-mail.patch [deleted file]
php-mysql-ssl-context.patch [deleted file]
php.spec

diff --git a/php-imap-annotations.patch b/php-imap-annotations.patch
deleted file mode 100644 (file)
index d94dcbd..0000000
+++ /dev/null
@@ -1,305 +0,0 @@
-Provides get/set ANNOTATIONS support to PHP. [Version: 5.2.6]
-
-diff -r 76412c484360 ext/imap/php_imap.c
---- a/ext/imap/php_imap.c      Wed Dec 23 22:18:41 2009 +0100
-+++ b/ext/imap/php_imap.c      Wed Dec 23 22:46:34 2009 +0100
-@@ -161,6 +161,22 @@
-       ZEND_ARG_INFO(0, mailbox)
- ZEND_END_ARG_INFO()
- #endif
-+#if defined(HAVE_IMAP2005)
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_setannotation, 0, 0, 5)
-+      ZEND_ARG_INFO(0, stream_id)
-+      ZEND_ARG_INFO(0, mailbox)
-+      ZEND_ARG_INFO(0, entry)
-+      ZEND_ARG_INFO(0, attr)
-+      ZEND_ARG_INFO(0, value)
-+ZEND_END_ARG_INFO()
-+
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_getannotation, 0, 0, 4)
-+      ZEND_ARG_INFO(0, stream_id)
-+      ZEND_ARG_INFO(0, mailbox)
-+      ZEND_ARG_INFO(0, entry)
-+      ZEND_ARG_INFO(0, attr)
-+ZEND_END_ARG_INFO()
-+#endif
- ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_expunge, 0, 0, 1)
-       ZEND_ARG_INFO(0, stream_id)
-@@ -402,6 +418,11 @@
- ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_status, 0, 0, 3)
-       ZEND_ARG_INFO(0, stream_id)
-       ZEND_ARG_INFO(0, mailbox)
-+      ZEND_ARG_INFO(0, options)
-+ZEND_END_ARG_INFO()
-+
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_status_current, 0, 0, 2)
-+      ZEND_ARG_INFO(0, stream_id)
-       ZEND_ARG_INFO(0, options)
- ZEND_END_ARG_INFO()
-@@ -504,6 +525,7 @@
-       PHP_FE(imap_binary,                                                             arginfo_imap_binary)
-       PHP_FE(imap_utf8,                                                               arginfo_imap_utf8)
-       PHP_FE(imap_status,                                                             arginfo_imap_status)
-+      PHP_FE(imap_status_current,                                             arginfo_imap_status_current)
-       PHP_FE(imap_mailboxmsginfo,                                             arginfo_imap_mailboxmsginfo)
-       PHP_FE(imap_setflag_full,                                               arginfo_imap_setflag_full)
-       PHP_FE(imap_clearflag_full,                                             arginfo_imap_clearflag_full)
-@@ -534,6 +556,10 @@
-       PHP_FE(imap_setacl,                                                             arginfo_imap_setacl)
-       PHP_FE(imap_getacl,                                                             arginfo_imap_getacl)
- #endif
-+#if defined(HAVE_IMAP2005)
-+      PHP_FE(imap_setannotation,                                              arginfo_imap_setannotation)
-+      PHP_FE(imap_getannotation,                                              arginfo_imap_getannotation)
-+#endif
-       PHP_FE(imap_mail,                                                               arginfo_imap_mail)
-@@ -795,6 +821,30 @@
- /* }}} */
- #endif
-+#if defined(HAVE_IMAP2005)
-+/* {{{ mail_getannotation
-+ *
-+ * Mail GET_ANNOTATION callback
-+ * Called via the mail_parameter function in c-client:src/c-client/mail.c
-+ */
-+void mail_getannotation(MAILSTREAM *stream, ANNOTATION *alist)
-+{
-+        ANNOTATION_VALUES *cur;
-+        
-+      TSRMLS_FETCH();
-+
-+      /* walk through the ANNOTATION_VALUES */
-+        
-+      for(cur = alist->values; cur; cur = cur->next) {
-+          if (cur->value)
-+              add_assoc_stringl(IMAPG(imap_annotation_list), cur->attr, cur->value, strlen(cur->value), 1);
-+          else
-+              add_assoc_stringl(IMAPG(imap_annotation_list), cur->attr, "", 0, 1);
-+      }
-+}
-+/* }}} */
-+#endif
-+
- /* {{{ PHP_GINIT_FUNCTION
-  */
- static PHP_GINIT_FUNCTION(imap)
-@@ -820,6 +870,7 @@
- #if defined(HAVE_IMAP2000) || defined(HAVE_IMAP2001)
-       imap_globals->quota_return = NIL;
-       imap_globals->imap_acl_list = NIL;
-+      imap_globals->imap_annotation_list = NIL;
- #endif
-       imap_globals->gets_stream = NIL;
- }
-@@ -1475,7 +1526,119 @@
- }
- /* }}} */
- #endif /* HAVE_IMAP2000 || HAVE_IMAP2001 */
--
-+ 
-+#if defined(HAVE_IMAP2005)
-+
-+/* {{{ proto bool imap_setannotation(resource stream_id, string mailbox, string entry, string attr, string value)
-+      Sets an annotation for a given mailbox */
-+PHP_FUNCTION(imap_setannotation)
-+{
-+      zval **streamind, **mailbox, **entry, **attr, **value;
-+      pils *imap_le_struct;
-+        long ret;
-+      
-+        // TODO: Use zend_parse_parameters here
-+      if (ZEND_NUM_ARGS() != 5 || zend_get_parameters_ex(5, &streamind, &mailbox, &entry, &attr, &value) == FAILURE) {
-+              ZEND_WRONG_PARAM_COUNT();
-+      }
-+
-+      ZEND_FETCH_RESOURCE(imap_le_struct, pils *, streamind, -1, "imap", le_imap);
-+
-+      convert_to_string_ex(mailbox);
-+      convert_to_string_ex(entry);
-+      convert_to_string_ex(attr);
-+      convert_to_string_ex(value);
-+
-+        // create annotation object
-+        ANNOTATION *annotation = mail_newannotation();
-+        if (!annotation)
-+            RETURN_FALSE;
-+        annotation->values = mail_newannotationvalue();
-+        if (!annotation->values) {
-+            mail_free_annotation(&annotation);
-+            RETURN_FALSE;
-+        }
-+        
-+        // fill in annotation values
-+        annotation->mbox = Z_STRVAL_PP(mailbox);
-+        annotation->entry = Z_STRVAL_PP(entry);
-+        annotation->values->attr = Z_STRVAL_PP(attr);
-+        annotation->values->value = Z_STRVAL_PP(value);
-+        
-+        ret = imap_setannotation(imap_le_struct->imap_stream, annotation);
-+                
-+        // make sure mail_free_annotation doesn't free our variables
-+        annotation->mbox = NULL;
-+        annotation->entry = NULL;
-+        annotation->values->attr = NULL;
-+        annotation->values->value = NULL;
-+        mail_free_annotation(&annotation);
-+        
-+        RETURN_BOOL(ret);
-+}
-+/* }}} */
-+
-+/* {{{ proto array imap_getannotation(resource stream_id, string mailbox, string entry, string attr)
-+      Gets the ACL for a given mailbox */
-+PHP_FUNCTION(imap_getannotation)
-+{
-+      zval **streamind, **mailbox, **entry, **attr;
-+      pils *imap_le_struct;
-+        long ret;
-+
-+      if(ZEND_NUM_ARGS() != 4 || zend_get_parameters_ex(4, &streamind, &mailbox, &entry, &attr) == FAILURE) {
-+              ZEND_WRONG_PARAM_COUNT();
-+      }
-+
-+      ZEND_FETCH_RESOURCE(imap_le_struct, pils *, streamind, -1, "imap", le_imap);
-+
-+      convert_to_string_ex(mailbox);
-+      convert_to_string_ex(entry);
-+      convert_to_string_ex(attr);
-+
-+      /* initializing the special array for the return values */
-+      if (array_init(return_value) == FAILURE) {
-+              RETURN_FALSE;
-+      }
-+
-+        // fillup calling parameters
-+        STRINGLIST *entries = mail_newstringlist();
-+        if (!entries)
-+            RETURN_FALSE;
-+        
-+        STRINGLIST *cur = entries;
-+        cur->text.data = (unsigned char *)cpystr(Z_STRVAL_PP(entry));
-+        cur->text.size = Z_STRLEN_PP(entry);
-+        cur->next = NIL;
-+        
-+        STRINGLIST *attributes = mail_newstringlist();
-+        if (!attributes)
-+            RETURN_FALSE;
-+        cur = attributes;
-+        cur->text.data = (unsigned char *)cpystr (Z_STRVAL_PP(attr));
-+        cur->text.size = Z_STRLEN_PP(attr);
-+        cur->next = NIL;
-+        
-+        IMAPG(imap_annotation_list) = return_value;
-+        
-+        /* set the callback for the GET_ANNOTATION function */
-+      mail_parameters(NIL, SET_ANNOTATION, (void *) mail_getannotation);
-+        ret = imap_getannotation(imap_le_struct->imap_stream, Z_STRVAL_PP(mailbox), entries, attributes);
-+        
-+        mail_free_stringlist(&entries);
-+        mail_free_stringlist(&attributes);
-+        
-+        if (!ret) {
-+            zval_dtor(return_value);
-+            RETURN_FALSE;
-+        }
-+        
-+      IMAPG(imap_annotation_list) = NIL;
-+}
-+/* }}} */
-+
-+#endif /* HAVE_IMAP2005 */
-+ 
- /* {{{ proto bool imap_expunge(resource stream_id)
-    Permanently delete all messages marked for deletion */
- PHP_FUNCTION(imap_expunge)
-@@ -3118,6 +3281,42 @@
- }
- /* }}} */
-+/* {{{ proto object imap_status_current(resource stream_id, int options)
-+   Get (cached) status info from current mailbox */
-+PHP_FUNCTION(imap_status_current)
-+{
-+      zval **streamind, **pflags;
-+      pils *imap_le_struct;
-+      long flags = 0L;
-+
-+      if (ZEND_NUM_ARGS() != 2 || zend_get_parameters_ex(2, &streamind, &pflags) == FAILURE) {
-+              ZEND_WRONG_PARAM_COUNT();
-+      }
-+
-+      ZEND_FETCH_RESOURCE(imap_le_struct, pils *, streamind, -1, "imap", le_imap);
-+
-+      convert_to_long_ex(pflags);
-+      flags = Z_LVAL_PP(pflags);
-+
-+      if (object_init(return_value) == FAILURE) {
-+              RETURN_FALSE;
-+      }
-+
-+      if (flags & SA_MESSAGES) {
-+              add_property_long(return_value, "messages", imap_le_struct->imap_stream->nmsgs);
-+      }
-+      if (flags & SA_RECENT) {
-+              add_property_long(return_value, "recent", imap_le_struct->imap_stream->recent);
-+      }
-+      if (flags & SA_UIDNEXT) {
-+              add_property_long(return_value, "uidnext", imap_le_struct->imap_stream->uid_last+1);
-+      }
-+      if (flags & SA_UIDVALIDITY) {
-+              add_property_long(return_value, "uidvalidity", imap_le_struct->imap_stream->uid_validity);
-+      }
-+}
-+/* }}} */
-+
- /* {{{ proto object imap_status(resource stream_id, string mailbox, int options)
-    Get status info from a mailbox */
- PHP_FUNCTION(imap_status)
-diff -r 76412c484360 ext/imap/php_imap.h
---- a/ext/imap/php_imap.h      Wed Dec 23 22:18:41 2009 +0100
-+++ b/ext/imap/php_imap.h      Wed Dec 23 22:46:34 2009 +0100
-@@ -153,6 +153,7 @@
- PHP_FUNCTION(imap_lsub_full);
- PHP_FUNCTION(imap_create);
- PHP_FUNCTION(imap_rename);
-+PHP_FUNCTION(imap_status_current);
- PHP_FUNCTION(imap_status);
- PHP_FUNCTION(imap_bodystruct);
- PHP_FUNCTION(imap_fetch_overview);
-@@ -173,6 +174,9 @@
- PHP_FUNCTION(imap_thread);
- PHP_FUNCTION(imap_timeout);
-+// TODO: Needs fixing in configure in
-+#define HAVE_IMAP2005 1
-+
- #if defined(HAVE_IMAP2000) || defined(HAVE_IMAP2001)
- PHP_FUNCTION(imap_get_quota);
- PHP_FUNCTION(imap_get_quotaroot);
-@@ -180,7 +184,10 @@
- PHP_FUNCTION(imap_setacl);
- PHP_FUNCTION(imap_getacl);
- #endif
--
-+#if defined(HAVE_IMAP2005)
-+PHP_FUNCTION(imap_setannotation);
-+PHP_FUNCTION(imap_getannotation);
-+#endif
- ZEND_BEGIN_MODULE_GLOBALS(imap)
-       char *imap_user;
-@@ -211,6 +218,9 @@
-       zval **quota_return;
-       zval *imap_acl_list;
- #endif
-+#if defined(HAVE_IMAP2005)
-+        zval *imap_annotation_list;
-+#endif
-       /* php_stream for php_mail_gets() */
-       php_stream *gets_stream;
- ZEND_END_MODULE_GLOBALS(imap)
diff --git a/php-imap-myrights.patch b/php-imap-myrights.patch
deleted file mode 100644 (file)
index ddadbd3..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-diff -r 5daa8cce8706 ext/imap/php_imap.c
---- a/ext/imap/php_imap.c      Wed Dec 23 22:46:34 2009 +0100
-+++ b/ext/imap/php_imap.c      Wed Dec 23 22:49:02 2009 +0100
-@@ -157,6 +157,11 @@
- ZEND_END_ARG_INFO()
- ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_getacl, 0, 0, 2)
-+      ZEND_ARG_INFO(0, stream_id)
-+      ZEND_ARG_INFO(0, mailbox)
-+ZEND_END_ARG_INFO()
-+
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_imap_myrights, 0, 0, 2)
-       ZEND_ARG_INFO(0, stream_id)
-       ZEND_ARG_INFO(0, mailbox)
- ZEND_END_ARG_INFO()
-@@ -555,6 +560,7 @@
-       PHP_FE(imap_set_quota,                                                  arginfo_imap_set_quota)
-       PHP_FE(imap_setacl,                                                             arginfo_imap_setacl)
-       PHP_FE(imap_getacl,                                                             arginfo_imap_getacl)
-+      PHP_FE(imap_myrights,                                                   arginfo_imap_myrights)
- #endif
- #if defined(HAVE_IMAP2005)
-       PHP_FE(imap_setannotation,                                              arginfo_imap_setannotation)
-@@ -817,6 +823,20 @@
-       for(; alist; alist = alist->next) {
-               add_assoc_stringl(IMAPG(imap_acl_list), alist->identifier, alist->rights, strlen(alist->rights), 1);
-       }
-+}
-+/* }}} */
-+
-+/* {{{ mail_myrights
-+ *
-+ * Mail MYRIGHTS callback
-+ * Called via the mail_parameter function in c-client:src/c-client/mail.c
-+ */
-+void mail_myrights(MAILSTREAM *stream, char *mailbox, char *rights)
-+{
-+      TSRMLS_FETCH();
-+
-+      ZVAL_STRING(IMAPG(imap_acl_list), rights, 1)
-+
- }
- /* }}} */
- #endif
-@@ -1525,6 +1545,36 @@
-       IMAPG(imap_acl_list) = NIL;
- }
- /* }}} */
-+
-+/* {{{ proto string imap_myrights(resource stream_id, string mailbox)
-+      Gets my rights (ACL) for a given mailbox */
-+PHP_FUNCTION(imap_myrights)
-+{
-+      zval **streamind, **mailbox;
-+      pils *imap_le_struct;
-+
-+      if(ZEND_NUM_ARGS() != 2 || zend_get_parameters_ex(2, &streamind, &mailbox) == FAILURE) {
-+              ZEND_WRONG_PARAM_COUNT();
-+      }
-+
-+      ZEND_FETCH_RESOURCE(imap_le_struct, pils *, streamind, -1, "imap", le_imap);
-+
-+      convert_to_string_ex(mailbox);
-+
-+      IMAPG(imap_acl_list) = return_value;
-+
-+      /* set the callback for the GET_ACL function */
-+      mail_parameters(NIL, SET_MYRIGHTS, (void *) mail_myrights);
-+      if(!imap_myrights(imap_le_struct->imap_stream, Z_STRVAL_PP(mailbox))) {
-+              php_error(E_WARNING, "c-client imap_myrights failed");
-+              zval_dtor(return_value);
-+              RETURN_FALSE;
-+      }
-+
-+      IMAPG(imap_acl_list) = NIL;
-+}
-+/* }}} */
-+
- #endif /* HAVE_IMAP2000 || HAVE_IMAP2001 */
-  
- #if defined(HAVE_IMAP2005)
-diff -r 5daa8cce8706 ext/imap/php_imap.h
---- a/ext/imap/php_imap.h      Wed Dec 23 22:46:34 2009 +0100
-+++ b/ext/imap/php_imap.h      Wed Dec 23 22:49:02 2009 +0100
-@@ -183,6 +183,7 @@
- PHP_FUNCTION(imap_set_quota);
- PHP_FUNCTION(imap_setacl);
- PHP_FUNCTION(imap_getacl);
-+PHP_FUNCTION(imap_myrights);
- #endif
- #if defined(HAVE_IMAP2005)
- PHP_FUNCTION(imap_setannotation);
diff --git a/php-mail.patch b/php-mail.patch
deleted file mode 100644 (file)
index e541727..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
---- php-5.2.0/ext/standard/mail.c      2006-12-01 14:20:27.881416250 +0100
-+++ php-5.2.4/ext/standard/mail.c      2007-08-31 19:25:50.777713042 +0300
-@@ -35,6 +37,8 @@
- #include "php_ini.h"
- #include "safe_mode.h"
- #include "exec.h"
-+#include "zend_operators.h"
-+#include "zend_globals.h"
- #ifdef PHP_WIN32
- #include "win32/sendmail.h"
-@@ -107,6 +111,18 @@
-               return;
-       }
-+    /* search for To: and Subject: headers which should be specified in proper mail() parameters, not in additional headers */
-+    if (headers != NULL) {
-+        if (strncasecmp(headers, "to:", sizeof("to:") - 1) == 0 || strcasestr(headers, "\nto:")) {
-+            php_error_docref(NULL TSRMLS_CC, E_WARNING, "To: headers aren't allowed in the additional_headers parameter. Use $to parameter for that. Mail not sent.");
-+            RETURN_FALSE;
-+        }
-+        if (strncasecmp(headers, "subject:", sizeof("subject:") - 1) == 0 || strcasestr(headers, "\nsubject:")) {
-+            php_error_docref(NULL TSRMLS_CC, E_WARNING, "Subject: headers aren't allowed in the additional_headers parameter. Use $subject parameter for that. Mail not sent.");
-+            RETURN_FALSE;
-+        }
-+    }
-+
-       if (to_len > 0) {
-               to_r = estrndup(to, to_len);
-               for (; to_len; to_len--) {
-@@ -231,8 +247,42 @@
-                       return 0;
-               }
- #endif
--              fprintf(sendmail, "To: %s\n", to);
--              fprintf(sendmail, "Subject: %s\n", subject);
-+              TSRMLS_FETCH();
-+
-+              if ((to != NULL) && (strlen(to)!=0)) {
-+                      fprintf(sendmail, "To: %s\n", to);
-+              }
-+              if ((subject != NULL) && (strlen(subject)!=0)) {
-+                      fprintf(sendmail, "Subject: %s\n", subject);
-+              }
-+              zend_is_auto_global(ZEND_STRL("_SERVER") TSRMLS_CC);
-+              if (PG(http_globals)[TRACK_VARS_SERVER]) {
-+                      zval **remote_addr, **server_name, **server_port,
-+                              **script_name, **http_user_agent;
-+
-+                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "REMOTE_ADDR", sizeof("REMOTE_ADDR"), (void **) &remote_addr)==SUCCESS) {
-+                              convert_to_string_ex(remote_addr);
-+                              fprintf(sendmail, "HTTP-Posting-Client: %s\n", Z_STRVAL_PP(remote_addr));
-+                      }
-+                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SERVER_NAME", sizeof("SERVER_NAME"), (void **) &server_name)==SUCCESS) {
-+                              convert_to_string_ex(server_name);
-+                              fprintf(sendmail, "HTTP-Posting-URI: %s", Z_STRVAL_PP(server_name));
-+                              if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SERVER_PORT", sizeof("SERVER_PORT"), (void **) &server_port)==SUCCESS) {
-+                                      convert_to_string_ex(server_port);
-+                                      fprintf(sendmail, ":%s", Z_STRVAL_PP(server_port));
-+                              }
-+                              if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SCRIPT_NAME", sizeof("SCRIPT_NAME"), (void **) &script_name)==SUCCESS) {
-+                                      convert_to_string_ex(script_name);
-+                                      fprintf(sendmail, "%s", Z_STRVAL_PP(script_name));
-+                              }
-+                              fprintf(sendmail, "\n");
-+                      }
-+                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "HTTP_USER_AGENT", sizeof("HTTP_USER_AGENT"), (void **) &http_user_agent)==SUCCESS) {
-+                              convert_to_string_ex(http_user_agent);
-+                                      fprintf(sendmail, "HTTP-Posting-User-Agent: %s\n", Z_STRVAL_PP(http_user_agent));
-+                      }
-+              }
-+
-               if (hdr != NULL) {
-                       fprintf(sendmail, "%s\n", hdr);
-               }
diff --git a/php-mysql-ssl-context.patch b/php-mysql-ssl-context.patch
deleted file mode 100644 (file)
index c8ff48d..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-; obey default context options
-; https://bugs.php.net/bug.php?id=68344
-diff -urbB php-5.6.12/ext/mysqlnd/mysqlnd_net.c php-5.6.12/ext/mysqlnd/mysqlnd_net.c
---- php-5.6.12/ext/mysqlnd/mysqlnd_net.c       2015-08-06 09:55:57.000000000 +0200
-+++ php-5.6.12/ext/mysqlnd/mysqlnd_net.c       2015-08-10 13:25:30.187912101 +0200
-@@ -29,6 +29,7 @@
- #include "mysqlnd_ext_plugin.h"
- #include "php_network.h"
- #include "zend_ini.h"
-+#include "ext/standard/file.h"
- #ifdef MYSQLND_COMPRESSION_ENABLED
- #include <zlib.h>
- #endif
-@@ -868,6 +868,21 @@ MYSQLND_METHOD(mysqlnd_net, enable_ssl)(
-               DBG_RETURN(FAIL);
-       }
-+      if (FG(default_context)) {
-+              zval **tmpzval = NULL;
-+              int i = 0;
-+              /* copy values from default stream settings */
-+              char *opts[] = { "allow_self_signed", "cafile", "capath", "ciphers", "CN_match",
-+                      "disable_compression", "local_cert", "local_pk", "no_ticket", "passphrase",
-+                      "peer_fingerprint", "peer_name", "SNI_enabled", "SNI_server_certs", "SNI_server_name",
-+                      "verify_depth", "verify_peer", "verify_peer_name", NULL };
-+              while (opts[i]) {
-+                      if (php_stream_context_get_option(FG(default_context), "ssl", opts[i], &tmpzval) == SUCCESS)
-+                              php_stream_context_set_option(context, "ssl", opts[i], *tmpzval);
-+                      i++;
-+              }
-+      }
-+
-       if (net->data->options.ssl_key) {
-               zval key_zval;
-               ZVAL_STRING(&key_zval, net->data->options.ssl_key, 0);
-
index 11db9539a9322e9c815b19c953e3dfe8a8bd02e7..cadf8afef6ad4bb407fff319f4649006887ec436 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -163,7 +163,6 @@ Source13:   dep-tests.sh
 Source14:      skip-tests.sh
 Patch0:                %{orgname}-shared.patch
 Patch1:                %{orgname}-tld.patch
-Patch2:                %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
 Patch5:                %{orgname}-filter-shared.patch
@@ -193,8 +192,6 @@ Patch41:    %{orgname}-fpm-config.patch
 Patch42:       %{orgname}-fpm-shared.patch
 Patch43:       %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
-Patch45:       %{orgname}-imap-annotations.patch
-Patch46:       %{orgname}-imap-myrights.patch
 Patch47:       suhosin.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
@@ -207,8 +204,6 @@ Patch62:    mcrypt-libs.patch
 Patch65:       system-libzip.patch
 Patch66:       php-db.patch
 Patch67:       mysql-lib-ver-mismatch.patch
-# https://bugs.php.net/bug.php?id=68344
-Patch68:       php-mysql-ssl-context.patch
 Patch69:       fpm-conf-split.patch
 Patch70:       mysqlnd-ssl.patch
 Patch71:       libdb-info.patch
@@ -1930,7 +1925,6 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
-#%patch2 -p1
 %patch3 -p1
 %patch5 -p1
 %patch6 -p1
@@ -1960,8 +1954,6 @@ cp -p php.ini-production php.ini
 %endif
 %patch43 -p1
 %patch44 -p1
-#%patch45 -p1 # imap annotations. fixme
-#%patch46 -p1 # imap myrights. fixme
 %if %{with suhosin}
 %patch47 -p1
 %endif
@@ -1977,7 +1969,6 @@ cp -p php.ini-production php.ini
 %{?with_system_libzip:%patch65 -p1}
 %patch66 -p1
 %patch67 -p1
-#%patch68 -p1
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1