]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- fix ext_skel file conflict, fix man pages alternatives
authorMarcin Krol <hawk@tld-linux.org>
Mon, 13 Jun 2022 16:06:43 +0000 (18:06 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 13 Jun 2022 16:06:43 +0000 (18:06 +0200)
php.spec

index 58a8454aeb5a163bd52b16c55903920a8559c32e..6c9ac2bbfcc9f107a424527c990e7e94116da495 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -126,7 +126,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.4.30
-Release:       2
+Release:       3
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -1856,7 +1856,7 @@ cp -p php.ini-production php.ini
 %patch71 -p1
 %patch72 -p1
 
-sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{_bindir}/\1%{php_suffix},' \
       ext/ext_skel.php \
       run-tests.php
 
@@ -2496,7 +2496,7 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common%{php_suffix}.la
 
-install -p ext/ext_skel.php $RPM_BUILD_ROOT%{_bindir}
+install -p ext/ext_skel.php $RPM_BUILD_ROOT%{_bindir}/ext_skel%{php_suffix}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -2514,7 +2514,7 @@ fi
 %post cli
 update-alternatives \
        --install %{_bindir}/php php %{_bindir}/php%{php_suffix} %{php_suffix} \
-       --slave %{_mandir}/man1/php.1 php.1 %{_mandir}/man1/php%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/php.1.gz php.1.gz %{_mandir}/man1/php%{php_suffix}.1.gz || :
 
 %postun cli
 if [ $1 -eq 0 ]; then
@@ -2527,10 +2527,12 @@ fi
 %post devel
 update-alternatives \
        --install %{_bindir}/phpize phpize %{_bindir}/phpize%{php_suffix} %{php_suffix} \
-       --slave %{_mandir}/man1/php.1 php.1 %{_mandir}/man1/php%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/phpize.1.gz phpize.1.gz %{_mandir}/man1/phpize%{php_suffix}.1.gz || :
 update-alternatives \
        --install %{_bindir}/php-config php-config %{_bindir}/php-config%{php_suffix} %{php_suffix} \
-       --slave %{_mandir}/man1/php.1 php.1 %{_mandir}/man1/php%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/php-config.1.gz php-config.1.gz %{_mandir}/man1/php-config%{php_suffix}.1.gz || :
+update-alternatives \
+       --install %{_bindir}/ext_skel ext_skel %{_bindir}/ext_skel%{php_suffix} %{php_suffix} || :
 
 %postun devel
 if [ $1 -eq 0 ]; then
@@ -2544,7 +2546,9 @@ fi
 %post fpm
 /sbin/chkconfig --add %{name}-fpm
 %service %{name}-fpm restart
-update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_suffix}-fpm %{php_suffix} || :
+update-alternatives \
+       --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_suffix}-fpm %{php_suffix} \
+       --slave %{_mandir}/man8/php-fpm.8.gz php-fpm.8.gz %{_mandir}/man8/php-fpm%{php_suffix}.8.gz || :
 
 %preun fpm
 if [ "$1" = "0" ]; then
@@ -2701,7 +2705,7 @@ fi \
 %ext_post
 update-alternatives \
        --install %{_bindir}/phar phar %{_bindir}/phar%{php_suffix}.phar %{php_suffix} \
-       --slave %{_mandir}/man1/phar.1 phar.1 %{_mandir}/man1/phar%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/phar.1.gz phar.1.gz %{_mandir}/man1/phar%{php_suffix}.1.gz || :
 
 %postun phar
 %ext_postun
@@ -2788,7 +2792,7 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %doc CODING_STANDARDS.md docs/*.md
-%attr(755,root,root) %{_bindir}/ext_skel.php
+%attr(755,root,root) %{_bindir}/ext_skel%{php_suffix}
 %attr(755,root,root) %{_bindir}/phpize%{php_suffix}
 %attr(755,root,root) %{_bindir}/php-config%{php_suffix}
 %ghost %{_bindir}/phpize