]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 7.1.13
authorMarcin Krol <hawk@tld-linux.org>
Fri, 12 Jan 2018 15:00:43 +0000 (15:00 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Fri, 12 Jan 2018 15:00:43 +0000 (15:00 +0000)
php.spec

index 5f4e66aac58f7229ecd0253d3da7774a663210c1..9082ae539109831206225b26eab164e305a7489a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -142,7 +142,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.1.11
+Version:       7.1.13
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -151,7 +151,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: bbf4dfe4f501143a1763eb86b6a0a454
+# Source0-md5: 86ea87c65d879b8684040fe19a5fba5d
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -294,13 +294,13 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # Extension versions
 %define                bz2ver          1.0
-%define                enchantver      1.1.0
+%define                enchantver      %{version}
 %define                fileinfover     1.0.5
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.5.0
 %define                pharver         2.0.2
-%define                sqlite3ver      0.7-dev
+%define                sqlite3ver      %{version}
 %define                zipver          1.13.5
 %define                phpdbgver       0.5.0
 
@@ -2113,8 +2113,6 @@ if test "$ver" != "%{pharver}"; then
 fi
 ver=$(awk '/#define PHP_SQLITE3_VERSION/ {print $3}' ext/sqlite3/php_sqlite3.h | xargs)
 if test "$ver" != "PHP_VERSION"; then
-       : Error: Upstream Sqlite3 version is now ${ver}, expecting %{sqlite3ver}.
-       : Update the sqlite3ver macro and rebuild.
        exit 1
 fi
 ver=$(sed -n '/#define PHP_ZIP_VERSION /{s/.* "//;s/".*$//;p}' ext/zip/php_zip.h)
@@ -2141,10 +2139,8 @@ if test "$ver" != "%{bz2ver}"; then
        : Update the bz2ver macro and rebuild.
        exit 1
 fi
-ver=$(sed -n '/#define PHP_ENCHANT_VERSION /{s/.* "//;s/".*$//;p}' ext/enchant/php_enchant.h)
-if test "$ver" != "%{enchantver}"; then
-       : Error: Upstream Enchant version is now ${ver}, expecting %{enchantver}.
-       : Update the enchantver macro and rebuild.
+ver=$(awk '/#define PHP_ENCHANT_VERSION/ {print $3}' ext/enchant/php_enchant.h | xargs)
+if test "$ver" != "PHP_VERSION"; then
        exit 1
 fi
 ver=$(awk '/#define PHP_HASH_VERSION/ {print $3}' ext/hash/php_hash.h | xargs)