]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 7.3.12
authorMarcin Krol <hawk@tld-linux.org>
Thu, 12 Dec 2019 20:53:51 +0000 (21:53 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 12 Dec 2019 20:53:51 +0000 (21:53 +0100)
pcre-shared.patch
php.spec

index 384b23d25075650dd2aae0abded79db0767527ce..c1b2627e27b3fa4c1a3c80e3d8874baf507e72c5 100644 (file)
@@ -1,5 +1,6 @@
---- php-7.3.0RC5/ext/pcre/config0.m4~  2018-11-06 12:22:53.000000000 +0200
-+++ php-7.3.0RC5/ext/pcre/config0.m4   2018-11-12 13:30:52.805036671 +0200
+diff -urN php-7.3.12.orig/ext/pcre/config0.m4 php-7.3.12/ext/pcre/config0.m4
+--- php-7.3.12.orig/ext/pcre/config0.m4        2019-12-12 21:43:24.775000000 +0100
++++ php-7.3.12/ext/pcre/config0.m4     2019-12-12 21:43:36.336000000 +0100
 @@ -84,8 +84,9 @@
        ])
      fi
    else
      AC_MSG_CHECKING([for PCRE library to use])
      AC_MSG_RESULT([bundled])
---- php-7.3.0alpha3/ext/pcre/php_pcre.h~       2018-07-03 15:56:43.000000000 +0300
-+++ php-7.3.0alpha3/ext/pcre/php_pcre.h        2018-07-10 11:11:55.739017013 +0300
-@@ -33,7 +33,29 @@
+diff -urN php-7.3.12.orig/ext/pcre/php_pcre.c php-7.3.12/ext/pcre/php_pcre.c
+--- php-7.3.12.orig/ext/pcre/php_pcre.c        2019-12-12 21:43:24.775000000 +0100
++++ php-7.3.12/ext/pcre/php_pcre.c     2019-12-12 21:43:36.339000000 +0100
+@@ -19,6 +19,9 @@
+ #include "php.h"
+ #include "php_ini.h"
+ #include "php_globals.h"
++#if COMPILE_DL_PCRE
++#define COMPILE_DL_PCRE_NOREDIRECT
++#endif
+ #include "php_pcre.h"
+ #include "ext/standard/info.h"
+ #include "ext/standard/basic_functions.h"
+@@ -290,6 +293,17 @@
+               pcre2_set_match_limit(mctx, (uint32_t)PCRE_G(backtrack_limit));
+       }
++#if COMPILE_DL_PCRE
++      pcre_get_compiled_regex_p = pcre_get_compiled_regex;
++      pcre_get_compiled_regex_cache_p = pcre_get_compiled_regex_cache;
++      php_pcre_replace_impl_p = php_pcre_replace_impl;
++      php_pcre_match_impl_p = php_pcre_match_impl;
++      php_pcre_split_impl_p = php_pcre_split_impl;
++      php_pcre_create_match_data_p = php_pcre_create_match_data;
++      php_pcre_free_match_data_p = php_pcre_free_match_data;
++      php_pcre_mctx_p = php_pcre_mctx;
++#endif
++
+       return SUCCESS;
+ }/*}}}*/
+diff -urN php-7.3.12.orig/ext/pcre/php_pcre.h php-7.3.12/ext/pcre/php_pcre.h
+--- php-7.3.12.orig/ext/pcre/php_pcre.h        2019-12-12 21:43:24.777000000 +0100
++++ php-7.3.12/ext/pcre/php_pcre.h     2019-12-12 21:45:10.506000000 +0100
+@@ -31,7 +31,35 @@
  #include <locale.h>
  #endif
  
@@ -23,6 +56,9 @@
 +#define php_pcre_replace_impl (*php_pcre_replace_impl_p)
 +#define php_pcre_match_impl (*php_pcre_match_impl_p)
 +#define php_pcre_split_impl (*php_pcre_split_impl_p)
++#define php_pcre_create_match_data (*php_pcre_create_match_data_p)
++#define php_pcre_free_match_data (*php_pcre_free_match_data_p)
++#define php_pcre_mctx (*php_pcre_mctx_p)
 +#if !defined(COMPILE_DL_PCRE_NOEXTERN)
 +#     define PCRE_EXTERN extern
 +#else
@@ -36,6 +72,9 @@
 +extern void *php_pcre_replace_impl_p;
 +extern void *php_pcre_match_impl_p;
 +extern void *php_pcre_split_impl_p;
++extern void *php_pcre_create_match_data_p;
++extern void *php_pcre_free_match_data_p;
++extern void *php_pcre_mctx_p;
 +#endif
 +
  PHPAPI zend_string *php_pcre_replace(zend_string *regex, zend_string *subject_str, char *subject, size_t subject_len, zend_string *replace_str, size_t limit, size_t *replace_count);
  PHPAPI pcre2_code* pcre_get_compiled_regex(zend_string *regex, uint32_t *capture_count, uint32_t *options);
  PHPAPI pcre2_code* pcre_get_compiled_regex_ex(zend_string *regex, uint32_t *capture_count, uint32_t *preg_options, uint32_t *coptions);
  
-@@ -45,14 +67,18 @@
+@@ -43,21 +71,26 @@
  
  typedef struct _pcre_cache_entry pcre_cache_entry;
  
 +PCRE_EXTERN
  PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache(zend_string *regex);
+ PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache_ex(zend_string *regex, int locale_aware);
  
 +PCRE_EXTERN
  PHPAPI void  php_pcre_match_impl(  pcre_cache_entry *pce, char *subject, size_t subject_len, zval *return_value,
  PHPAPI void  php_pcre_split_impl(  pcre_cache_entry *pce, zend_string *subject_str, zval *return_value,
        zend_long limit_val, zend_long flags);
  
---- php-7.3.0beta3/ext/pcre/php_pcre.c~        2018-09-11 11:43:27.000000000 +0300
-+++ php-7.3.0beta3/ext/pcre/php_pcre.c 2018-09-11 11:43:30.747506034 +0300
-@@ -21,6 +21,9 @@
- #include "php.h"
- #include "php_ini.h"
- #include "php_globals.h"
-+#if COMPILE_DL_PCRE
-+#define COMPILE_DL_PCRE_NOREDIRECT
-+#endif
- #include "php_pcre.h"
- #include "ext/standard/info.h"
- #include "ext/standard/basic_functions.h"
-@@ -208,6 +211,17 @@
-       REGISTER_LONG_CONSTANT("PREG_JIT_STACKLIMIT_ERROR", PHP_PCRE_JIT_STACKLIMIT_ERROR, CONST_CS | CONST_PERSISTENT);
-       REGISTER_STRING_CONSTANT("PCRE_VERSION", (char *)pcre_version(), CONST_CS | CONST_PERSISTENT);
+ PHPAPI void  php_pcre_grep_impl(   pcre_cache_entry *pce, zval *input, zval *return_value,
+       zend_long flags);
  
-+#if COMPILE_DL_PCRE
-+      pcre_get_compiled_regex_p = pcre_get_compiled_regex;
-+      pcre_get_compiled_regex_cache_p = pcre_get_compiled_regex_cache;
-+      php_pcre_replace_impl_p = php_pcre_replace_impl;
-+      php_pcre_match_impl_p = php_pcre_match_impl;
-+      php_pcre_split_impl_p = php_pcre_split_impl;
-+      php_pcre_create_match_data_p = php_pcre_create_match_data;
-+      php_pcre_free_match_data_p = php_pcre_free_match_data;
-+      php_pcre_mctx_p = php_pcre_mctx;
-+#endif
-+
-       return SUCCESS;
- }
- /* }}} */
---- php-7.2.0RC5/ext/standard/basic_functions.c        2017-10-28 21:08:47.383549141 +0300
-+++ php-7.2.0RC5/ext/standard/basic_functions.c        2017-10-28 21:10:20.625051932 +0300
-@@ -113,6 +113,18 @@
++PCRE_EXTERN
+ PHPAPI pcre2_match_context *php_pcre_mctx(void);
+ PHPAPI pcre2_general_context *php_pcre_gctx(void);
+ PHPAPI pcre2_compile_context *php_pcre_cctx(void);
+@@ -65,7 +98,9 @@
+ PHPAPI void php_pcre_pce_decref(pcre_cache_entry *);
+ PHPAPI pcre2_code *php_pcre_pce_re(pcre_cache_entry *);
+ /* capture_count can be ignored, re is required. */
++PCRE_EXTERN
+ PHPAPI pcre2_match_data *php_pcre_create_match_data(uint32_t, pcre2_code *);
++PCRE_EXTERN
+ PHPAPI void php_pcre_free_match_data(pcre2_match_data *);
+ ZEND_BEGIN_MODULE_GLOBALS(pcre)
+diff -urN php-7.3.12.orig/ext/phar/Makefile.frag php-7.3.12/ext/phar/Makefile.frag
+--- php-7.3.12.orig/ext/phar/Makefile.frag     2019-12-12 21:43:24.654000000 +0100
++++ php-7.3.12/ext/phar/Makefile.frag  2019-12-12 21:43:36.358000000 +0100
+@@ -14,7 +14,7 @@
+               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
+               if test "x$(PHP_MODULES)" != "x"; then \
+               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
+-              for i in spl bz2 zlib phar; do \
++              for i in pcre spl bz2 zlib phar; do \
+                       if test -f "$(top_builddir)/modules/$$i.la"; then \
+                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
+                       fi; \
+diff -urN php-7.3.12.orig/ext/standard/basic_functions.c php-7.3.12/ext/standard/basic_functions.c
+--- php-7.3.12.orig/ext/standard/basic_functions.c     2019-12-12 21:43:24.765000000 +0100
++++ php-7.3.12/ext/standard/basic_functions.c  2019-12-12 21:43:36.361000000 +0100
+@@ -112,6 +112,18 @@
  PHPAPI php_basic_globals basic_globals;
  #endif
  
  #include "php_fopen_wrappers.h"
  #include "streamsfuncs.h"
  
---- php-5.3.2/sapi/cli/tests/018.phpt~ 2008-03-17 16:05:39.000000000 +0200
-+++ php-5.3.2/sapi/cli/tests/018.phpt  2010-03-16 20:41:11.341251246 +0200
-@@ -20,8 +20,6 @@
- --EXPECTF--     
- [PHP Modules]
- %a
--pcre
--%a
- [Zend Modules]
- %aDone
---- php-7.0.0beta3/main/php_ini.c~     2015-08-26 18:50:15.000000000 +0300
-+++ php-7.0.0beta3/main/php_ini.c      2015-08-26 22:33:59.126957396 +0300
-@@ -765,8 +765,8 @@
+diff -urN php-7.3.12.orig/main/php_ini.c php-7.3.12/main/php_ini.c
+--- php-7.3.12.orig/main/php_ini.c     2019-12-12 21:43:24.549000000 +0100
++++ php-7.3.12/main/php_ini.c  2019-12-12 21:43:36.364000000 +0100
+@@ -807,8 +807,8 @@
   */
  void php_ini_register_extensions(void)
  {
  
        zend_llist_destroy(&extension_lists.engine);
        zend_llist_destroy(&extension_lists.functions);
---- php-5.3.1/ext/phar/Makefile.frag~  2009-07-23 15:48:04.000000000 +0000
-+++ php-5.3.1/ext/phar/Makefile.frag   2009-11-30 16:10:29.687175948 +0000
-@@ -10,7 +10,7 @@
-               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
-               if test "x$(PHP_MODULES)" != "x"; then \
-               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
--              for i in spl bz2 zlib phar; do \
-+              for i in pcre spl bz2 zlib phar; do \
-                       if test -f "$(top_builddir)/modules/$$i.la"; then \
-                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-                       fi; \
---- php-7.3.0beta3/ext/pcre/php_pcre.h~        2018-09-11 11:41:50.000000000 +0300
-+++ php-7.3.0beta3/ext/pcre/php_pcre.h 2018-09-11 11:41:54.865778887 +0300
-@@ -37,6 +37,9 @@
- #define php_pcre_replace_impl (*php_pcre_replace_impl_p)
- #define php_pcre_match_impl (*php_pcre_match_impl_p)
- #define php_pcre_split_impl (*php_pcre_split_impl_p)
-+#define php_pcre_create_match_data (*php_pcre_create_match_data_p)
-+#define php_pcre_free_match_data (*php_pcre_free_match_data_p)
-+#define php_pcre_mctx (*php_pcre_mctx_p)
- #if !defined(COMPILE_DL_PCRE_NOEXTERN)
- #     define PCRE_EXTERN extern
- #else
-@@ -50,6 +53,9 @@
- extern void *php_pcre_replace_impl_p;
- extern void *php_pcre_match_impl_p;
- extern void *php_pcre_split_impl_p;
-+extern void *php_pcre_create_match_data_p;
-+extern void *php_pcre_free_match_data_p;
-+extern void *php_pcre_mctx_p;
- #endif
- PHPAPI zend_string *php_pcre_replace(zend_string *regex, zend_string *subject_str, char *subject, size_t subject_len, zend_string *replace_str, size_t limit, size_t *replace_count);
-@@ -83,6 +89,7 @@
- PHPAPI void  php_pcre_grep_impl(   pcre_cache_entry *pce, zval *input, zval *return_value,
-       zend_long flags);
-+PCRE_EXTERN
- PHPAPI pcre2_match_context *php_pcre_mctx(void);
- PHPAPI pcre2_general_context *php_pcre_gctx(void);
- PHPAPI pcre2_compile_context *php_pcre_cctx(void);
-@@ -90,7 +97,9 @@
- PHPAPI void php_pcre_pce_decref(pcre_cache_entry *);
- PHPAPI pcre2_code *php_pcre_pce_re(pcre_cache_entry *);
- /* capture_count can be ignored, re is required. */
-+PCRE_EXTERN
- PHPAPI pcre2_match_data *php_pcre_create_match_data(uint32_t, pcre2_code *);
-+PCRE_EXTERN
- PHPAPI void php_pcre_free_match_data(pcre2_match_data *);
+diff -urN php-7.3.12.orig/sapi/cli/tests/018.phpt php-7.3.12/sapi/cli/tests/018.phpt
+--- php-7.3.12.orig/sapi/cli/tests/018.phpt    2019-12-12 21:43:24.534000000 +0100
++++ php-7.3.12/sapi/cli/tests/018.phpt 2019-12-12 21:43:36.364000000 +0100
+@@ -20,8 +20,6 @@
+ --EXPECTF--
+ [PHP Modules]
+ %a
+-pcre
+-%a
  
- ZEND_BEGIN_MODULE_GLOBALS(pcre)
+ [Zend Modules]
+ %aDone
index fe1fb62add0598c556a6d3792543cf2478f8c2b6..015ddc6962c0454b64f39b535fc1df1f0ad3c47a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -146,7 +146,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.3.11
+Version:       7.3.12
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -155,7 +155,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: b62a1e6f82e2646c01a7151492699d93
+# Source0-md5: e52a0dc6e7d94024989d0a3746070487
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini