]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- fixed removing alternatives on uninstall
authorMarcin Krol <hawk@tld-linux.org>
Wed, 22 Aug 2018 12:03:39 +0000 (12:03 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 22 Aug 2018 12:03:39 +0000 (12:03 +0000)
php.spec

index c37d79ec0752c6d2909ddde62e99548752e83717..30657938f6ae52d1810daba9ae7b96c782f564d7 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -147,7 +147,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.2.9
-Release:       1
+Release:       2
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -2669,7 +2669,7 @@ update-alternatives \
 
 %postun cli
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove php %{_bindir}/php || :
+       update-alternatives --remove php %{_bindir}/php%{php_suffix} || :
 fi
 
 %post  common -p /sbin/ldconfig
@@ -2685,8 +2685,8 @@ update-alternatives \
 
 %postun devel
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phpize %{_bindir}/phpize || :
-       update-alternatives --remove php-config %{_bindir}/php-config || :
+       update-alternatives --remove phpize %{_bindir}/phpize%{php_suffix} || :
+       update-alternatives --remove php-config %{_bindir}/php-config%{php_suffix} || :
 fi
 
 %pre fpm
@@ -2701,7 +2701,7 @@ update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_s
 if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
-       update-alternatives --remove php-fpm %{_sbindir}/php-fpm || :
+       update-alternatives --remove php-fpm %{_sbindir}/php%{php_suffix}-fpm || :
 fi
 
 %postun fpm
@@ -2864,7 +2864,7 @@ update-alternatives \
 %postun phar
 %ext_postun
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phar %{_bindir}/phar || :
+       update-alternatives --remove phar %{_bindir}/phar%{php_suffix}.phar || :
 fi
 
 %if %{with apache2}