]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 8.1.19
authorMarcin Krol <hawk@tld-linux.org>
Mon, 15 May 2023 20:26:45 +0000 (22:26 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 15 May 2023 20:26:45 +0000 (22:26 +0200)
php-ini.patch
php-silent-session-cleanup.patch
php.spec

index 156a129e7441e65ce5fddc56221c892b48524be2..392a7eb25d747fd275012b65da5cbf059aa2604b 100644 (file)
@@ -1,5 +1,5 @@
---- php-8.1.4/php.ini  2022-03-15 21:18:41.000000000 +0100
-+++ php-8.1.4/php.ini  2022-04-05 01:05:28.031906242 +0200
+--- php-8.1.19/php.ini 2023-05-10 15:43:03.000000000 +0200
++++ php-8.1.19/php.ini 2023-05-15 22:24:42.307500772 +0200
 @@ -82,6 +82,16 @@
  ; much more verbose when it comes to errors. We recommend using the
  ; development version only in development environments, as errors shown to
@@ -53,7 +53,7 @@
  
  ;;;;;;;;;;;;;;;;;;;
  ; Resource Limits ;
-@@ -762,7 +772,7 @@
+@@ -767,7 +777,7 @@
  ; https://php.net/extension-dir
  ;extension_dir = "./"
  ; On windows:
@@ -62,7 +62,7 @@
  
  ; Directory where the temporary files should be placed.
  ; Defaults to the system default (see sys_get_temp_dir)
-@@ -774,64 +784,6 @@
+@@ -779,64 +789,6 @@
  ; https://php.net/enable-dl
  enable_dl = Off
  
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -990,19 +942,19 @@
+@@ -1000,19 +952,19 @@
  ; Use of this INI entry is deprecated, use global input_encoding instead.
  ; If empty, default_charset or input_encoding or iconv.input_encoding is used.
  ; The precedence is: default_charset < input_encoding < iconv.input_encoding
  
  [imap]
  ; rsh/ssh logins are disabled by default. Use this INI entry if you want to
-@@ -1172,6 +1124,9 @@
+@@ -1182,6 +1134,9 @@
  ; https://php.net/mysqli.default-socket
  mysqli.default_socket =
  
  ; Default host for mysqli_connect() (doesn't apply in safe mode).
  ; https://php.net/mysqli.default-host
  mysqli.default_host =
-@@ -1318,7 +1273,7 @@
+@@ -1328,7 +1283,7 @@
  
  [browscap]
  ; https://php.net/browscap
  
  [Session]
  ; Handler used to store/retrieve data.
-@@ -1741,7 +1696,7 @@
+@@ -1751,7 +1706,7 @@
  
  ; Sets the directory name where SOAP extension will put cache files.
  ; https://php.net/soap.wsdl-cache-dir
  
  ; (time to live) Sets the number of second while cached file will be used
  ; instead of original one.
-@@ -1762,160 +1717,6 @@
+@@ -1772,165 +1727,6 @@
  [dba]
  ;dba.default_handler=
  
 -;opcache.file_cache_fallback=1
 -
 -; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
--; This should improve performance, but requires appropriate OS configuration.
--;opcache.huge_code_pages=1
+-; Under certain circumstances (if only a single global PHP process is
+-; started from which all others fork), this can increase performance
+-; by a tiny amount because TLB misses are reduced.  On the other hand, this
+-; delays PHP startup, increases memory usage and degrades performance
+-; under memory pressure - use with care.
+-; Requires appropriate OS configuration.
+-;opcache.huge_code_pages=0
 -
 -; Validate cached file permissions.
 -;opcache.validate_permission=0
index 2fdf68eb6910cd45e181522d375ae22eef04d234..6e394e949ad86cbbafff70b94562c42469bd9001 100644 (file)
@@ -5,6 +5,6 @@
        dir = opendir(dirname);
        if (!dir) {
 -              php_error_docref(NULL, E_NOTICE, "ps_files_cleanup_dir: opendir(%s) failed: %s (%d)", dirname, strerror(errno), errno);
-               return (0);
+               return -1;
        }
  
index 510e714d5e943df42adbea0cc52b97ba751e8847..8bde3fdcf4ffb66c6329e20a93cc89a14422f884 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -124,7 +124,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.1.16
+Version:       8.1.19
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -133,7 +133,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 7befaae076f821507588bd2f03ec8c68
+# Source0-md5: 7a06e016b0af0af215a0d3a18f06e29d
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini