]> TLD Linux GIT Repositories - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- updated to 4.5.3.1
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 # - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4 Summary:        phpMyAdmin - web-based MySQL administration
5 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
6 Name:           phpMyAdmin
7 Version:        4.5.3.1
8 Release:        1
9 License:        GPL v2
10 Group:          Applications/Databases/Interfaces
11 Source0:        https://files.phpmyadmin.net/%{name}/%{version}/%{name}-%{version}-all-languages.tar.xz
12 # Source0-md5:  e7e9981c75d356f5fb932e1a2e4978f8
13 Source1:        %{name}-apache.conf
14 Source2:        %{name}-lighttpd.conf
15 Patch0:         %{name}-config.patch
16 Patch1:         %{name}-ServerSelectDisplayName.patch
17 URL:            http://www.phpmyadmin.net/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 # phpMyAdmin doesn't support mysql < 5.5 and won't work with php < 5.3
22 Requires:       mysql-libs >= 5.5
23 Requires:       php(core) >= 5.3
24 Requires:       php(ctype)
25 Requires:       php(filter)
26 Requires:       php(json)
27 Requires:       php(mbstring)
28 Requires:       php(mcrypt)
29 Requires:       php(mysqli)
30 Requires:       php(pcre)
31 Requires:       php(session)
32 Requires:       php(simplexml)
33 Requires:       webapps
34 Requires:       webserver(access)
35 Requires:       webserver(alias)
36 Requires(triggerpostun):        sed >= 4.0
37 Suggests:       webserver(indexfile)
38 Suggests:       webserver(php)
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _appdir         %{_datadir}/%{name}
43 %define         _webapps        /etc/webapps
44 %define         _webapp         %{name}
45 %define         _sysconfdir     %{_webapps}/%{_webapp}
46
47 %description
48 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
49 but also a single database. To accomplish the latter you'll need a
50 properly set up MySQL-user who can read/write only the desired
51 database. It's up to you to look up the appropiate part in the MySQL
52 manual. Currently phpMyAdmin can:
53 - create and drop databases
54 - create, copy, drop and alter tables
55 - delete, edit and add fields
56 - execute any SQL-statement, even batch-queries
57 - manage keys on fields
58 - load text files into tables
59 - create (*) and read dumps of tables
60 - export (*) and import data to CSV values
61 - administer multiple servers and single databases
62 - check referencial integrity
63 - create complex queries automatically connecting required tables
64 - create PDF graphics of your database layout
65 - communicate in more than 50 different languages
66
67 %description -l pl.UTF-8
68 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
69 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
70 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
71 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
72 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
73 - tworzyć i usuwać bazy
74 - wykonywać create, copy, drop oraz alter na tabelach
75 - dodawać, usuwać i modyfikować pola
76 - wykonywać dowolne zapytania SQL
77 - zarządzać kluczami na rekordach
78 - wczytywać tekst z plików do tabel
79 - obsługiwać ponad 20 języków
80 - zarządzać wieloma serwerami i pojedynczymi bazami danych
81 - eksportować i importować dane do wartości CSV
82 - tworzyć i czytać zrzuty tabel
83
84 %prep
85 %setup -q -n %{name}-%{version}-all-languages
86 %patch0 -p1
87 %patch1 -p0
88
89 # cleanup backups after patching
90 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
95
96 cp -p *.php *.css favicon.ico robots.txt $RPM_BUILD_ROOT%{_appdir}
97 cp -a js libraries locale templates themes $RPM_BUILD_ROOT%{_appdir}
98
99 cp -p libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
100 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
101
102 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
103 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
104 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %triggerin -- apache1 < 1.3.37-3, apache1-base
110 %webapp_register apache %{_webapp}
111
112 %triggerun -- apache1 < 1.3.37-3, apache1-base
113 %webapp_unregister apache %{_webapp}
114
115 %triggerin -- apache < 2.2.0, apache-base
116 %webapp_register httpd %{_webapp}
117
118 %triggerun -- apache < 2.2.0, apache-base
119 %webapp_unregister httpd %{_webapp}
120
121 %triggerin -- lighttpd
122 %webapp_register lighttpd %{_webapp}
123
124 %triggerun -- lighttpd
125 %webapp_unregister lighttpd %{_webapp}
126
127 %files
128 %defattr(644,root,root,755)
129 %doc ChangeLog README examples
130 %dir %attr(750,root,http) %{_sysconfdir}
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
133 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
134 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
135 %dir %{_appdir}
136 %{_appdir}/js
137 %{_appdir}/libraries
138 %{_appdir}/locale
139 %{_appdir}/templates
140 %{_appdir}/themes
141 %{_appdir}/*.css
142 %{_appdir}/*.php
143 %{_appdir}/favicon.ico
144 %{_appdir}/robots.txt