]> TLD Linux GIT Repositories - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- updated to 4.2.2
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 # - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4 Summary:        phpMyAdmin - web-based MySQL administration
5 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
6 Name:           phpMyAdmin
7 Version:        4.2.2
8 Release:        0.1
9 License:        GPL v2
10 Group:          Applications/Databases/Interfaces
11 Source0:        http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.xz
12 # Source0-md5:  67f15fb02d327f04fca3713d57ccc367
13 Source1:        apache.conf
14 Source2:        %{name}-lighttpd.conf
15 Patch0:         %{name}-config.patch
16 Patch1:         %{name}-ServerSelectDisplayName.patch
17 Patch2:         %{name}-ServerSelectDisplayName-config.patch
18 URL:            http://www.phpmyadmin.net/
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 # phpMyAdmin doesn't support mysql < 5.5 and won't work with php < 5.3
23 Requires:       mysql-libs >= 5.5
24 Requires:       php(core) >= 5.3
25 Requires:       php(ctype)
26 Requires:       php(filter)
27 Requires:       php(json)
28 Requires:       php(mbstring)
29 Requires:       php(mcrypt)
30 Requires:       php(mysql)
31 Requires:       php(pcre)
32 Requires:       php(session)
33 Requires:       php(simplexml)
34 Requires:       webapps
35 Requires:       webserver(access)
36 Requires:       webserver(alias)
37 Requires(triggerpostun):        sed >= 4.0
38 Suggests:       php-mysqli
39 Suggests:       webserver(indexfile)
40 Suggests:       webserver(php)
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _appdir         %{_datadir}/%{name}
45 %define         _webapps        /etc/webapps
46 %define         _webapp         %{name}
47 %define         _sysconfdir     %{_webapps}/%{_webapp}
48
49 %description
50 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
51 but also a single database. To accomplish the latter you'll need a
52 properly set up MySQL-user who can read/write only the desired
53 database. It's up to you to look up the appropiate part in the MySQL
54 manual. Currently phpMyAdmin can:
55 - create and drop databases
56 - create, copy, drop and alter tables
57 - delete, edit and add fields
58 - execute any SQL-statement, even batch-queries
59 - manage keys on fields
60 - load text files into tables
61 - create (*) and read dumps of tables
62 - export (*) and import data to CSV values
63 - administer multiple servers and single databases
64 - check referencial integrity
65 - create complex queries automatically connecting required tables
66 - create PDF graphics of your database layout
67 - communicate in more than 50 different languages
68
69 %description -l pl.UTF-8
70 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
71 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
72 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
73 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
74 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
75 - tworzyć i usuwać bazy
76 - wykonywać create, copy, drop oraz alter na tabelach
77 - dodawać, usuwać i modyfikować pola
78 - wykonywać dowolne zapytania SQL
79 - zarządzać kluczami na rekordach
80 - wczytywać tekst z plików do tabel
81 - obsługiwać ponad 20 języków
82 - zarządzać wieloma serwerami i pojedynczymi bazami danych
83 - eksportować i importować dane do wartości CSV
84 - tworzyć i czytać zrzuty tabel
85
86 %prep
87 %setup -q -n %{name}-%{version}-all-languages
88 %patch0 -p1
89 %patch1 -p0
90 %patch2 -p0
91
92 # cleanup backups after patching
93 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
98
99 cp -p *.php *.css favicon.ico robots.txt $RPM_BUILD_ROOT%{_appdir}
100 cp -a locale themes js libraries $RPM_BUILD_ROOT%{_appdir}
101
102 cp -p libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
103 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
104
105 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
106 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
107 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %triggerin -- apache1 < 1.3.37-3, apache1-base
113 %webapp_register apache %{_webapp}
114
115 %triggerun -- apache1 < 1.3.37-3, apache1-base
116 %webapp_unregister apache %{_webapp}
117
118 %triggerin -- apache < 2.2.0, apache-base
119 %webapp_register httpd %{_webapp}
120
121 %triggerun -- apache < 2.2.0, apache-base
122 %webapp_unregister httpd %{_webapp}
123
124 %triggerin -- lighttpd
125 %webapp_register lighttpd %{_webapp}
126
127 %triggerun -- lighttpd
128 %webapp_unregister lighttpd %{_webapp}
129
130 %files
131 %defattr(644,root,root,755)
132 %doc ChangeLog README examples
133 %dir %attr(750,root,http) %{_sysconfdir}
134 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
135 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
136 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
137 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
138 %dir %{_appdir}
139 %{_appdir}/js
140 %{_appdir}/libraries
141 %{_appdir}/locale
142 %{_appdir}/themes
143 %{_appdir}/*.css
144 %{_appdir}/*.php
145 %{_appdir}/favicon.ico
146 %{_appdir}/robots.txt