]> TLD Linux GIT Repositories - packages/poldek.git/blobdiff - poldek.spec
- merged update to 0.30.0 from PLD
[packages/poldek.git] / poldek.spec
index 8c9470fd41ae27fa009c6ffeb49ed8465420dd02..42cce4e371fada52096be57dc4d96149000563d7 100644 (file)
@@ -1,41 +1,41 @@
+#
 # Conditional build:
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
 %bcond_without python  # don't build python bindings
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-%define        ver_db          4.5.20
-%define        ver_db_rel      8
-%define        ver_rpm         4.5-49
+%define                db_pkg          db4.5
+%define                ver_db          4.5.20
+%define                ver_db_rel      3
+%define                ver_rpm         4.5-71
 
-%define                snap    rc7
 %define                rel     1
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
 Version:       0.30.0
-Release:       1.%{snap}.%{rel}
+Release:       %{rel}
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://carme.pld-linux.org/~megabajt/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
-# Source0-md5: 56ba9e7b709a99965f42e24e65eb2d7f
+#Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
+Source0:       http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
+# Source0-md5: 392cfa125912fbedb6cc6d54dfbb80e3
 Source1:       %{name}.conf
 Source2:       %{name}-multilib.conf
 Source5:       %{name}-aliases.conf
 Source6:       %{name}.desktop
 Source7:       %{name}.png
-Patch0:                %{name}-vserver-packages.patch
-Patch1:                %{name}-config.patch
-Patch2:                %{name}-size-type.patch
-Patch3:                %{name}-Os-fail-workaround.patch
-Patch4:                %{name}-git.patch
+Patch0:                %{name}-size-type.patch
+Patch1:                %{name}-Os-fail-workaround.patch
+Patch2:                %{name}-config.patch
 URL:           http://poldek.pld-linux.org/
+BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: check-devel
-BuildRequires: db-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gettext-devel
 BuildRequires: libtool
@@ -50,11 +50,13 @@ BuildRequires:      readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: swig-python
+BuildRequires: tar >= 1:1.22
 BuildRequires: xmlto
+BuildRequires: xz
 BuildRequires: zlib-devel
 %if %{with static}
+BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
 BuildRequires: bzip2-static
-BuildRequires: db-static >= %{ver_db}-%{ver_db_rel}
 BuildRequires: glibc-static
 BuildRequires: libselinux-static
 BuildRequires: libxml2-static
@@ -68,15 +70,18 @@ BuildRequires:      zlib-static
 %endif
 Requires(triggerpostun):       awk
 Requires(triggerpostun):       sed >= 4.0
+Requires:      %{db_pkg} >= %{ver_db}-%{ver_db_rel}
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      db >= %{ver_db}-%{ver_db_rel}
 Requires:      rpm >= %{ver_rpm}
 Requires:      rpm-db-ver = %{ver_db}
-Requires:      rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
+#Requires:     rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
+Requires:      rpm-lib >= %{ver_rpm}
 # vf* scripts use sed
 Requires:      sed
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _libexecdir     %{_prefix}/lib/%{name}
+
 %description
 poldek is an RPM package management tool which allows you to easily
 perform package verification, installation (including system
@@ -174,7 +179,7 @@ Summary(hu.UTF-8):  Python modulok poldek-hez
 Summary(pl.UTF-8):     Moduły języka Python dla poldka
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{version}-%{release}
-%pyrequires_eq python-libs
+Requires:      python-libs
 
 %description -n python-poldek
 Python modules for poldek.
@@ -190,8 +195,6 @@ Moduły języka Python dla poldka.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
@@ -223,6 +226,7 @@ CPPFLAGS="%{rpmcppflags} -std=gnu99"
 %configure \
        %{?with_static:--enable-static --disable-shared} \
        %{!?with_imode:--disable-imode} \
+       --with-pkglibdir=%{_libexecdir} \
        --enable-nls \
        %{?with_python:--with-python}
 %{__make} -j1
@@ -243,16 +247,13 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i586 i686 ppc sparc alpha athlon
+%ifarch i686
        %define         _ftp_arch       %{_target_cpu}
 %endif
 %ifarch %{x8664}
        %define         _ftp_arch       x86_64
        %define         _ftp_alt_arch   i686
 %endif
-%ifarch i586
-       %define         _ftp_arch       i586
-%endif
 %ifarch pentium2 pentium3 pentium4
        %define         _ftp_arch       i686
 %endif
@@ -398,8 +399,8 @@ fi
 %attr(755,root,root) %{_bindir}/ipoldek
 %attr(755,root,root) %{_bindir}/poldek
 %attr(755,root,root) %{_bindir}/rpmvercmp
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*
+%dir %{_libexecdir}
+%attr(755,root,root) %{_libexecdir}/*
 %{_mandir}/man1/%{name}*.1*
 %lang(pl) %{_mandir}/pl/man1/%{name}*
 %{_infodir}/poldek.info*