]> TLD Linux GIT Repositories - packages/postfix.git/blob - postfix.spec
f91b3f72c7a7684e4db9a6e6a83978238b9e35bc
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %bcond_with     vda     # with VDA patch
11 %bcond_with     hir     # with Beeth's header_if_reject patch
12 %bcond_with     tcp     # with unofficial tcp: lookup table
13 %bcond_without  epoll   # disable epoll for 2.4 kernels
14
15 %define         vda_ver v11-2.9.1
16 Summary:        Postfix Mail Transport Agent
17 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
18 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
19 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
20 Summary(pl.UTF-8):      Serwer SMTP Postfix
21 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
22 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
23 Name:           postfix
24 Version:        2.11.1
25 Release:        1
26 Epoch:          2
27 License:        distributable
28 Group:          Networking/Daemons/SMTP
29 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
30 # Source0-md5:  56ac1f1a79737c4ac1e24535a122a4a6
31 Source1:        %{name}.aliases
32 Source2:        %{name}.cron
33 Source3:        %{name}.init
34 Source4:        %{name}.sysconfig
35 Source5:        %{name}.sasl
36 Source6:        %{name}.pamd
37 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
38 # Source7-md5:  a54a21428de5eeae91b4bb670976e37a
39 Source8:        %{name}-bounce.cf.pl
40 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
41 Source9:        %{name}-bounce.cf.de
42 Source10:       %{name}.monitrc
43 Source11:       %{name}-vda-bigquota.patch
44 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
45 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
46 Source12:       %{name}.service
47 Patch0:         %{name}-config.patch
48 Patch1:         %{name}-conf_msg.patch
49 Patch2:         %{name}-dynamicmaps.patch
50 Patch3:         %{name}-master.cf_cyrus.patch
51 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
52 Patch4:         %{name}-header_if_reject.patch
53 Patch5:         %{name}-ident.patch
54 Patch6:         %{name}-lib64.patch
55 Patch7:         %{name}-conf.patch
56 Patch8:         %{name}-dictname.patch
57 Patch9:         %{name}-make-jN.patch
58 Patch10:        %{name}-link.patch
59 Patch11:        %{name}-scache_clnt.patch
60 Patch12:        format-security.patch
61 URL:            http://www.postfix.org/
62 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
63 BuildRequires:  db-devel
64 # getifaddrs() with IPv6 support
65 BuildRequires:  glibc-devel >= 6:2.3.4
66 %{?with_mysql:BuildRequires:    mysql-devel}
67 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
68 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
69 BuildRequires:  pcre-devel
70 BuildRequires:  perl-base
71 %{?with_pgsql:BuildRequires:    postgresql-devel}
72 BuildRequires:  rpm >= 4.4.9-56
73 BuildRequires:  rpmbuild(macros) >= 1.644
74 BuildRequires:  sed >= 4.0
75 %{?with_sqlite:BuildRequires:   sqlite3-devel}
76 %{?with_cdb:BuildRequires:      tinycdb-devel}
77 %{?with_mysql:BuildRequires:    zlib-devel}
78 Requires(post): /bin/hostname
79 Requires(post,postun):  /sbin/ldconfig
80 Requires(post,preun):   /sbin/chkconfig
81 Requires(postun):       /usr/sbin/groupdel
82 Requires(postun):       /usr/sbin/userdel
83 Requires(pre):  /bin/id
84 Requires(pre):  /usr/bin/getgid
85 Requires(pre):  /usr/sbin/groupadd
86 Requires(pre):  /usr/sbin/useradd
87 Requires:       /sbin/chkconfig
88 Requires:       diffutils
89 Requires:       findutils
90 Requires:       rc-scripts
91 Requires:       sed
92 %{?with_cdb:Requires:tinycdb}
93 Requires:       systemd-units >= 38
94 Suggests:       cyrus-sasl-saslauthd
95 Provides:       group(postfix)
96 Provides:       smtpdaemon
97 Provides:       user(postfix)
98 Obsoletes:      smtpdaemon
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %description
102 Postfix is attempt to provide an alternative to the widely-used
103 Sendmail program. Postfix attempts to be fast, easy to administer, and
104 hopefully secure, while at the same time being sendmail compatible
105 enough to not upset your users. This version has IPv6 support.
106
107 %description -l es.UTF-8
108 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
109 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
110
111 %description -l fr.UTF-8
112 Postfix (voir http://www.postfix.org/) se veut une alternative à
113 sendmail, responsable de l'acheminement de 70% des courriers
114 électroniques sur Internet. IBM en a suppotré le développement, mais
115 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
116 plus grand nombre de systèmes possible. Dans cette optique, il a été
117 écrit pour être totalement sous le contrôle de l'utilisateur.
118
119 %description -l it.UTF-8
120 Postfix (http://www.postfix.org/) e' un'alternativa al programma
121 sendmail utilizzato per la gestione del 70 per cento della posta
122 Internet.
123
124 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
125 evoluzione.
126
127 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
128 quale troverete le indicazioni per una corretta installazione e
129 configurazione di questo programma.
130
131 %description -l pl.UTF-8
132 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
133 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
134 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
135 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
136
137 %description -l pt_BR.UTF-8
138 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
139 você deseja um servidor SMTP *rápido*, instale este pacote.
140
141 %description -l sk.UTF-8
142 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
143 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
144 elektronickej pošty doručenej na Internete.
145
146 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
147 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
148 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
149 môže vyvíjať podľa jeho používateľov.
150
151 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
152 popísané kroky potrebné pred a po inštalácii Postfixu.
153
154 %package devel
155 Summary:        Postfix loadable modules development package
156 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
157 Group:          Development/Libraries
158 Requires:       %{name} = %{epoch}:%{version}-%{release}
159
160 %description devel
161 Header files to build additional map types for Postfix.
162
163 %description devel -l pl.UTF-8
164 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
165
166 %package dict-ldap
167 Summary:        LDAP map support for Postfix
168 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
169 Group:          Networking/Daemons/SMTP
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171 Requires:       openldap >= 2.3.6
172
173 %description dict-ldap
174 This package provides support for LDAP maps in Postfix.
175
176 %description dict-ldap -l pl.UTF-8
177 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
178
179 %package dict-mysql
180 Summary:        MySQL map support for Postfix
181 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
182 Group:          Networking/Daemons/SMTP
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description dict-mysql
186 This package provides support for MySQL maps in Postfix.
187
188 %description dict-mysql -l pl.UTF-8
189 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
190
191 %package dict-pcre
192 Summary:        PCRE map support for Postfix
193 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
194 Group:          Networking/Daemons/SMTP
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196
197 %description dict-pcre
198 This package provides support for PCRE maps in Postfix.
199
200 %description dict-pcre -l pl.UTF-8
201 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
202
203 %package dict-pgsql
204 Summary:        PostgreSQL map support for Postfix
205 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
206 Group:          Networking/Daemons/SMTP
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208
209 %description dict-pgsql
210 This package provides support for PostgreSQL maps in Postfix.
211
212 %description dict-pgsql -l pl.UTF-8
213 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
214
215 %package dict-sqlite
216 Summary:        SQLite map support for Postfix
217 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
218 Group:          Networking/Daemons/SMTP
219 Requires:       %{name} = %{epoch}:%{version}-%{release}
220
221 %description dict-sqlite
222 This package provides support for SQLite maps in Postfix.
223
224 %description dict-sqlite -l pl.UTF-8
225 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
226
227 %package qshape
228 Summary:        qshape - Print Postfix queue domain and age distribution
229 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
230 Group:          Networking/Daemons/SMTP
231 Requires:       %{name} = %{epoch}:%{version}-%{release}
232
233 %description qshape
234 The qshape program helps the administrator understand the Postfix
235 queue message distribution in time and by sender domain or recipient
236 domain. The program needs read access to the queue directories and
237 queue files, so it must run as the superuser or the mail_owner
238 specified in main.cf (typically postfix).
239
240 %description qshape -l pl.UTF-8
241 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
242 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
243 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
244 kolejki, więc musi być uruchamiany przez superużytkownika lub
245 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
246 postfix).
247
248 %package -n monit-rc-%{name}
249 Summary:        monit support for Postfix
250 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
251 Group:          Applications/System
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253 Requires:       monit
254
255 %description -n monit-rc-%{name}
256 monitrc file for monitoring Postfix.
257
258 %description -n monit-rc-%{name} -l pl.UTF-8
259 Plik monitrc do monitorowania serwera Postfix.
260
261 %prep
262 %setup -q
263 %if %{with vda}
264 cat %{SOURCE7} | %{__patch} -p1 -s
265 cat %{SOURCE11} | %{__patch} -p1 -s
266 %endif
267
268 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
269
270 %patch0 -p1
271 %patch1 -p0
272 %patch2 -p1
273 %patch3 -p1
274 %{?with_hir:%patch4 -p0}
275 %patch5 -p1
276 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
277 %if "%{_lib}" == "lib64"
278 %patch6 -p1
279 %endif
280 %patch7 -p1
281 %patch8 -p1
282 %patch9 -p1
283 %patch10 -p1
284 %patch11 -p1
285 %if %{with vda}
286 %patch12 -p1
287 %endif
288
289 %if %{with tcp}
290 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
291 %endif
292
293 %build
294 %{__make} -f Makefile.init makefiles
295 %{__make} tidy
296 CC="%{__cc}"
297 export CC
298 %{__make} \
299         DEBUG="" \
300         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
301         %{!?with_ldap:LDAPSO=""} \
302         %{!?with_mysql:MYSQLSO=""} \
303         %{!?with_pgsql:PGSQLSO=""} \
304         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
305         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
306
307 %install
308 rm -rf $RPM_BUILD_ROOT
309 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
310         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
311         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
312         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
313         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
314         $RPM_BUILD_ROOT%{_var}/lib/postfix \
315         $RPM_BUILD_ROOT%{systemdunitdir}
316
317 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
318
319 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
320 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
321 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
322 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
323 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
324 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
325         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
326
327 for f in dns global master util ; do
328         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
329         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
330 done
331 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
332 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
333
334 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
335
336 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
337 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
338 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
339 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
340 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
341 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
342 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
343 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
344 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
345 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
346 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
347 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
348
349 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
350 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
351 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
352
353 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
354         {aliases,access,canonical,relocated,transport,virtual}{,.db}
355
356 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
357
358 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
359
360 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
361 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
362
363 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
364
365 %clean
366 rm -rf $RPM_BUILD_ROOT
367
368 %pre
369 %groupadd -g 62 postfix
370 %groupadd -g 63 maildrop
371 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
372
373 %post
374 /sbin/ldconfig
375 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
376         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
377         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
378 fi
379 if [ "$1" = "1" ]; then
380         # only on installation, not upgrade; set sane defaults
381         # postfix expects gethostname() to return FQDN, which is obviously wrong
382         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
383                 domain=$(/bin/hostname -d 2>/dev/null)
384                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
385                         postconf -e mydomain="$domain"
386         fi
387 else
388         %{_sbindir}/postfix upgrade-configuration
389 fi
390
391 %{_bindir}/newaliases
392 /sbin/chkconfig --add postfix
393 %service postfix restart "Postfix Daemon"
394 #%%systemd_post
395
396 %preun
397 if [ "$1" = "0" ]; then
398         %service postfix stop
399         /sbin/chkconfig --del postfix
400 fi
401 #%%systemd_preun
402
403 %postun
404 /sbin/ldconfig
405 if [ "$1" = "0" ]; then
406         %groupremove maildrop
407         %userremove postfix
408         %groupremove postfix
409 fi
410 #%%systemd_postun
411
412 %files
413 %defattr(644,root,root,755)
414 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
415 %doc README_FILES/*README
416 %doc examples/smtpd-policy
417 %dir %{_sysconfdir}/mail
418 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
419 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
420 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
421 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
422 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
423 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
424 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
425 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
428 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
430 #%ghost %{_sysconfdir}/mail/*.db
431 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
433 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
434 %{_sysconfdir}/mail/postfix-wrapper
435 %{_sysconfdir}/mail/postmulti-script
436 %attr(740,root,root) /etc/cron.daily/postfix
437 %attr(754,root,root) /etc/rc.d/init.d/postfix
438 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
439 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
440 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
441 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
442 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
443 %attr(755,root,root) %{_bindir}/mailq
444 %attr(755,root,root) %{_bindir}/newaliases
445 %attr(755,root,root) %{_bindir}/rmail
446 %attr(755,root,root) %{_sbindir}/s*
447 %attr(755,root,root) %{_sbindir}/postfix
448 %attr(755,root,root) %{_sbindir}/postalias
449 %attr(2755,root,maildrop) %{_sbindir}/postdrop
450 %attr(755,root,root) %{_sbindir}/postkick
451 %attr(755,root,root) %{_sbindir}/postl*
452 %attr(755,root,root) %{_sbindir}/postc*
453 %attr(755,root,root) %{_sbindir}/postmap
454 %attr(755,root,root) %{_sbindir}/postmulti
455 %attr(2755,root,maildrop) %{_sbindir}/postqueue
456 %attr(755,root,root) %{_sbindir}/postsuper
457 %attr(755,root,root) %{_sbindir}/posttls-finger
458 %attr(755,root,root) %{_sbindir}/qmqp-sink
459 %attr(755,root,root) %{_sbindir}/qmqp-source
460 %attr(755,root,root) /usr/lib/sendmail
461 %dir %{_libdir}/postfix
462 %attr(755,root,root) %{_libdir}/postfix/[!d]*
463 %attr(755,root,root) %{_libdir}/postfix/discard
464 %attr(755,root,root) %{_libdir}/postfix/dnsblog
465 %attr(755,root,root) %dir %{_var}/spool/postfix
466 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
467 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
468 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
469 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
470 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
471 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
472 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
473 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
474 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
475 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
476 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
477 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
478 %attr(700,postfix,root) %{_var}/lib/postfix
479 %{_mandir}/man1/mailq.1*
480 %{_mandir}/man1/newaliases.1*
481 %{_mandir}/man1/post*.1*
482 %{_mandir}/man1/qmqp-*.1*
483 %{_mandir}/man1/sendmail.1*
484 %{_mandir}/man1/smtp-*.1*
485 %{_mandir}/man5/access.5*
486 %{_mandir}/man5/aliases.5*
487 %{_mandir}/man5/body_checks.5*
488 %{_mandir}/man5/bounce.5*
489 %{_mandir}/man5/canonical.5*
490 %{_mandir}/man5/cidr_table.5*
491 %{_mandir}/man5/generic.5*
492 %{_mandir}/man5/header_checks.5*
493 %{_mandir}/man5/lmdb_table.5*
494 %{_mandir}/man5/master.5*
495 %{_mandir}/man5/memcache_table.5*
496 %{_mandir}/man5/nisplus_table.5*
497 %{_mandir}/man5/postconf.5*
498 %{_mandir}/man5/postfix-wrapper.5*
499 %{_mandir}/man5/regexp_table.5*
500 %{_mandir}/man5/relocated.5*
501 %{_mandir}/man5/socketmap_table.5*
502 %{_mandir}/man5/tcp_table.5*
503 %{_mandir}/man5/transport.5*
504 %{_mandir}/man5/virtual.5*
505 %{_mandir}/man8/*.8*
506 %{systemdunitdir}/%{name}.service
507
508 %files devel
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/libpostfix-*.so
511 %{_includedir}/postfix
512
513 %if %{with ldap}
514 %files dict-ldap
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
517 %{_mandir}/man5/ldap_table.5*
518 %endif
519
520 %if %{with mysql}
521 %files dict-mysql
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
524 %{_mandir}/man5/mysql_table.5*
525 %endif
526
527 %files dict-pcre
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
530 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
531 %{_mandir}/man5/pcre_table.5*
532
533 %if %{with pgsql}
534 %files dict-pgsql
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
537 %{_mandir}/man5/pgsql_table.5*
538 %endif
539
540 %if %{with sqlite}
541 %files dict-sqlite
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
544 %{_mandir}/man5/sqlite_table.5*
545 %endif
546
547 %files qshape
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/qshape
550 %{_mandir}/man1/qshape.1*
551
552 %files -n monit-rc-%{name}
553 %defattr(644,root,root,755)
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc