]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - per-version-dirs.patch
- updated to 14.0
[packages/postgresql.git] / per-version-dirs.patch
index 46e8c453b4fdf1abb8a1a6d1e68618e464a69aa5..dbf4cf86137097a3e59a53b3c6cd6d8f7320a1ba 100644 (file)
@@ -1,35 +1,16 @@
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -120,7 +120,7 @@ libdir := @libdir@
- pkglibdir = $(libdir)
- ifeq "$(findstring pgsql, $(pkglibdir))" ""
- ifeq "$(findstring postgres, $(pkglibdir))" ""
--override pkglibdir := $(pkglibdir)/postgresql
-+override pkglibdir := $(pkglibdir)/postgresql/@PG_MAJORVERSION@/lib
- endif
- endif
-@@ -168,7 +168,7 @@ endif # PGXS
- # These derived path variables aren't separately configurable.
--includedir_server = $(pkgincludedir)/server
-+includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
- includedir_internal = $(pkgincludedir)/internal
- pgxsdir = $(pkglibdir)/pgxs
---- a/src/bin/pg_config/pg_config.c
-+++ b/src/bin/pg_config/pg_config.c
+diff -ur postgresql-14.0.orig/src/bin/pg_config/pg_config.c postgresql-14.0/src/bin/pg_config/pg_config.c
+--- postgresql-14.0.orig/src/bin/pg_config/pg_config.c 2021-11-01 14:48:22.654149731 +0100
++++ postgresql-14.0/src/bin/pg_config/pg_config.c      2021-11-01 14:49:14.747282545 +0100
 @@ -27,6 +27,8 @@
- #include "port.h"
  #include "common/config_info.h"
+ #include "port.h"
  
 +#include "../port/pg_config_paths.h"
 +
  static const char *progname;
  
  /*
-@@ -148,11 +150,7 @@ main(int argc, char **argv)
+@@ -149,11 +151,7 @@
                }
        }
  
  
        configdata = get_configdata(my_exec_path, &configdata_len);
        /* no arguments -> print everything */
+diff -ur postgresql-14.0.orig/src/Makefile.global.in postgresql-14.0/src/Makefile.global.in
+--- postgresql-14.0.orig/src/Makefile.global.in        2021-11-01 14:48:22.456149226 +0100
++++ postgresql-14.0/src/Makefile.global.in     2021-11-01 14:49:14.747282545 +0100
+@@ -119,7 +119,7 @@
+ pkglibdir = $(libdir)
+ ifeq "$(findstring pgsql, $(pkglibdir))" ""
+ ifeq "$(findstring postgres, $(pkglibdir))" ""
+-override pkglibdir := $(pkglibdir)/postgresql
++override pkglibdir := $(pkglibdir)/postgresql/@PG_MAJORVERSION@/lib
+ endif
+ endif
+@@ -167,7 +167,7 @@
+ # These derived path variables aren't separately configurable.
+-includedir_server = $(pkgincludedir)/server
++includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
+ includedir_internal = $(pkgincludedir)/internal
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode