]> TLD Linux GIT Repositories - packages/postgresql.git/commitdiff
- switched to direct file logging, added logrotate
authorMarcin Krol <hawk@tld-linux.org>
Mon, 3 Dec 2018 17:10:23 +0000 (17:10 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 3 Dec 2018 17:10:23 +0000 (17:10 +0000)
postgresql-conf.patch
postgresql.logrotate [new file with mode: 0644]
postgresql.spec

index 288a7954138a5d7be8945531be6e4e8b40a81fd6..578f90949cb9b9b9602f87854bb44feee6ff2bec 100644 (file)
@@ -1,15 +1,43 @@
 --- postgresql-10.6/src/backend/utils/misc/postgresql.conf.sample      2018-11-05 21:45:50.000000000 +0000
 +++ postgresql-10.6/src/backend/utils/misc/postgresql.conf.sample      2018-12-03 13:23:39.277403000 +0000
-@@ -341,7 +341,7 @@
+@@ -341,23 +341,23 @@
  
  # - Where to Log -
  
 -#log_destination = 'stderr'           # Valid values are combinations of
-+log_destination = 'syslog'            # Valid values are combinations of
++log_destination = 'stderr'            # Valid values are combinations of
                                        # stderr, csvlog, syslog, and eventlog,
                                        # depending on platform.  csvlog
                                        # requires logging_collector to be on.
-@@ -374,9 +374,9 @@
+ # This is used when logging to stderr:
+-#logging_collector = off              # Enable capturing of stderr and csvlog
++logging_collector = on                        # Enable capturing of stderr and csvlog
+                                       # into log files. Required to be on for
+                                       # csvlogs.
+                                       # (change requires restart)
+ # These are only used if logging_collector is on:
+-#log_directory = 'log'                        # directory where log files are written,
++log_directory = '/var/log/postgresql' # directory where log files are written,
+                                       # can be absolute or relative to PGDATA
+-#log_filename = 'postgresql-%Y-%m-%d_%H%M%S.log'      # log file name pattern,
++log_filename = 'postgresql-10.log'    # log file name pattern,
+                                       # can include strftime() escapes
+-#log_file_mode = 0600                 # creation mode for log files,
++log_file_mode = 0640                  # creation mode for log files,
+                                       # begin with 0 to use octal notation
+ #log_truncate_on_rotation = off               # If on, an existing log file with the
+                                       # same name as the new log file will be
+@@ -367,16 +367,16 @@
+                                       # or size-driven rotation.  Default is
+                                       # off, meaning append to existing files
+                                       # in all cases.
+-#log_rotation_age = 1d                        # Automatic rotation of logfiles will
++log_rotation_age = 0                  # Automatic rotation of logfiles will
+                                       # happen after that time.  0 disables.
+ #log_rotation_size = 10MB             # Automatic rotation of logfiles will
+                                       # happen after that much log output.
                                        # 0 disables.
  
  # These are relevant when logging to syslog:
diff --git a/postgresql.logrotate b/postgresql.logrotate
new file mode 100644 (file)
index 0000000..1001b95
--- /dev/null
@@ -0,0 +1,7 @@
+/var/log/postgresql/*.log
+{
+       olddir /var/log/archive/postgresql
+       notifempty
+       missingok
+       copytruncate
+}
index a68f619a805a27c05c472d1e58c611ff572713c1..9f2a18ab02756c9b1b20b3541ad3c0c4520ac959 100644 (file)
@@ -29,7 +29,7 @@ Summary(uk.UTF-8):    PostgreSQL - система керування базами 
 Summary(zh_CN.UTF-8):  PostgreSQL 客户端程序和库文件
 Name:          postgresql-%{pgsqlversion}
 Version:       %{pgsqlversion}.6
-Release:       2
+Release:       3
 License:       BSD
 Group:         Applications/Databases
 Source0:       http://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
@@ -38,6 +38,7 @@ Source1:      postgresql.init
 Source2:       pgsql-Database-HOWTO-html.tar.gz
 # Source2-md5: 5b656ddf1db41965761f85204a14398e
 Source3:       postgresql.sysconfig
+Source4:       postgresql.logrotate
 Patch0:                postgresql-conf.patch
 Patch1:                postgresql-absolute_dbpaths.patch
 Patch2:                postgresql-ecpg-includedir.patch
@@ -549,8 +550,8 @@ done
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
-       $RPM_BUILD_ROOT/var/{lib/postgresql/%{pgsqlversion},log,run/postgresql} \
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{logrotate.d,rc.d/init.d,sysconfig}} \
+       $RPM_BUILD_ROOT/var/{lib/postgresql/%{pgsqlversion},log/{archive,}/postgresql,run/postgresql} \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
        $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
 
@@ -571,10 +572,9 @@ for mod in %{contrib_modules}; do \
                DESTDIR=$RPM_BUILD_ROOT
 done
 
-touch $RPM_BUILD_ROOT/var/log/pgsql
-
 sed -e 's,@pgsqlbindir@,%{pgsqllibdir}/bin,g; s,@pgsqlversion@,%{pgsqlversion},g;' %{SOURCE1} >$RPM_BUILD_ROOT/etc/rc.d/init.d/postgresql-%{pgsqlversion}
 sed -e 's,@pgsqlversion@,%{pgsqlversion},g;' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/postgresql-%{pgsqlversion}
+cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/postgresql
 
 install -d howto
 tar zxf %{SOURCE2} -C howto
@@ -784,8 +784,6 @@ fi
 
 %dir %{pgsqldatadir}/contrib
 
-%attr(640,postgres,postgres) %config(noreplace) %verify(not md5 mtime size) /var/log/pgsql
-
 %{pgsqldatadir}/man/man1/initdb.1*
 %{pgsqldatadir}/man/man1/pg_basebackup.1*
 %{pgsqldatadir}/man/man1/pg_controldata.1*