]> TLD Linux GIT Repositories - packages/postgresql.git/commitdiff
- build with python3, allow newer autoconf, adjust for rpm.org
authorMarcin Krol <hawk@tld-linux.org>
Mon, 4 Apr 2022 16:06:34 +0000 (18:06 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 4 Apr 2022 16:06:34 +0000 (18:06 +0200)
per-version-dirs.patch
postgresql-autoconf.patch [new file with mode: 0644]
postgresql-link.patch
postgresql.spec

index 46e8c453b4fdf1abb8a1a6d1e68618e464a69aa5..34e1c4f22418b122180b263de17111b53dbe8745 100644 (file)
@@ -1,6 +1,7 @@
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -120,7 +120,7 @@ libdir := @libdir@
+diff -urNp -x '*.orig' postgresql-13.6.org/src/Makefile.global.in postgresql-13.6/src/Makefile.global.in
+--- postgresql-13.6.org/src/Makefile.global.in 2022-02-07 22:17:41.000000000 +0100
++++ postgresql-13.6/src/Makefile.global.in     2022-04-04 17:54:23.042839497 +0200
+@@ -119,7 +119,7 @@ libdir := @libdir@
  pkglibdir = $(libdir)
  ifeq "$(findstring pgsql, $(pkglibdir))" ""
  ifeq "$(findstring postgres, $(pkglibdir))" ""
@@ -9,7 +10,7 @@
  endif
  endif
  
-@@ -168,7 +168,7 @@ endif # PGXS
+@@ -167,7 +167,7 @@ endif # PGXS
  
  # These derived path variables aren't separately configurable.
  
 +includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
  includedir_internal = $(pkgincludedir)/internal
  pgxsdir = $(pkglibdir)/pgxs
---- a/src/bin/pg_config/pg_config.c
-+++ b/src/bin/pg_config/pg_config.c
+ bitcodedir = $(pkglibdir)/bitcode
+diff -urNp -x '*.orig' postgresql-13.6.org/src/bin/pg_config/pg_config.c postgresql-13.6/src/bin/pg_config/pg_config.c
+--- postgresql-13.6.org/src/bin/pg_config/pg_config.c  2022-02-07 22:17:41.000000000 +0100
++++ postgresql-13.6/src/bin/pg_config/pg_config.c      2022-04-04 17:54:23.042839497 +0200
 @@ -27,6 +27,8 @@
- #include "port.h"
  #include "common/config_info.h"
+ #include "port.h"
  
 +#include "../port/pg_config_paths.h"
 +
  static const char *progname;
  
  /*
-@@ -148,11 +150,7 @@ main(int argc, char **argv)
+@@ -149,11 +151,7 @@ main(int argc, char **argv)
                }
        }
  
diff --git a/postgresql-autoconf.patch b/postgresql-autoconf.patch
new file mode 100644 (file)
index 0000000..717ca43
--- /dev/null
@@ -0,0 +1,14 @@
+diff -ur postgresql-13.6.orig/configure.in postgresql-13.6/configure.in
+--- postgresql-13.6.orig/configure.in  2022-02-07 22:17:41.000000000 +0100
++++ postgresql-13.6/configure.in       2022-04-04 17:51:22.778422656 +0200
+@@ -19,10 +19,6 @@
+ AC_INIT([PostgreSQL], [13.6], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/])
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended.  You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2020, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
index 84694890983041518a5ecb4dfe80fb49ee5b443e..c6700c138e01e98e8464bd65acb4bbe7c1ce0557 100644 (file)
@@ -1,6 +1,7 @@
---- postgresql-9.5.0/configure.in.orig   2018-02-21 03:23:25.335399998 +0100
-+++ postgresql-9.5.0/configure.in        2018-02-21 03:28:24.392066743 +0100
-@@ -1203,6 +1203,7 @@
+diff -urNp -x '*.orig' postgresql-13.6.org/configure.in postgresql-13.6/configure.in
+--- postgresql-13.6.org/configure.in   2022-04-04 17:57:53.706326633 +0200
++++ postgresql-13.6/configure.in       2022-04-04 17:57:57.921336380 +0200
+@@ -1478,6 +1478,7 @@ fi
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
@@ -8,7 +9,7 @@
  dnl At some point we might add something like
  dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
  dnl but right now, what that would mainly accomplish is to encourage
-@@ -1210,6 +1211,7 @@
+@@ -1485,6 +1486,7 @@ dnl people to try to use the avahi imple
  dnl If you want to use Apple's own Bonjour code on another platform,
  dnl just add -ldns_sd to LIBS manually.
  fi
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
-@@ -60,7 +60,7 @@
+diff -urNp -x '*.orig' postgresql-13.6.org/src/Makefile.global.in postgresql-13.6/src/Makefile.global.in
+--- postgresql-13.6.org/src/Makefile.global.in 2022-04-04 17:57:53.704326629 +0200
++++ postgresql-13.6/src/Makefile.global.in     2022-04-04 17:57:57.922336382 +0200
+@@ -172,6 +172,7 @@ includedir_internal = $(pkgincludedir)/i
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
++BONJOUR_LIBS            = @BONJOUR_LIBS@
+ ##########################################################################
+ #
+diff -urNp -x '*.orig' postgresql-13.6.org/src/backend/Makefile postgresql-13.6/src/backend/Makefile
+--- postgresql-13.6.org/src/backend/Makefile   2022-02-07 22:17:41.000000000 +0100
++++ postgresql-13.6/src/backend/Makefile       2022-04-04 17:57:57.921336380 +0200
+@@ -63,7 +63,7 @@ ifneq ($(PORTNAME), win32)
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
  
  endif
  endif
---- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
-@@ -216,6 +216,7 @@
- PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
- PTHREAD_LIBS          = @PTHREAD_LIBS@
-+BONJOUR_LIBS            = @BONJOUR_LIBS@
- ##########################################################################
- #
index 08c67141352ca5679caac0d4b51168640416e332..fea63c7597a31bee31746fc3abdcd7e16cee41a6 100644 (file)
@@ -46,6 +46,7 @@ Patch4:               postgresql-tests.patch
 Patch5:                postgresql-heimdal.patch
 Patch6:                postgresql-link.patch
 Patch7:                socket-dir-fixes.patch
+Patch8:                postgresql-autoconf.patch
 URL:           http://www.postgresql.org/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
@@ -71,9 +72,9 @@ BuildRequires:        ossp-uuid-devel
 BuildRequires: pam-devel
 %{?with_perl:BuildRequires:    perl-devel}
 %if %{with python}
-BuildRequires: python >= 1:2.3
-BuildRequires: python-devel >= 1:2.3
-BuildRequires: python-modules >= 1:2.3
+BuildRequires: python3
+BuildRequires: python3-devel
+BuildRequires: python3-modules
 %endif
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.671
@@ -84,8 +85,8 @@ BuildRequires:        zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(pre): /bin/id
 Requires(pre): /usr/bin/getgid
-Requires(triggerpostun):       /bin/id
-Requires(triggerpostun):       /usr/sbin/usermod
+Requires(post):        /bin/id
+Requires(post):        /usr/sbin/usermod
 Requires:      %{name}-clients = %{version}-%{release}
 Requires:      %{name}-dirs = %{version}-%{release}
 Requires:      postgresql-libs >= %{version}-%{release}
@@ -501,6 +502,7 @@ Różne moduły dołączone do PostgreSQL-a.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 # force rebuild of bison/flex files
 find src -name \*.l -o -name \*.y | xargs touch
@@ -591,8 +593,8 @@ install -d howto
 tar zxf %{SOURCE2} -C howto
 
 %if %{with python}
-%py_comp $RPM_BUILD_ROOT%{py_libdir}
-%py_ocomp $RPM_BUILD_ROOT%{py_libdir}
+%py3_comp $RPM_BUILD_ROOT%{py3_libdir}
+%py3_ocomp $RPM_BUILD_ROOT%{py3_libdir}
 %endif
 
 # find locales
@@ -887,7 +889,7 @@ fi
 %if %{with python}
 %files module-plpython -f plpython-%{pgsqlversion}.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{moduledir}/plpython2.so
+%attr(755,root,root) %{moduledir}/plpython3.so
 %{extensiondir}/plpython*--*.sql
 %{extensiondir}/plpython*.control
 %endif
@@ -1054,8 +1056,8 @@ fi
 %{extensiondir}/hstore_plperlu.control
 %endif
 %if %{with python}
-%attr(755,root,root) %{moduledir}/hstore_plpython2.so
-%attr(755,root,root) %{moduledir}/ltree_plpython2.so
+%attr(755,root,root) %{moduledir}/hstore_plpython3.so
+%attr(755,root,root) %{moduledir}/ltree_plpython3.so
 %{extensiondir}/hstore_plpythonu--*.sql
 %{extensiondir}/hstore_plpythonu.control
 %{extensiondir}/hstore_plpython2u--*.sql