]> TLD Linux GIT Repositories - packages/python-PyQt5.git/commitdiff
- allow bootstrap build without BRing myself
authorMarcin Krol <hawk@tld-linux.org>
Sun, 1 Sep 2019 13:37:18 +0000 (15:37 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 1 Sep 2019 13:37:18 +0000 (15:37 +0200)
python-PyQt5.spec

index 711c134b3ad985aeef89c67a3c12cf1460feda36..8e1a424bdd12c327f6736beef907ce96ef6304a3 100644 (file)
@@ -4,6 +4,7 @@
 %bcond_without python3         # CPython 3.x modules
 %bcond_with    enginio         # Qt5Enginio support
 %bcond_without webkit          # Qt5WebKit support
+%bcond_with    bootstrap       # bootstrap bconds - don't BR myself
 
 %define                module  PyQt5
 # minimal required sip version
@@ -60,12 +61,14 @@ BuildRequires:      pkgconfig
 # configure.py does: "from PyQt5 import sip" but sip doesn't provide PyQt5/__init__.py file,
 # and thus sip cannot be import. That's why we require python-PyQt5 (which provides __init__.py)
 # here. Only for python2 since python3 can import from directory without __init__.py file.
+%if !%{with bootstrap}
 %{?with_python2:BuildRequires:  python-PyQt5 >= 5.11.2}
-BuildRequires: python-dbus-devel >= 0.80
 BuildRequires: python-PyQt5-sip >= %{sip_ver}
+BuildRequires: python3-PyQt5-sip >= %{sip_ver}
+%endif
+BuildRequires: python-dbus-devel >= 0.80
 BuildRequires: python-sip-devel >= %{sip_ver}
 BuildRequires: python3-dbus >= 0.80
-BuildRequires: python3-PyQt5-sip >= %{sip_ver}
 BuildRequires: python3-sip-devel >= %{sip_ver}
 BuildRequires: qt5-build >= %{qt_ver}
 BuildRequires: qt5-qmake >= %{qt_ver}