]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- updated to 2.5.0
[packages/qemu.git] / qemu.spec
index de1ebf4a93a4b749722396add4bc3be2d0a370f1..cfa48fd27e38b01af225a22d5779ae088ee4b141 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,13 +1,13 @@
+# TODO: archipelago (libxseg) on bcond (GPL v3 vs v2-only conflict)
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
-%bcond_without glx             # OpenGL/GLX support
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
-%bcond_with    gtk3            # Do not build GTK+ UI
-%bcond_with    vte             # VTE support in GTK+ UI
+%bcond_without gtk3            # Do not build GTK+ UI
+%bcond_without vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 %bcond_without oss             # OSS audio support
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.2.0
-Release:       2
-License:       GPL v2+
+Version:       2.5.0
+Release:       1
+License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: f7a5e2da22d057eb838a91da7aff43c8
-Source2:       %{name}.binfmt
+# Source0-md5: f469f2330bbe76e3e39db10e9ac4f8db
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -51,18 +50,18 @@ Source10:   ksmtuned.conf
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-system-libcacard.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
 # Proof of concept, for reference, do not remove
 Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
-%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
+BuildRequires: OpenGL-GLX-devel
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
-BuildRequires: bcc
+BuildRequires: bcc >= 0.16.21-2
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
+BuildRequires: bzip2-devel
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
@@ -89,8 +88,10 @@ BuildRequires:       libuuid-devel
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
 %{?with_smartcard:BuildRequires:       nss-devel >= 3.12.8}
+BuildRequires: numactl-devel
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
+BuildRequires: pixman-devel >= 0.21.8
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.644
@@ -151,6 +152,7 @@ Requires:   SDL2 \
 Requires:      libseccomp >= 2.1.0 \
 %endif \
 Requires:      libusb >= 1.0.13 \
+Requires:      pixman >= 0.21.8 \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
@@ -163,8 +165,9 @@ Requires:   gtk+3 >= 3.0.0 \
 %{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
-# some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
+# don't strip/chrpath anything in there; these are boot images, roms etc
+%define                _noautostrip    .*%{_datadir}/qemu/.*
+%define                _noautochrpath  .*%{_datadir}/qemu/.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -243,6 +246,19 @@ images.
 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
 na obrazach dysków.
 
+%package ivshmem
+Summary:       Client and server for QEMU ivshmem device
+Summary(pl.UTF-8):     Klient i serwer dla urządzeia ivshmem QEMU
+Group:         Development/Tools
+
+%description ivshmem
+This package provides client and server tools for QEMU's ivshmem
+device.
+
+%description ivshmem -l pl.UTF-8
+Ten pakiet udostępnia działające z linii poleceń narzędzia dla
+urządzenia ivshmem QEMU.
+
 %package user
 Summary:       QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
@@ -657,6 +673,18 @@ Requires:  %{name}-common = %{version}-%{release}
 %description module-block-curl -l pl.UTF-8
 Moduł QEMU dla urządeń blokowych typu 'curl'.
 
+%package module-block-dmg
+Summary:       QEMU module for 'dmg' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'dmg'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-dmg
+'dmg' block device support for QEMU.
+
+%description module-block-dmg -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'dmg'.
+
 %package module-block-gluster
 Summary:       QEMU module for 'gluster' block devices
 Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'gluster'
@@ -714,9 +742,6 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch2 -p0
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-
-%{__mv} libcacard libcacard-use-system-lib
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
@@ -742,14 +767,13 @@ ln -s ../error.h qapi/error.h
        --enable-fdt \
        %{__enable_disable glusterfs} \
        %{__enable_disable iscsi libiscsi} \
-       %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       %{__enable_disable smartcard smartcard-nss} \
+       %{__enable_disable smartcard smartcard} \
        --enable-tpm \
        --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
        %{__enable_disable usbredir usb-redir} \
@@ -759,7 +783,6 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       --enable-vnc-tls \
        %{!?with_vte:--disable-vte} \
        --enable-kvm \
        %{__enable_disable xen} \
@@ -768,7 +791,6 @@ ln -s ../error.h qapi/error.h
        %{__enable_disable libnfs} \
        --enable-lzo \
        %{__enable_disable snappy} \
-       --enable-quorum \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
        --interp-prefix=%{_libdir}/qemu/lib-%%M \
 %if %{without gtk2} && %{without gtk3}
@@ -816,27 +838,6 @@ install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 
-for i in dummy \
-%ifnarch %{ix86} %{x8664}
-       qemu-i386 \
-%endif
-%ifnarch arm
-       qemu-arm \
-%endif
-%ifnarch ppc ppc64
-       qemu-ppc \
-%endif
-%ifnarch sparc sparc64
-       qemu-sparc \
-%endif
-%ifnarch sh4
-       qemu-sh4 \
-%endif
-; do
-       test $i = dummy && continue
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
-done < %{SOURCE2}
-
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
@@ -878,20 +879,16 @@ if [ "$1" = "0" ]; then
        %groupremove kvm
 fi
 
-%triggerpostun common -- qemu-common < 1.6.1-4
-
 %files
 %defattr(644,root,root,755)
 
 %files common -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html qmp-commands.txt
+%doc LICENSE README qemu-doc.html qemu-tech.html qmp-commands.txt
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
-%dir %{_sysconfdir}/qemu
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
@@ -938,11 +935,12 @@ fi
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/vgabios.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
+%{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
-%{_datadir}/%{name}/vgabios.bin
 
 %dir %{_libdir}/%{name}
 
@@ -951,9 +949,13 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-img
 %{_mandir}/man1/qemu-img.1*
 
+%files ivshmem
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ivshmem-client
+%attr(755,root,root) %{_bindir}/ivshmem-server
+
 %files user
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
@@ -981,6 +983,7 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
+%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_bindir}/qemu-unicore32
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
@@ -1032,7 +1035,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
-#%attr(755,root,root) %{_bindir}/qemu-system-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
 %{_datadir}/%{name}/u-boot.e500
 
@@ -1080,11 +1082,16 @@ fi
 %files guest-agent
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man8/qemu-ga.8*
 
 %files module-block-curl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/block-curl.so
 
+%files module-block-dmg
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-dmg.so
+
 %if %{with glusterfs}
 %files module-block-gluster
 %defattr(644,root,root,755)