]> TLD Linux GIT Repositories - packages/qemu.git/commitdiff
- updated to 2.5.0
authorMarcin Krol <hawk@tld-linux.org>
Wed, 20 Jan 2016 11:36:30 +0000 (11:36 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 20 Jan 2016 11:36:30 +0000 (11:36 +0000)
qemu-cflags.patch
qemu.spec

index f9a9ecad341702a9536cc8b162cbe11234b66774..b118f7a9b3b01bac7edb576dcb9173b453f68cc8 100644 (file)
@@ -1,6 +1,6 @@
---- qemu-1.7.0/configure.orig  2013-11-27 23:15:55.000000000 +0100
-+++ qemu-1.7.0/configure       2013-12-15 08:37:16.187664605 +0100
-@@ -332,10 +332,6 @@
+--- qemu-2.5.0/configure.orig  2015-12-16 22:04:48.000000000 +0000
++++ qemu-2.5.0/configure       2016-01-20 08:44:46.108727000 +0000
+@@ -418,10 +418,6 @@
  QEMU_CFLAGS="-Wstrict-prototypes -Wredundant-decls $QEMU_CFLAGS"
  QEMU_CFLAGS="-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $QEMU_CFLAGS"
  QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/include"
  
  # make source path absolute
  source_path=`cd "$source_path"; pwd`
-@@ -3549,8 +3545,6 @@
+@@ -4498,12 +4494,8 @@
+ # After here, no more $cc or $ld runs
  if test "$gcov" = "yes" ; then
-   CFLAGS="-fprofile-arcs -ftest-coverage -g $CFLAGS"
+-  CFLAGS="-fprofile-arcs -ftest-coverage -g $CFLAGS"
++  CFLAGS="-fprofile-arcs -ftest-coverage $CFLAGS"
    LDFLAGS="-fprofile-arcs -ftest-coverage $LDFLAGS"
--elif test "$debug" = "no" ; then
+-elif test "$fortify_source" = "yes" ; then
 -  CFLAGS="-O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $CFLAGS"
+-elif test "$debug" = "no"; then
+-  CFLAGS="-O2 $CFLAGS"
  fi
  
+ ##########################################
index 171f56577604de7a694e19ec13d3f1c2b8a2b007..cfa48fd27e38b01af225a22d5779ae088ee4b141 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.4.0
+Version:       2.5.0
 Release:       1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 186ee8194140a484a455f8e3c74589f4
+# Source0-md5: f469f2330bbe76e3e39db10e9ac4f8db
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -50,9 +50,8 @@ Source10:     ksmtuned.conf
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-system-libcacard.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
 # Proof of concept, for reference, do not remove
 Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
@@ -247,6 +246,19 @@ images.
 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
 na obrazach dysków.
 
+%package ivshmem
+Summary:       Client and server for QEMU ivshmem device
+Summary(pl.UTF-8):     Klient i serwer dla urządzeia ivshmem QEMU
+Group:         Development/Tools
+
+%description ivshmem
+This package provides client and server tools for QEMU's ivshmem
+device.
+
+%description ivshmem -l pl.UTF-8
+Ten pakiet udostępnia działające z linii poleceń narzędzia dla
+urządzenia ivshmem QEMU.
+
 %package user
 Summary:       QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
@@ -730,9 +742,6 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch2 -p0
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-
-%{__mv} libcacard libcacard-use-system-lib
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
@@ -764,7 +773,7 @@ ln -s ../error.h qapi/error.h
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       %{__enable_disable smartcard smartcard-nss} \
+       %{__enable_disable smartcard smartcard} \
        --enable-tpm \
        --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
        %{__enable_disable usbredir usb-redir} \
@@ -774,7 +783,6 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       --enable-vnc-tls \
        %{!?with_vte:--disable-vte} \
        --enable-kvm \
        %{__enable_disable xen} \
@@ -941,6 +949,11 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-img
 %{_mandir}/man1/qemu-img.1*
 
+%files ivshmem
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ivshmem-client
+%attr(755,root,root) %{_bindir}/ivshmem-server
+
 %files user
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-aarch64
@@ -970,6 +983,7 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
+%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_bindir}/qemu-unicore32
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
@@ -1068,6 +1082,7 @@ fi
 %files guest-agent
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man8/qemu-ga.8*
 
 %files module-block-curl
 %defattr(644,root,root,755)