]> TLD Linux GIT Repositories - packages/qemu.git/commitdiff
- updated to 7.2.0
authorMarcin Krol <hawk@tld-linux.org>
Wed, 8 Feb 2023 23:28:01 +0000 (00:28 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 8 Feb 2023 23:28:01 +0000 (00:28 +0100)
qemu-no-fortify.patch
qemu-user-execve.patch
qemu-xattr.patch
qemu.spec

index 587f30a776e9d6ccba37cfa93a2dac750c5532ae..aa69ee07e7568e93fda2ee6d479a18a6ede4cd90 100644 (file)
@@ -1,7 +1,7 @@
-diff -ur qemu-7.1.0.orig/configure qemu-7.1.0/configure
---- qemu-7.1.0.orig/configure  2022-09-02 16:07:34.783540992 +0200
-+++ qemu-7.1.0/configure       2022-09-02 16:11:03.625989858 +0200
-@@ -299,7 +299,6 @@
+diff -ur qemu-7.2.0.orig/configure qemu-7.2.0/configure
+--- qemu-7.2.0.orig/configure  2023-02-08 21:21:36.128176965 +0100
++++ qemu-7.2.0/configure       2023-02-08 21:22:06.431170014 +0100
+@@ -275,7 +275,6 @@
  debug_tcg="no"
  sanitizers="no"
  tsan="no"
@@ -9,7 +9,7 @@ diff -ur qemu-7.1.0.orig/configure qemu-7.1.0/configure
  EXESUF=""
  modules="no"
  prefix="/usr/local"
-@@ -819,7 +818,6 @@
+@@ -789,7 +788,6 @@
        debug_tcg="yes"
        meson_option_parse --enable-debug-mutex ""
        meson_option_add -Doptimization=0
@@ -17,7 +17,7 @@ diff -ur qemu-7.1.0.orig/configure qemu-7.1.0/configure
    ;;
    --enable-sanitizers) sanitizers="yes"
    ;;
-@@ -1743,20 +1741,6 @@
+@@ -1691,20 +1689,6 @@
      ccache_cpp2=yes
  fi
  
@@ -38,7 +38,7 @@ diff -ur qemu-7.1.0.orig/configure qemu-7.1.0/configure
  ##########################################
  # checks for sanitizers
  
-@@ -2246,10 +2230,6 @@
+@@ -2207,10 +2191,6 @@
  
  write_c_skeleton
  
index bbaf83e694d8a2368bb9089a65fde958f068d9ed..4faf7359d475e817c9d654cd2862ad58c1c07e85 100644 (file)
@@ -45,18 +45,18 @@ Reviewed-by: Laurent Vivier <laurent@vivier.eu>
 v3 changes:
        - rebase the patchset against current code
 
-diff -urNpa qemu-7.1.0.orig/linux-user/main.c qemu-7.1.0/linux-user/main.c
---- qemu-7.1.0.orig/linux-user/main.c  2022-09-02 16:12:25.825166528 +0200
-+++ qemu-7.1.0/linux-user/main.c       2022-09-02 16:12:55.593230519 +0200
+diff -urNpa qemu-7.2.0.orig/linux-user/main.c qemu-7.2.0/linux-user/main.c
+--- qemu-7.2.0.orig/linux-user/main.c  2023-02-08 21:23:07.149156085 +0100
++++ qemu-7.2.0/linux-user/main.c       2023-02-08 21:23:36.695149312 +0100
 @@ -123,6 +123,7 @@ static void usage(int exitcode);
  
  static const char *interp_prefix = CONFIG_QEMU_INTERP_PREFIX;
  const char *qemu_uname_release;
 +const char *qemu_execve_path;
  
+ #if !defined(TARGET_DEFAULT_STACK_SIZE)
  /* XXX: on x86 MAP_GROWSDOWN only works if ESP <= address + 32, so
-    we allocate a bigger stack. Need a better solution, for example
-@@ -356,6 +357,11 @@ static void handle_arg_guest_base(const
+@@ -362,6 +363,11 @@ static void handle_arg_guest_base(const
      have_guest_base = true;
  }
  
@@ -68,7 +68,7 @@ diff -urNpa qemu-7.1.0.orig/linux-user/main.c qemu-7.1.0/linux-user/main.c
  static void handle_arg_reserved_va(const char *arg)
  {
      char *p;
-@@ -458,6 +464,8 @@ static const struct qemu_argument arg_ta
+@@ -464,6 +470,8 @@ static const struct qemu_argument arg_ta
       "uname",      "set qemu uname release string to 'uname'"},
      {"B",          "QEMU_GUEST_BASE",  true,  handle_arg_guest_base,
       "address",    "set guest_base address to 'address'"},
@@ -77,10 +77,10 @@ diff -urNpa qemu-7.1.0.orig/linux-user/main.c qemu-7.1.0/linux-user/main.c
      {"R",          "QEMU_RESERVED_VA", true,  handle_arg_reserved_va,
       "size",       "reserve 'size' bytes for guest virtual address space"},
      {"d",          "QEMU_LOG",         true,  handle_arg_log,
-diff -urNpa qemu-7.1.0.orig/linux-user/syscall.c qemu-7.1.0/linux-user/syscall.c
---- qemu-7.1.0.orig/linux-user/syscall.c       2022-09-02 16:12:25.833166545 +0200
-+++ qemu-7.1.0/linux-user/syscall.c    2022-09-02 16:12:55.595230523 +0200
-@@ -8330,6 +8330,109 @@ static target_timer_t get_timer_id(abi_l
+diff -urNpa qemu-7.2.0.orig/linux-user/syscall.c qemu-7.2.0/linux-user/syscall.c
+--- qemu-7.2.0.orig/linux-user/syscall.c       2023-02-08 21:23:07.150156084 +0100
++++ qemu-7.2.0/linux-user/syscall.c    2023-02-08 21:28:50.327077355 +0100
+@@ -8378,6 +8378,109 @@ static target_timer_t get_timer_id(abi_l
      return timerid;
  }
  
@@ -190,23 +190,29 @@ diff -urNpa qemu-7.1.0.orig/linux-user/syscall.c qemu-7.1.0/linux-user/syscall.c
  static int target_to_host_cpu_mask(unsigned long *host_mask,
                                     size_t host_size,
                                     abi_ulong target_addr,
-@@ -8843,7 +8946,12 @@ static abi_long do_syscall1(CPUArchState
-              * before the execve completes and makes it the other
+@@ -8933,9 +9036,17 @@ static abi_long do_syscall1(CPUArchState
               * program's problem.
               */
--            ret = get_errno(safe_execve(p, argp, envp));
-+            if (qemu_execve_path && *qemu_execve_path) {
-+                ret = get_errno(qemu_execve(p, argp, envp));
-+            } else {
-+                ret = get_errno(safe_execve(p, argp, envp));
-+            }
-+
+             if (is_proc_myself(p, "exe")) {
+-                ret = get_errno(safe_execve(exec_path, argp, envp));
++                if (qemu_execve_path && *qemu_execve_path) {
++                    ret = get_errno(qemu_execve(exec_path, argp, envp));
++                } else {
++                    ret = get_errno(safe_execve(exec_path, argp, envp));
++                }
+             } else {
+-                ret = get_errno(safe_execve(p, argp, envp));
++                if (qemu_execve_path && *qemu_execve_path) {
++                    ret = get_errno(qemu_execve(p, argp, envp));
++                } else {
++                    ret = get_errno(safe_execve(p, argp, envp));
++                }
+             }
              unlock_user(p, arg1, 0);
  
-             goto execve_end;
-diff -urNpa qemu-7.1.0.orig/linux-user/user-internals.h qemu-7.1.0/linux-user/user-internals.h
---- qemu-7.1.0.orig/linux-user/user-internals.h        2022-09-02 16:12:25.822166522 +0200
-+++ qemu-7.1.0/linux-user/user-internals.h     2022-09-02 16:12:55.595230523 +0200
+diff -urNpa qemu-7.2.0.orig/linux-user/user-internals.h qemu-7.2.0/linux-user/user-internals.h
+--- qemu-7.2.0.orig/linux-user/user-internals.h        2023-02-08 21:23:07.148156085 +0100
++++ qemu-7.2.0/linux-user/user-internals.h     2023-02-08 21:23:36.697149312 +0100
 @@ -27,6 +27,7 @@ void init_task_state(TaskState *ts);
  void task_settid(TaskState *);
  void stop_all_tasks(void);
index b76f5f94435c68487cba318952dd9867ad7bb1d3..96dbae18cf28bdbccc645028a7aa9aa913121327 100644 (file)
@@ -1,15 +1,15 @@
-diff -ur qemu-7.1.0.orig/fsdev/virtfs-proxy-helper.c qemu-7.1.0/fsdev/virtfs-proxy-helper.c
---- qemu-7.1.0.orig/fsdev/virtfs-proxy-helper.c        2022-09-02 16:14:57.215491914 +0200
-+++ qemu-7.1.0/fsdev/virtfs-proxy-helper.c     2022-09-02 16:15:29.826562009 +0200
+diff -ur qemu-7.2.0.orig/fsdev/virtfs-proxy-helper.c qemu-7.2.0/fsdev/virtfs-proxy-helper.c
+--- qemu-7.2.0.orig/fsdev/virtfs-proxy-helper.c        2023-02-08 21:30:45.812050860 +0100
++++ qemu-7.2.0/fsdev/virtfs-proxy-helper.c     2023-02-08 21:31:51.135037450 +0100
 @@ -10,6 +10,7 @@
   */
  
  #include "qemu/osdep.h"
 +#include "qemu/xattr.h"
+ #include <glib/gstdio.h>
  #include <sys/resource.h>
  #include <getopt.h>
- #include <syslog.h>
-@@ -22,7 +23,6 @@
+@@ -23,7 +24,6 @@
  #endif
  #include <cap-ng.h>
  #include "qemu/sockets.h"
index 4d7c9cad0180848d32da4a4c203ba6eb6c6a79eb..204801091ebb5ab1f504c6a6448bca7a48e80a0f 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       7.1.0
+Version:       7.2.0
 Release:       1
 License:       GPL v2, BSD (edk2 firmware files)
 Group:         Applications/Emulators
 Source0:       https://download.qemu.org/%{name}-%{version}.tar.xz
-# Source0-md5: 3be5458a9171b4ec5220c65d5d52bdcf
+# Source0-md5: 7630d6a9eba7ab2bcb9979d6d24c2697
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -98,7 +98,6 @@ BuildRequires:        libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
 %{?with_seccomp:BuildRequires: libseccomp-devel >= 2.3.0}
 BuildRequires: libssh-devel >= 0.8
-BuildRequires: libslirp-devel >= 4.0.0
 # for tests only
 #BuildRequires:        libtasn1-devel
 BuildRequires: libusb-devel >= 1.0.22
@@ -189,7 +188,6 @@ Requires:   libfdt >= 1.4.2 \
 %if %{with seccomp} \
 Requires:      libseccomp >= 2.3.0 \
 %endif \
-Requires:      libslirp >= 4.0.0 \
 Requires:      libusb >= 1.0.22 \
 Requires:      pixman >= 0.21.8 \
 %if %{with spice} \
@@ -995,7 +993,6 @@ build dynamic \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
        %{__enable_disable seccomp} \
-       --enable-slirp=system \
        %{__enable_disable spice} \
        %{__enable_disable smartcard} \
        %{__enable_disable snappy} \
@@ -1028,7 +1025,6 @@ build static \
        --disable-nettle \
        --disable-pie \
        --disable-sdl \
-       --disable-slirp \
        --disable-spice \
        --disable-system \
        --disable-tools \