]> TLD Linux GIT Repositories - packages/qemu.git/commitdiff
- updated to 2.1.2
authorMarcin Krol <hawk@tld-linux.org>
Thu, 9 Oct 2014 06:37:39 +0000 (06:37 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 9 Oct 2014 06:37:39 +0000 (06:37 +0000)
qemu-system-libcacard.patch
qemu.spec

index 98c11b765886b25371e9fc56c41a4490b146995d..e629fa827c5100de07718d81f9cfd63cf48a4aad 100644 (file)
@@ -1,43 +1,36 @@
 --- qemu-1.7.0/configure.orig  2013-12-15 08:38:07.584329114 +0100
 +++ qemu-1.7.0/configure       2013-12-15 08:54:19.730954984 +0100
-@@ -3123,9 +3123,10 @@
- #include <pk11pub.h>
+@@ -3543,9 +3543,11 @@
  int main(void) { PK11_FreeSlot(0); return 0; }
  EOF
--    smartcard_includes="-I\$(SRC_PATH)/libcacard"
--    libcacard_libs="$($pkg_config --libs nss 2>/dev/null) $glib_libs"
--    libcacard_cflags="$($pkg_config --cflags nss 2>/dev/null) $glib_cflags"
+     # FIXME: do not include $glib_* in here
 +    libcacard_libs="$($pkg_config --libs libcacard 2>/dev/null)"
 +    libcacard_cflags="$($pkg_config --cflags libcacard 2>/dev/null)"
-+    nss_libs="$($pkg_config --libs nss 2>/dev/null) $glib_libs"
-+    nss_cflags="$($pkg_config --cflags nss 2>/dev/null) $glib_cflags"
-     test_cflags="$libcacard_cflags"
+     nss_libs="$($pkg_config --libs nss 2>/dev/null) $glib_libs"
+     nss_cflags="$($pkg_config --cflags nss 2>/dev/null) $glib_cflags"
+-    test_cflags="$nss_cflags"
++    test_cflags="$libcacard_cflags"
      # The header files in nss < 3.13.3 have a bug which causes them to
      # emit a warning. If we're going to compile QEMU with -Werror, then
-@@ -3136,11 +3137,10 @@
-     fi
-     if test -n "$libtool" &&
+     # test that the headers don't have this bug. Otherwise we would pass
+@@ -3557,6 +3559,8 @@
         $pkg_config --atleast-version=3.12.8 nss && \
--      compile_prog "$test_cflags" "$libcacard_libs"; then
-+      compile_prog "$test_cflags" "$nss_libs"; then
+       compile_prog "$test_cflags" "$nss_libs"; then
          smartcard_nss="yes"
--        QEMU_CFLAGS="$QEMU_CFLAGS $libcacard_cflags"
--        QEMU_INCLUDES="$QEMU_INCLUDES $smartcard_includes"
--        libs_softmmu="$libcacard_libs $libs_softmmu"
 +        QEMU_CFLAGS="$QEMU_CFLAGS $libcacard_cflags $nss_cflags"
 +        libs_softmmu="$libcacard_libs $nss_libs $libs_softmmu"
      else
          if test "$smartcard_nss" = "yes"; then
              feature_not_found "nss"
-@@ -4082,6 +4082,8 @@
+@@ -4574,6 +4578,8 @@
+ if test "$smartcard_nss" = "yes" ; then
    echo "CONFIG_SMARTCARD_NSS=y" >> $config_host_mak
-   echo "libcacard_libs=$libcacard_libs" >> $config_host_mak
-   echo "libcacard_cflags=$libcacard_cflags" >> $config_host_mak
-+  echo "nss_libs=$nss_libs" >> $config_host_mak
-+  echo "nss_cflags=$nss_cflags" >> $config_host_mak
++  echo "LIBCACARD_LIBS=$libcacard_libs" >> $config_host_mak
++  echo "LIBCACARD_CFLAGS=$libcacard_cflags" >> $config_host_mak
+   echo "NSS_LIBS=$nss_libs" >> $config_host_mak
+   echo "NSS_CFLAGS=$nss_cflags" >> $config_host_mak
  fi
- if test "$libusb" = "yes" ; then
 --- qemu-1.3.0/Makefile.orig   2012-12-03 20:37:05.000000000 +0100
 +++ qemu-1.3.0/Makefile        2012-12-16 11:08:58.001201236 +0100
 @@ -111,9 +111,6 @@
index f9a3dc4a1f74265df47fccfbb26f1262b8773b9e..c5605808fa8de7f2ea9592237d3643d93d2580c5 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.0.0
-Release:       2
+Version:       2.1.2
+Release:       1
 License:       GPL v2+
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 2790f44fd76da5de5024b4aafeb594c2
+# Source0-md5: 0ff197c4ed4b695620bc4734e77c888f
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
@@ -77,7 +77,7 @@ BuildRequires:        libcap-devel
 BuildRequires: libcap-ng-devel
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
-%{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.4.0}
+%{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
 BuildRequires: libjpeg-devel
 %{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
@@ -756,6 +756,7 @@ ln -s ../error.h qapi/error.h
 %if %{without gtk2} && %{without gtk3}
        --disable-gtk
 %else
+       --enable-gtk \
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
@@ -954,6 +955,7 @@ fi
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/u-boot.e500
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
@@ -990,6 +992,7 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
+%attr(755,root,root) %{_bindir}/qemu-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-s390x
 %attr(755,root,root) %{_bindir}/qemu-sh4
 %attr(755,root,root) %{_bindir}/qemu-sh4eb