]> TLD Linux GIT Repositories - packages/rpm-build-tools.git/commitdiff
- fix -at option with git (get last git tag)
authorBartosz Świątek <shadzik@tld-linux.org>
Tue, 10 Jul 2012 13:48:31 +0000 (15:48 +0200)
committerBartosz Świątek <shadzik@tld-linux.org>
Tue, 10 Jul 2012 13:48:31 +0000 (15:48 +0200)
kde4send2builders.sh

index 4b5cbf15c74aeafa64f4b41afd3ab1edac1df94b..47be9f298c7f4f8b8852f48a53509b404dfcd8f9 100755 (executable)
@@ -177,7 +177,10 @@ fi
 if [ "$ATAG" == "yes" ]; then
        for spec in $specs; do
                PKG=$(echo $spec |sed -e 's/.spec//g')
-               LAST_AUTOTAG=$(cd $SPECDIR/packages && ksh ./builder -g -ns $PKG/$spec >/dev/null 2>&1 && cvs status -v $PKG/$spec | awk -vdist=$disttag '!/Sticky/ && $1 ~ "^auto-" dist "-"{if (!a++) print $1}')
+               if [ ! -d $PKG ]; then
+                       git clone git@git.tld-linux.org:packages/${PKG}
+               fi
+               LAST_AUTOTAG=$(cd $PKG && git tag |tail -n 1)
                sleep 1
                SENDPRIO="$SENDPRIO $spec:$LAST_AUTOTAG "
        done