]> TLD Linux GIT Repositories - packages/rpm-build-tools.git/commitdiff
- more directories to trigger systemd excludes master
authorMarcin Krol <hawk@tld-linux.org>
Wed, 3 Apr 2024 18:39:29 +0000 (20:39 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 3 Apr 2024 18:39:29 +0000 (20:39 +0200)
builder.sh
fetchsrc_request.sh

index 587d275c9ba413f0770529a01c0d846a1c6613c0..a6eb3d72279dc333a5ca7eff96c3ce7e5fd2e645 100755 (executable)
@@ -1688,7 +1688,7 @@ build_package() {
        local specdir=$(insert_gitlog $SPECFILE)
        ulimit -c unlimited
        # If required exclude directories with systemd related files from package contents
-       if grep -q -E '(lib/(systemd|tmpfiles.d)|systemd(unitdir|userunitdir|tmpfilesdir))' $specdir/$SPECFILE; then
+       if grep -q -E '(lib/(systemd|binfmt.d|sysctl.d|sysusers.d|tmpfiles.d)|systemd(unitdir|userunitdir|tmpfilesdir))' $specdir/$SPECFILE; then
                sed -i -e '/^%exclude_systemd_files/d; /^%files/s/$/\n%exclude_systemd_files/g;' $specdir/$SPECFILE
        fi
        # Enable/disable distro wide bconds based on ~/.distbcond
index 8d3e5e23dd0753d9bc2c7da86ea8d71d285670a6..21296361cc1e47384f01f0cbaa82565f388970a5 100755 (executable)
@@ -1,41 +1,15 @@
 #!/bin/sh
-# $Id$
-#
-# Sending by
-MAILER='/usr/sbin/sendmail'
-# MAILER='/usr/bin/msmtp'
-# Sending via
-VIA="SENDMAIL"
-#VIA="localhost"
-VIA_ARGS=""
-#VIA_ARGS="some additional flags"
-# e.g. for msmtp:
-# VIA_ARGS='-a gmail'
-#
-# DISTFILES EMAIL
-DMAIL="df@tld-linux.org"
-#
-# CVS LOGIN or fill it by hand :)
+
+# GIT LOGIN or fill it by hand :)
 tmp=$(git config user.email)
-LOGIN=${tmp%@*}
-#LOGIN="djrzulf"
-#
-# HOST
-HOST=`hostname -f`
-#HOST="knycz.net"
-#
-# functions
+#LOGIN=${tmp%@*}
+LOGIN="hawk"
+#HOST=`hostname -f`
+HOST="src.tld-linux.org"
 
-usage()
-{
+if [ "$#" = 0 ]; then
        echo "Usage: fetchsrc_request file.spec [BRANCH]"
        echo
-}
-
-#------------------
-# main()
-if [ "$#" = 0 ]; then
-       usage
        exit 1
 fi
 if [ "$2" != "" ]; then
@@ -49,37 +23,5 @@ fi
 SPEC="$(basename $1)"
 SPEC=${SPEC%.spec}
 
-if [ "$VIA" = "SENDMAIL" ]; then
-       echo >&2 "Requesting $SPEC:$BRANCH via $MAILER ${VIA_ARGS:+ ($VIA_ARGS)}"
-       cat <<EOF | "$MAILER" -t -i $VIA_ARGS
-To: $DMAIL
-From: $LOGIN <$LOGIN@$HOST>
-Subject: fetchsrc_request notify
-X-distfiles-request: yes
-X-Login: $LOGIN
-X-Package: $SPEC
-X-Branch: $BRANCH
-X-Flags: force-reply
-
-.
-EOF
-else
-       echo >&2 "Requesting $SPEC:$BRANCH via SMTP ($VIA:25)"
-       cat <<EOF | /usr/bin/nc $VIA 25 > /dev/null
-EHLO $HOST
-MAIL FROM: $LOGIN <$LOGIN@$HOST>
-RCPT TO: $DMAIL
-DATA
-To: $DMAIL
-Subject: fetchsrc_request notify
-X-distfiles-request: yes
-X-Login: $LOGIN
-X-Package: $SPEC
-X-Branch: $BRANCH
-X-Flags: force-reply
-
-.
-QUIT
-EOF
-fi
-
+echo >&2 "Requesting $SPEC:$BRANCH"
+curl -d "type=fetchsrc&from=$LOGIN&spec=$SPEC&branch=$BRANCH&flags=force-reply" -H "Content-Type: application/x-www-form-urlencoded" -X POST https://df.tld-linux.org/api/ >&2