]> TLD Linux GIT Repositories - packages/rpm-tld-macros.git/commitdiff
- fix PHP macros to use proper version of php-config
authorMarcin Krol <hawk@tld-linux.org>
Sat, 26 Sep 2020 19:44:20 +0000 (21:44 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 26 Sep 2020 19:44:20 +0000 (21:44 +0200)
macros.php
rpm-tld-macros.spec

index f2a83a35e525963b9e11d862463c28a50c9f07fd..31a0b1452d71e787eda68ee87be4d03a41ea3713 100644 (file)
@@ -15,9 +15,9 @@
 
 %php_pear_dir          /usr/share/pear
 %php_data_dir          /usr/share/php
-%php_extensiondir      %{expand:%%global php_extensiondir %(php-config --extension-dir 2>/dev/null || echo ERROR)}%php_extensiondir
-%php_sysconfdir                %{expand:%%global php_sysconfdir %(php-config --sysconfdir 2>/dev/null || echo ERROR)}%php_sysconfdir
-%php_includedir                %{expand:%%global php_includedir %(php-config --include-dir 2>/dev/null || echo ERROR)}%php_includedir
+%php_extensiondir      %{expand:%%global php_extensiondir %(php-config%{?php_suffix} --extension-dir 2>/dev/null || echo ERROR)}%php_extensiondir
+%php_sysconfdir                %{expand:%%global php_sysconfdir %(php-config%{?php_suffix} --sysconfdir 2>/dev/null || echo ERROR)}%php_sysconfdir
+%php_includedir                %{expand:%%global php_includedir %(php-config%{?php_suffix} --include-dir 2>/dev/null || echo ERROR)}%php_includedir
 
 # extract php/zend api versions
 %php_major_version     %{expand:%%global php_major_version %(awk '/#define PHP_MAJOR_VERSION/{print $3}' %{php_includedir}/main/php_version.h 2>/dev/null || echo ERROR)}%php_major_version
index e48208c78bf9260316e062669521a02e09171ad6..63b54968646001dee66cad1302fc5773eda7bcd9 100644 (file)
@@ -6,7 +6,7 @@ Summary:        TLD Linux RPM macros
 Summary(pl.UTF-8):     Makra RPM dla Linuksa TLD
 Name:          rpm-tld-macros
 Version:       %{rpm_macros_rev}
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         Development/Building
 Source0:       macros.tld