]> TLD Linux GIT Repositories - packages/rpm-tld-macros.git/commitdiff
- updated systemd macros from master, required before rpm.org migration rpm-4.5
authorMarcin Krol <hawk@tld-linux.org>
Wed, 6 Dec 2023 17:48:52 +0000 (18:48 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 6 Dec 2023 17:48:52 +0000 (18:48 +0100)
macros.systemd
rpm-tld-macros.spec

index 8eb65cfde7b54d9035dd80679fb2dde4a7ce1766..301a580f1ac2f54de3548a5680d39582e36753ca 100644 (file)
@@ -1,17 +1,78 @@
 # Disable all systemd related macros
 
+%systemd_requires %{nil}
+%systemd_ordering %{nil}
+%__systemd_someargs_0() %{nil}
+%__systemd_twoargs_2() %{nil}
+%systemd_post() %{nil}
+%systemd_user_post() %{nil}
+%systemd_preun() %{nil}
+%systemd_user_preun() %{nil}
+%systemd_postun() %{nil}
+%systemd_user_postun() %{nil}
+%systemd_postun_with_restart() %{nil}
+%systemd_user_postun_with_restart() %{nil}
+%udev_hwdb_update() %{nil}
+%udev_rules_update() %{nil}
+%journal_catalog_update() %{nil}
+%tmpfiles_create() %{nil}
+%sysusers_create() %{nil}
+%sysusers_create_inline() %{nil}
+%sysusers_create_package() %{nil}
+%tmpfiles_create_package() %{nil}
+%sysctl_apply() %{nil}
+%binfmt_apply() %{nil}
 %systemd_reload %{nil}
-%systemd_service_enable %{nil}
-%systemd_service_disable %{nil}
-%systemd_service %{nil}
-%systemd_service_start %{nil}
-%systemd_service_stop %{nil}
-%systemd_service_restart %{nil}
-%systemd_service_reload %{nil}
-%systemd_trigger %{nil}
-%systemd_post %{nil}
-%systemd_preun %{nil}
-%systemdunitdir %{nil}
-%systemduserunitdir %{nil}
-%systemdtmpfilesdir %{nil}
-%journal_catalog_update %{nil}
+%systemd_service_enable() %{nil}
+%systemd_service_disable() %{nil}
+%systemd_service() %{nil}
+%systemd_service_start() %{nil}
+%systemd_service_stop() %{nil}
+%systemd_service_restart() %{nil}
+%systemd_service_reload() %{nil}
+%systemd_trigger() %{nil}
+
+# Keep paths for systemd related files
+
+%_systemd_util_dir /lib/systemd
+%_unitdir /lib/systemd/system
+%_userunitdir /usr/lib/systemd/user
+%_presetdir /lib/systemd/system-preset
+%_userpresetdir /usr/lib/systemd/user-preset
+%_udevhwdbdir /lib/udev/hwdb.d
+%_udevrulesdir /lib/udev/rules.d
+%_journalcatalogdir /usr/lib/systemd/catalog
+%_binfmtdir /usr/lib/binfmt.d
+%_sysctldir /usr/lib/sysctl.d
+%_sysusersdir /usr/lib/sysusers.d
+%_tmpfilesdir /usr/lib/tmpfiles.d
+%_user_tmpfilesdir /usr/share/user-tmpfiles.d
+%_environmentdir /usr/lib/environment.d
+%_modulesloaddir /usr/lib/modules-load.d
+%_modprobedir /lib/modprobe.d
+%_systemdgeneratordir /lib/systemd/system-generators
+%_systemdusergeneratordir /usr/lib/systemd/user-generators
+%_systemd_system_env_generator_dir /usr/lib/systemd/system-environment-generators
+%_systemd_user_env_generator_dir /usr/lib/systemd/user-environment-generators
+
+%systemdunitdir %_unitdir
+%systemduserunitdir %_userunitdir
+%systemdtmpfilesdir %_tmpfilesdir
+
+# Macro for excluding systemd related paths from package contents
+
+%exclude_systemd_files\
+%exclude /lib/systemd\
+%exclude /usr/lib/systemd\
+%exclude /etc/binfmt.d\
+%exclude /etc/modules-load.d\
+%exclude /etc/systemd\
+%exclude /etc/tmpfiles.d\
+%exclude %{_binfmtdir}\
+%exclude %{_sysctldir}\
+%exclude %{_sysusersdir}\
+%exclude %{_tmpfilesdir}\
+%exclude %{_user_tmpfilesdir}\
+%exclude %{_environmentdir}\
+%exclude %{_modulesloaddir}\
+%{nil}
index 9af5dc1fda90f41d368dee9cb1daa4eb66ddd7ef..11f090386363b22d1b07b47c2176b05da61b283f 100644 (file)
@@ -6,7 +6,7 @@ Summary:        TLD Linux RPM macros
 Summary(pl.UTF-8):     Makra RPM dla Linuksa TLD
 Name:          rpm-tld-macros
 Version:       %{rpm_macros_rev}
-Release:       6
+Release:       6.1
 License:       GPL v2+
 Group:         Development/Building
 Source0:       macros.tld