]> TLD Linux GIT Repositories - packages/rpm.git/commitdiff
- fix trigger flag int type check
authorMarcin Krol <hawk@tld-linux.org>
Fri, 25 Jan 2019 11:50:12 +0000 (12:50 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Fri, 25 Jan 2019 11:50:12 +0000 (12:50 +0100)
rpm-trigger-flags-int-type.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-trigger-flags-int-type.patch b/rpm-trigger-flags-int-type.patch
new file mode 100644 (file)
index 0000000..b3ed60a
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur rpm-4.5.orig/lib/formats.c rpm-4.5/lib/formats.c
+--- rpm-4.5.orig/lib/formats.c 2008-06-10 01:19:16.000000000 +0200
++++ rpm-4.5/lib/formats.c      2019-01-24 21:42:07.736000000 +0100
+@@ -900,7 +900,7 @@
+     char * val;
+ assert(ix == 0);
+-    if (he->t != RPM_INT64_TYPE) {
++    if (he->t != RPM_INT32_TYPE) {
+       val = xstrdup(_("(invalid type)"));
+     } else {
+       int anint = data.i64p[ix];
index aa9ef4eb16e13889f26242e97a860cf147b75291..f582a336e5d8cd32b1d28f0446e4061d48cca7ee 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -42,7 +42,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       84
+Release:       85
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -175,6 +175,7 @@ Patch112:   notrans.patch
 Patch113:      %{name}-rubyprov.patch
 Patch114:      %{name}-ruby-gem-build.patch
 Patch115:      %{name}-glibc.patch
+Patch116:      %{name}-trigger-flags-int-type.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1.4
@@ -817,6 +818,7 @@ install %{SOURCE13} scripts/perl.prov
 %patch113 -p1
 %patch114 -p1
 %patch115 -p1
+%patch116 -p1
 
 mv -f po/{sr,sr@Latn}.po
 rm -rf sqlite zlib popt