]> TLD Linux GIT Repositories - packages/rpm.git/commitdiff
- merged cflags/ldflags macros from PLD, we need this to their specs
authorMarcin Krol <hawk@tld-linux.org>
Wed, 17 Jul 2013 12:32:45 +0000 (12:32 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 17 Jul 2013 12:32:45 +0000 (12:32 +0000)
rpm-macros-ti.patch
rpm-rpmrc.patch
rpm.spec

index ac1956d8951ba1d1b8e8677fb1d97e732c86325d..1e2a93427ba6e200604848253668375890c9b20e 100644 (file)
@@ -1,6 +1,6 @@
-diff -urN rpm-4.5/macros.in rpm-4.5.new//macros.in
---- rpm-4.5/macros.in  2010-05-28 20:56:02.854032755 +0200
-+++ rpm-4.5.new//macros.in     2010-05-28 20:59:04.177348180 +0200
+diff -ur rpm-4.5.orig/macros.in rpm-4.5/macros.in
+--- rpm-4.5.orig/macros.in     2013-07-17 11:43:34.000000000 +0000
++++ rpm-4.5/macros.in  2013-07-17 11:55:15.035117233 +0000
 @@ -277,6 +277,9 @@
  #
  #%distribution
@@ -29,13 +29,58 @@ diff -urN rpm-4.5/macros.in rpm-4.5.new//macros.in
  
  #------------------------------------------------------------------------
  # executable(...) configuration.
-@@ -1482,6 +1485,9 @@
- # -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
+@@ -1478,16 +1481,49 @@
+ #-----------------------------------------------------------------
+ # CFLAGS and LDFLAGS used to build
+-%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-4 -fno-debug-types-section -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
  
  %debugcflags  -O0 -g -Wall
 +%debugcppflags        %{nil}
++%debugldflags %{nil}
++
 +%optldflags   -Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc
 +%optcppflags  %{nil}
  
  # Warning: those macros are overwritten by macros.build,
  #          left here for compatibility
+-%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
+-%rpmcxxflags  %{rpmcflags}
+-%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
+-  
++%rpmcflags %(awk 'BEGIN {
++       split("%{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}",I);
++       split("%{?filterout} %{?filterout_c} %{?filterout_ld}",F);
++       %{filter_out}
++}')
++%rpmcppflags       %(awk 'BEGIN {
++       split("%{?debug:%debugcppflags}%{!?debug:%optcppflags}%{?debuginfocppflags}",I);
++       split("%{?filterout} %{?filterout_cpp} %{?filterout_cpp}",F);
++       %{filter_out}
++}')
++%rpmcxxflags       %(awk 'BEGIN {
++       split("%{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}",I);
++       split("%{?filterout} %{?filterout_cxx} %{?filterout_ld}",F);
++       %{filter_out}
++}')
++%rpmldflags        %(awk 'BEGIN {
++       split("%{?optldflags}",I);
++       split("%{?filterout_ld}",F)
++       %{filter_out}
++}')
++
++# common compilation flags
++%_fortify_cflags      -Wp,-D_FORTIFY_SOURCE=2
++
++# cf http://wiki.mandriva.com/en/Development/Packaging/Problems#format_not_a_string_literal_and_no_format_arguments
++%Werror_cflags                -Wformat -Werror=format-security
++
++%_ssp_cflags          -fstack-protector --param=ssp-buffer-size=4
++%__common_cflags      -O2 -fwrapv -pipe %{Werror_cflags} %{debuginfocflags} %{?_fortify_cflags} %{!?nospecflags:%{?specflags}}
++%__common_cflags_with_ssp     %{__common_cflags} %{?_ssp_cflags}
++
+ #------------------------------------------------------------------------
+ # mimetype(...) configuration.
+ #
index 53f1741a9b17c72f7c96a4bc16a14e1b46b62c36..6a501348b1410f2ae60227bd22821f26d0910016 100644 (file)
 -optflags: atariclone -O2 -g -fomit-frame-pointer
 -optflags: milan -O2 -g -fomit-frame-pointer
 -optflags: hades -O2 -g -fomit-frame-pointer
-+optflags: i386 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -fasynchronous-unwind-tables  -mtune=generic -march=i386%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_i386: %{specflags_i386}}}
-+optflags: i486 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -fasynchronous-unwind-tables -march=i486%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_i486: %{specflags_i486}}}
-+optflags: i586 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -fasynchronous-unwind-tables -mtune=generic -march=i586%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_i586: %{specflags_i586}}}
-+optflags: i686 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -fasynchronous-unwind-tables -march=i686 -mtune=pentium4%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_i686: %{specflags_i686}}}
-+optflags: pentium3 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -march=pentium3%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_pentium3: %{specflags_pentium3}}}
-+optflags: pentium4 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -march=pentium4%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_pentium4: %{specflags_pentium4}}}
-+optflags: athlon -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fomit-frame-pointer -fasynchronous-unwind-tables -march=athlon%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32: %{specflags_ia32}}%{?specflags_athlon: %{specflags_athlon}}}
-+optflags: ia64 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia64: %{specflags_ia64}}}
-+optflags: x86_64 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fPIC -march=x86-64%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_x86_64: %{specflags_x86_64}}}
-+optflags: amd64 -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fPIC -march=k8%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_amd64: %{specflags_amd64}}}
-+optflags: ia32e -O2 -pipe -fno-strict-aliasing -fwrapv -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fPIC -march=nocona%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_ia32e: %{specflags_ia32e}}}
++optflags: i386 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer}%{!?__common_cflags_with_ssp:-O2 -g -m32} -march=i386 -mtune=generic -fasynchronous-unwind-tables %{!?nospecflags:%{?specflags_ia32:} %{?specflags_i386}}
++optflags: i486 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer}%{!?__common_cflags_with_ssp:-O2 -g -m32} -march=i486 -fasynchronous-unwind-tables %{!?nospecflags:%{?specflags_ia32} %{?specflags_i486}}
++optflags: i586 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer -mtune=generic}%{!?__common_cflags_with_ssp:-O2 -g -m32} -march=i586 -fasynchronous-unwind-tables %{!?nospecflags:%{?specflags_ia32} %{?specflags_i586}}
++optflags: i686 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer}%{!?__common_cflags_with_ssp:-O2 -g -m32 -mtune=generic} -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 %{!?nospecflags:%{?specflags_ia32} %{?specflags_i686}}
++optflags: pentium3 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer}%{!?__common_cflags_with_ssp:-O2 -g -m32} -march=pentium3 -fasynchronous-unwind-tables %{!?nospecflags:%{?specflags_ia32} %{?specflags_pentium3}}
++optflags: pentium4 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer}%{!?__common_cflags_with_ssp:-O2 -g -m32} -march=pentium4 -fasynchronous-unwind-tables %{!?nospecflags:%{?specflags_ia32} %{?specflags_pentium4}}
++optflags: athlon %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fomit-frame-pointer}%{!?__common_cflags_with_ssp:-O2 -g -m32} -march=athlon -fasynchronous-unwind-tables %{!?nospecflags:%{?specflags_ia32} %{?specflags_athlon}}
++optflags: ia64 %{?__common_cflags:%{__common_cflags}}%{!?__common_cflags:-O2 -g}
++optflags: x86_64 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fPIC}%{!?__common_cflags_with_ssp:-O2 -g -m64 -mtune=generic} -march=x86-64 %{!?nospecflags:%{?specflags_x86_64}}
++optflags: amd64 %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fPIC}%{!?__common_cflags_with_ssp:-O2 -g -m64 -mtune=generic} -march=x86-64 %{!?nospecflags:%{?specflags_x86_64}}
++optflags: ia32e %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fPIC}%{!?__common_cflags_with_ssp:-O2 -g -m64 -mtune=generic} -march=x86-64 %{!?nospecflags:%{?specflags_ia32e}}
 +
 +optflags: alpha -O2 -fno-strict-aliasing -fwrapv -mieee%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_alpha: %{specflags_alpha}}}
 +optflags: alphaev5 -O2 -fno-strict-aliasing -fwrapv -mieee -mcpu=ev5%{!?nospecflags:%{?specflags: %{specflags}}%{?specflags_alpha: %{specflags_alpha}}%{?specflags_alphaev5: %{specflags_alphaev5}}}
index 902c98e0f25ac3adf4a92eda66dff424511a7dea..1898db76244e27bdb45ed592d7856d5ffc9fe6ae 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -42,7 +42,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       72
+Release:       73
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -509,7 +509,7 @@ Summary(ru.UTF-8):  Скрипты и утилиты, необходимые дл
 Summary(uk.UTF-8):     Скрипти та утиліти, необхідні для побудови пакетів
 Group:         Applications/File
 Requires(pretrans):    findutils
-Requires:      %{name}-build-macros >= 1.636
+Requires:      %{name}-build-macros >= 1.656
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk