]> TLD Linux GIT Repositories - packages/seabios.git/blob - seabios.spec
- updated to 1.16.3
[packages/seabios.git] / seabios.spec
1 Summary:        Open source implementation of a 16-bit x86 BIOS
2 Summary(pl.UTF-8):      Implementacja 16-bitowego BIOS-u x86 o otwartych źródłach
3 Name:           seabios
4 Version:        1.16.2
5 Release:        1
6 License:        LGPL v3
7 Group:          Applications/System
8 Source0:        https://www.seabios.org/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  ef52bf37a78e78a082688a244300ab86
10 URL:            https://www.seabios.org/SeaBIOS
11 BuildRequires:  acpica
12 %ifnarch %{ix86} %{x8664} x32
13 # i386 crosscompiler could be used as well, but we have only x86_64 as more universal
14 BuildRequires:  crossx8664-binutils
15 BuildRequires:  crossx8664-gcc
16 %endif
17 BuildRequires:  python3
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _enable_debug_packages  0
21
22 %description
23 SeaBIOS is an open source implementation of a 16-bit X86 BIOS. SeaBIOS
24 can run in an emulator or it can run natively on X86 hardware with the
25 use of coreboot.
26
27 SeaBIOS is the default BIOS for QEMU, KVM and Xen HVM.
28
29 %description -l pl.UTF-8
30 SeaBIOS to mająca otwarte źródła implementacją 16-bitowego BIOS-u X86.
31 SeaBIOS może działać pod kontrolą emulatora lub natywnie na sprzęcie
32 X86 przy użyciu bootloadera coreboot.
33
34 SeaBIOS to domyślny BIOS dla narzędzi QEMU, KVM i Xen HVM.
35
36 %prep
37 %setup -q
38
39 %build
40 %{__make} \
41         V=1 PYTHON=%{__python3} \
42 %ifnarch %{ix86} %{x8664} x32
43         CROSS_PREFIX=x86_64-tld-linux
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
49
50 install out/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios.bin
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README docs/{Debugging.md,Mailinglist.md,Memory_Model.md,Releases.md,Runtime_config.md,SeaBIOS.md,SeaVGABIOS.md}
58 %dir %{_datadir}/%{name}
59 %{_datadir}/%{name}/bios.bin