]> TLD Linux GIT Repositories - packages/virt-manager.git/blob - virt-manager.spec
- R dconf, fixes remote connections not being saved
[packages/virt-manager.git] / virt-manager.spec
1 Summary:        Virtual Machine Manager
2 Summary(pl.UTF-8):      Zarządca maszyn wirtualnych
3 Name:           virt-manager
4 Version:        1.5.1
5 Release:        4
6 Epoch:          1
7 License:        GPL v2+
8 Group:          Applications/Emulators
9 Source0:        https://virt-manager.org/download/sources/virt-manager/%{name}-%{version}.tar.gz
10 # Source0-md5:  32a929fd91fca9767730abaefb94661d
11 URL:            http://virt-manager.org/
12 BuildRequires:  gettext-devel >= 0.14.1
13 BuildRequires:  glib2-devel
14 BuildRequires:  gtk-update-icon-cache
15 BuildRequires:  intltool >= 0.35.0
16 BuildRequires:  perl-tools-pod
17 BuildRequires:  python-devel >= 1:2.7
18 BuildRequires:  rpmbuild(macros) >= 1.592
19 Requires:       dconf
20 Requires:       adwaita-icon-theme
21 Requires:       gnome-icon-theme
22 Requires(post,postun):  glib2
23 Requires(post,postun):  gtk-update-icon-cache
24 Requires:       gtk+3 >= 3.14
25 Requires:       gtk3-vnc >= 0.4.3
26 Requires:       hicolor-icon-theme
27 Requires:       libosinfo >= 0.2.10
28 Requires:       libvirt-glib
29 Requires:       python-chardet
30 Requires:       python-dbus >= 0.84.0
31 Requires:       python-idna
32 Requires:       python-ipaddr
33 Requires:       python-libvirt >= 0.9.6
34 Requires:       python-pygobject3 >= 3.14
35 Requires:       python-requests
36 Requires:       python-virtinst = %{epoch}:%{version}-%{release}
37 Requires:       spice-gtk
38 Requires:       vte >= 0.34
39 Suggests:       gnome-keyring >= 0.4.9
40 Suggests:       python-gnome-desktop-keyring >= 2.15.4
41 Suggests:       python-libguestfs >= 1.12.0
42 ExclusiveArch:  %{ix86} %{x8664} ia64
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Virtual Machine Manager provides a graphical tool for administering
47 virtual machines for KVM, Xen, and QEmu. Start, stop, add or remove
48 virtual devices, connect to a graphical or serial console, and see
49 resource usage statistics for existing VMs on local or remote
50 machines. Uses libvirt as the backend management API.
51
52 %description -l pl.UTF-8
53 Virtual Machine Manager udostępnia graficzne narzędzie do
54 administrowania maszynami wirtualnymi dla środowisk KVM, Xen i QEmu.
55 Pozwala uruchamiać, zatrzymywać, dodawać i usuwać urządzenia
56 wirtualne, łączyć się z konsolą graficzną lub szeregową oraz oglądać
57 statystyki wykorzystania zasobów istniejących maszyn wirtualnych na
58 maszynach lokalnych i zdalnych. Wykorzystuje libvirt jako API do
59 zarządzania.
60
61 %package -n python-virtinst
62 Summary:        Python modules and utilities for installing virtual machines
63 Summary(pl.UTF-8):      Moduły Pythona i narzędzia do instalowania maszyn wirtualnych
64 Group:          Libraries/Python
65 Requires:       python-libvirt >= 0.9.6
66 Requires:       python-libxml2 >= 1:2.7.8
67 Requires:       python-modules
68 Requires:       python-urlgrabber
69 Suggests:       python-selinux
70 Suggests:       virt-viewer >= 0.0.1
71
72 %description -n python-virtinst
73 virtinst is a module that helps build and install libvirt based
74 virtual machines. Currently supports KVM, QEmu and Xen virtual
75 machines. Package includes several command line utilities, including
76 virt-install (build and install new VMs) and virt-clone (clone an
77 existing virtual machine).
78
79 %description -n python-virtinst -l pl.UTF-8
80 virtinst to moduł pomagający przy tworzeniu i instalowaniu maszyn
81 wirtualnych opartych na libvirt. Obecnie obsługiwane są maszyny KVM,
82 QEmu i Xen. Pakiet zawiera kilka działających z linii poleceń
83 skryptów, w tym virt-install (tworzący i instalujący nowe VM-y) oraz
84 virt-clone (klonujący istniejącą maszynę wirtualną).
85
86 %prep
87 %setup -q
88
89 %build
90 %{__python} setup.py configure \
91         --prefix=%{_prefix}
92
93 %{__python} setup.py build
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__python} setup.py install \
99         --optimize=2 \
100         --root=$RPM_BUILD_ROOT
101
102 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
103 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
104 # requires patching(?)
105 #%%py_postclean %{_datadir}/%{name}
106
107 # Replace '#!/usr/bin/env python2' with '#!/usr/bin/python2'
108 # The format is ideal for upstream, but not a distro. See:
109 # https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython
110 for f in $(find $RPM_BUILD_ROOT -type f -executable -print); do
111     sed -i "1 s|^#!/usr/bin/env python2|#!%{__python}|" $f || :
112 done
113
114 %find_lang %{name}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 %glib_compile_schemas
121 %update_icon_cache hicolor
122
123 %postun
124 if [ "$1" = "0" ]; then
125         %glib_compile_schemas
126 fi
127 %update_icon_cache hicolor
128
129 %files
130 %defattr(644,root,root,755)
131 %doc NEWS.md README.md
132 %attr(755,root,root) %{_bindir}/virt-manager
133 %{_datadir}/%{name}/icons
134 %{_datadir}/%{name}/ui
135 %dir %{_datadir}/%{name}/virtManager
136 %{_datadir}/%{name}/virtManager/*.py*
137 %attr(755,root,root) %{_datadir}/%{name}/virt-manager
138 %{_datadir}/appdata/virt-manager.appdata.xml
139 %{_datadir}/glib-2.0/schemas/org.virt-manager.virt-manager.gschema.xml
140 %{_desktopdir}/%{name}.desktop
141 %{_iconsdir}/hicolor/*/apps/virt-manager.png
142 %{_mandir}/man1/virt-manager.1*
143
144 %files -n python-virtinst -f %{name}.lang
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/virt-clone
147 %attr(755,root,root) %{_bindir}/virt-convert
148 %attr(755,root,root) %{_bindir}/virt-install
149 %attr(755,root,root) %{_bindir}/virt-xml
150 %dir %{_datadir}/%{name}
151 %dir %{_datadir}/%{name}/virtcli
152 %{_datadir}/%{name}/virtcli/*.py*
153 %{_datadir}/%{name}/virtcli/cli.cfg
154 %dir %{_datadir}/%{name}/virtconv
155 %{_datadir}/%{name}/virtconv/*.py*
156 %dir %{_datadir}/%{name}/virtinst
157 %{_datadir}/%{name}/virtinst/*.py*
158 %attr(755,root,root) %{_datadir}/%{name}/virt-clone
159 %attr(755,root,root) %{_datadir}/%{name}/virt-convert
160 %attr(755,root,root) %{_datadir}/%{name}/virt-install
161 %attr(755,root,root) %{_datadir}/%{name}/virt-xml
162 %{_mandir}/man1/virt-clone.1*
163 %{_mandir}/man1/virt-convert.1*
164 %{_mandir}/man1/virt-install.1*
165 %{_mandir}/man1/virt-xml.1*