]> TLD Linux GIT Repositories - packages/zabbix.git/blob - zabbix.spec
- updated to 6.0.25
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  agent2  # build Zabbix Agent 2
6 %bcond_without  pgsql   # enable PostgreSQL support
7 %bcond_without  sqlite3 # enable sqlite3 support
8 %bcond_without  mysql   # enable MySQL support
9 %bcond_without  java    # disable java support
10
11 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
12 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
13
14 %define         _noautoreq 'pear(.*\.php)'
15
16 %define         php_min_version 7.2.5
17
18 %ifnarch %{go_arches}
19 %undefine       with_agent2
20 %endif
21
22 %{?with_java:%{?use_default_jdk}}
23
24 Summary:        Zabbix - network monitoring software
25 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
26 Name:           zabbix
27 Version:        6.0.25
28 Release:        1
29 License:        GPL v2+
30 Group:          Networking/Utilities
31 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/6.0/%{name}-%{version}.tar.gz
32 # Source0-md5:  510cb7207048414b71b4fecc9aa50b6b
33 Source1:        %{name}-apache.conf
34 Source2:        %{name}_agentd.init
35 Source3:        %{name}_server.init
36 Source4:        %{name}_proxy.init
37 Source5:        %{name}_agent2.init
38 Source6:        %{name}_agent2.sysconfig
39 Patch0:         tld.patch
40 Patch1:         sqlite3_dbname.patch
41 Patch2:         always_compile_ipc.patch
42 Patch3:         agent2.patch
43 Patch4:         go.patch
44 URL:            https://www.zabbix.com/
45 BuildRequires:  OpenIPMI-devel
46 BuildRequires:  autoconf
47 BuildRequires:  automake >= 1:1.15
48 BuildRequires:  curl-devel
49 %{?with_agent2:BuildRequires:   golang >= 1.13}
50 %{?with_java:%buildrequires_jdk}
51 BuildRequires:  libevent-devel
52 BuildRequires:  libssh2-devel
53 BuildRequires:  libtool
54 BuildRequires:  libxml2-devel
55 %{?with_mysql:BuildRequires:    mysql-devel}
56 BuildRequires:  net-snmp-devel
57 BuildRequires:  openldap-devel >= 2.4.6
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 %{?with_pgsql:BuildRequires:    postgresql-devel}
61 BuildRequires:  rpmbuild(macros) >= 1.671
62 %{?with_java:BuildRequires:     rpm-tld-macros-javaprov}
63 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
64 BuildRequires:  unixODBC-devel
65 BuildRequires:  zlib-devel
66 Requires(postun):       /usr/sbin/groupdel
67 Requires(postun):       /usr/sbin/userdel
68 Requires(pre):  /bin/id
69 Requires(pre):  /usr/bin/getgid
70 Requires(pre):  /usr/sbin/groupadd
71 Requires(pre):  /usr/sbin/useradd
72 Provides:       group(zabbix)
73 Provides:       user(zabbix)
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/%{name}
77 %define         _appdir         %{_datadir}/%{name}
78 %define         _webapps        /etc/webapps
79 %define         _webapp         %{name}
80
81 %description
82 Zabbix is software that monitors numerous parameters of a network and
83 the servers on that network. It is a useful tool for monitoring the
84 health and integrity of servers. Zabbix uses a flexible notification
85 mechanism that allows users to configure email based alerts for
86 virtually any event. All monitored parameters are stored in a
87 database. Zabbix offers excellent reporting and data visualisation
88 features based on the stored data. Zabbix supports both polling and
89 trapping. All Zabbix reports and statistics, as well as configuration
90 parameters, are accessed through a web-based front end.
91
92 %description -l pl.UTF-8
93 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
94 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
95 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
96 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
97 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
98 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
99 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
100 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
101 statystyk Zabbixa jest możliwy poprzez interfejs oparty o WWW.
102
103 %package agentd
104 Summary:        Zabbix Agent
105 Summary(pl.UTF-8):      Agenta Zabbixa
106 Group:          Networking/Utilities
107 Requires:       %{name} = %{version}-%{release}
108 Obsoletes:      zabbix-agent-inetd
109 Obsoletes:      zabbix-agent-standalone
110 Requires(post,preun):   /sbin/chkconfig
111 Requires:       rc-scripts
112
113 %description agentd
114 Zabbix agent collects data from the local system for a Zabbix server.
115
116 %description agentd -l pl.UTF-8
117 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
118
119 %package agent2
120 Summary:        Zabbix Agent 2
121 Summary(pl.UTF-8):      Agent 2 Zabbixa
122 Group:          Networking/Utilities
123 Requires:       %{name} = %{version}-%{release}
124 Requires(post,preun):   /sbin/chkconfig
125 Requires:       rc-scripts
126
127 %description agent2
128 Zabbix agent collects data from the local system for a Zabbix server.
129
130 %description agent2 -l pl.UTF-8
131 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
132
133 %package web
134 Summary:        Web frontend for Zabbix
135 Summary(pl.UTF-8):      Interfejs Web dla Zabbixa
136 Group:          Applications/WWW
137 Requires:       php(bcmath)
138 Requires:       php(core) >= %{php_min_version}
139 Requires:       php(ctype)
140 Requires:       php(gd)
141 Requires:       php(gettext)
142 Requires:       php(json)
143 Requires:       php(mbstring)
144 Requires:       php(pcre)
145 Requires:       php(session)
146 Requires:       php(sockets)
147 Requires:       php(xml)
148 Requires:       php(xmlreader)
149 Requires:       php(xmlwriter)
150 Requires:       webapps
151 Requires:       webserver(alias)
152 Requires:       webserver(indexfile)
153 Requires:       webserver(php)
154 Suggests:       php(mysql)
155 Suggests:       php(pgsql)
156 Suggests:       php(sqlite3)
157 # used with sqlite3
158 Suggests:       php(sysvsem)
159 BuildArch:      noarch
160
161 %description web
162 This package provides web based (PHP) frontend for Zabbix.
163
164 %description web -l pl.UTF-8
165 Ten pakiet dostarcza napisany w PHP frontend dla Zabbixa.
166
167 %package proxy
168 Summary:        Zabbix proxy
169 Summary(pl.UTF-8):      Proxy do Zabbixa
170 Group:          Networking/Utilities
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       zabbix-proxy(db) = %{version}-%{release}
173
174 %description proxy
175 This package provides the Zabbix proxy.
176
177 %description proxy -l pl.UTF-8
178 Ten pakiet zawiera proxy Zabbix.
179
180 %package proxy-mysql
181 Summary:        MySQL support for Zabbix proxy
182 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbixa
183 Group:          Networking/Utilities
184 Provides:       %{name}-proxy(db) = %{version}-%{release}
185 Obsoletes:      zabbix-proxy-postgresql
186 Obsoletes:      zabbix-proxy-sqlite3
187
188 %description proxy-mysql
189 This package provides the Zabbix proxy binary with MySQL support.
190
191 %description proxy-mysql -l pl.UTF-8
192 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
193
194 %package proxy-postgresql
195 Summary:        PostgreSQL support for Zabbix proxy
196 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbixa
197 Group:          Networking/Utilities
198 Provides:       %{name}-proxy(db) = %{version}-%{release}
199 Obsoletes:      zabbix-proxy-mysql
200 Obsoletes:      zabbix-proxy-sqlite3
201
202 %description proxy-postgresql
203 This package provides the Zabbix proxy binary with PostgreSQL support.
204
205 %description proxy-postgresql -l pl.UTF-8
206 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
207
208 %package proxy-sqlite3
209 Summary:        SQLite 3 support for Zabbix proxy
210 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbixa
211 Group:          Networking/Utilities
212 Provides:       %{name}-proxy(db) = %{version}-%{release}
213 Obsoletes:      zabbix-proxy-mysql
214 Obsoletes:      zabbix-proxy-postgresql
215
216 %description proxy-sqlite3
217 This package provides the Zabbix proxy binary with SQLite 3 support.
218
219 %description proxy-sqlite3 -l pl.UTF-8
220 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
221
222 %package server
223 Summary:        Zabbix server
224 Summary(pl.UTF-8):      Serwer Zabbixa
225 Group:          Networking/Utilities
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       %{name}-server(db) = %{version}-%{release}
228 Obsoletes:      zabbix-suckerd
229 Obsoletes:      zabbix-trapper-inetd
230 Obsoletes:      zabbix-trapper-standalone
231
232 %description server
233 This package provides the Zabbix server.
234
235 %description server -l pl.UTF-8
236 Ten pakiet zawiera serwer Zabbixa.
237
238 %package server-mysql
239 Summary:        MySQL support for Zabbix server
240 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbixa
241 Group:          Networking/Utilities
242 Provides:       %{name}-server(db) = %{version}-%{release}
243 Obsoletes:      zabbix-server-postgresql
244 Obsoletes:      zabbix-server-sqlite3
245
246 %description server-mysql
247 This package provides the Zabbix server binary for use with MySQL
248 database.
249
250 %description server-mysql -l pl.UTF-8
251 Ten pakiet zawiera serwer Zabbixa z obsługą bazy danych MySQL.
252
253 %package server-postgresql
254 Summary:        PostgreSQL support for Zabbix server
255 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbixa
256 Group:          Networking/Utilities
257 Provides:       %{name}-server(db) = %{version}-%{release}
258 Obsoletes:      zabbix-server-mysql
259 Obsoletes:      zabbix-server-sqlite3
260
261 %description server-postgresql
262 This package provides the Zabbix server binary for use with PostgreSQL
263 database.
264
265 %description server-postgresql -l pl.UTF-8
266 Ten pakiet zawiera serwer Zabbixa z obsługą bazy danych PostgreSQL.
267
268 %package java
269 Summary:        Zabbix Java Gateway
270 Group:          Networking/Utilities
271 Requires:       %{name} = %{version}-%{release}
272
273 %description java
274 This package provides the Zabbix Java Gateway.
275
276 %prep
277 %setup -q
278
279 %patch0 -p1
280 %patch1 -p1
281 %patch2 -p1
282 %patch3 -p1
283 %patch4 -p1
284
285 %build
286 %{__libtoolize}
287 %{__aclocal} -I m4
288 %{__autoconf}
289 %{__autoheader}
290 %{__automake}
291
292 configure() {
293         %configure \
294         %{?with_java:ac_cv_prog_JAVAC=%{java_home}/bin/javac} \
295         %{?with_java:ac_cv_prog_JAR=%{java_home}/bin/jar} \
296         --enable-agent \
297         %{__enable_disable agent2} \
298         --enable-ipv6 \
299         %{__enable_disable java} \
300         --with-ldap \
301         --with-libcurl \
302         --with-libevent \
303         --with-libpcre2 \
304         --with-libxml2 \
305         --with-net-snmp \
306         --with-openipmi \
307         --with-openssl \
308         --with-ssh2 \
309         --with-unixodbc \
310         "$@"
311 }
312
313 configure \
314         --disable-server \
315         --disable-proxy
316
317 %{__make}
318
319 for database in %{databases} ; do
320         if [ "$database" = "sqlite3" ] ; then
321                 enable_server=""
322         else
323                 enable_server="--enable-server"
324         fi
325         configure \
326                 --with-$database \
327                 $enable_server \
328                 --enable-proxy
329
330         %{__make}
331
332         if [ "$enable_server" ] ; then
333                 %{__make} install \
334                         -C src/zabbix_server \
335                         DESTDIR=$PWD/install-${database}
336         fi
337
338         %{__make} install \
339                 -C src/zabbix_proxy \
340                 DESTDIR=$PWD/install-${database}
341 done
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig},/etc/webapps/%{_webapp},%{_appdir}} \
346         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix}
347
348 %{__make} install \
349         DESTDIR=$RPM_BUILD_ROOT \
350         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
351
352 for database in %{databases} ; do
353         if [ "$database" != "sqlite3" ] ; then
354                 cp -p install-$database/%{_sbindir}/zabbix_server \
355                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
356         fi
357         cp -p install-$database/%{_sbindir}/zabbix_proxy \
358                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
359 done
360
361 if [ -n "$database" ] ; then
362         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
363         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
364 fi
365
366 cp -r ui $RPM_BUILD_ROOT%{_appdir}
367
368 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
369 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
370
371 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
372 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_server
373 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_proxy
374 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
375 install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/zabbix_agent2
376
377 mv $RPM_BUILD_ROOT%{_appdir}/ui/conf $RPM_BUILD_ROOT%{_sysconfdir}/web
378 ln -s %{_sysconfdir}/web $RPM_BUILD_ROOT%{_appdir}/ui/conf
379 touch $RPM_BUILD_ROOT%{_sysconfdir}/web/zabbix.conf.php
380
381 %if %{with java}
382 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
383 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
384 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
385 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
386 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
387 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
388
389 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
390 #!/bin/sh
391
392 exec %{_datadir}/zabbix_java/startup.sh "$@"
393 EOF
394
395 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
396 #!/bin/sh
397
398 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
399 EOF
400 %endif
401
402 %clean
403 rm -rf $RPM_BUILD_ROOT
404
405 %triggerin web -- apache < 2.2.0, apache-base
406 %webapp_register httpd %{_webapp}
407
408 %triggerun web -- apache < 2.2.0, apache-base
409 %webapp_unregister httpd %{_webapp}
410
411 %pre
412 %groupadd -g 111 zabbix
413 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
414 %addusertogroup -q zabbix proc
415
416 %postun
417 if [ "$1" = "0" ]; then
418         %userremove zabbix
419         %groupremove zabbix
420 fi
421
422 %post server-mysql
423 if [ "$1" = 1 ]; then
424         %banner -e %{name}-server <<-EOF
425         You should create database for Zabbix.
426
427         Running these should be fine in most cases:
428
429         mysqladmin create zabbix
430         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
431         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
432         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
433 EOF
434 fi
435 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
436
437 %post server-postgresql
438 if [ "$1" = 1 ]; then
439         %banner -e %{name}-server <<-EOF
440         You should create database for Zabbix.
441
442         Running these should be fine in most cases:
443
444         createuser -U postgres zabbix
445         createdb -U postgres -O zabbix zabbix
446         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -U zabbix zabbix
447         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -U zabbix zabbix
448         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -U zabbix zabbix
449 EOF
450 fi
451 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
452
453 %post server
454 /sbin/chkconfig --add zabbix_server
455 %service zabbix_server restart
456
457 %postun server
458 if [ "$1" = "0" ]; then
459         %service -q zabbix_server stop
460         /sbin/chkconfig --del zabbix_server
461 fi
462 if [ "$1" = "0" ]; then
463         if [ -L %{_sbindir}/zabbix_server ] ; then
464                 rm -f %{_sbindir}/zabbix_server || :
465         fi
466 fi
467
468 %post agentd
469 /sbin/chkconfig --add zabbix_agentd
470 %service zabbix_agentd restart
471
472 %preun agentd
473 if [ "$1" = "0" ]; then
474         %service -q zabbix_agentd stop
475         /sbin/chkconfig --del zabbix_agentd
476 fi
477
478 %post agent2
479 /sbin/chkconfig --add zabbix_agent2
480 %service zabbix_agent2 restart
481
482 %preun agent2
483 if [ "$1" = "0" ]; then
484         %service -q zabbix_agent2 stop
485         /sbin/chkconfig --del zabbix_agent2
486 fi
487
488 %post proxy-mysql
489 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
490
491 %post proxy-postgresql
492 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
493
494 %post proxy-sqlite3
495 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
496
497 %post proxy
498 /sbin/chkconfig --add zabbix_server
499 %service zabbix_server restart
500
501 %postun proxy
502 if [ "$1" = "0" ]; then
503         %service -q zabbix_proxy stop
504         /sbin/chkconfig --del zabbix_proxy
505 fi
506 if [ "$1" = "0" ]; then
507         if [ -L %{_sbindir}/zabbix_proxy ] ; then
508                 rm -f %{_sbindir}/zabbix_proxy || :
509         fi
510 fi
511
512 %files
513 %defattr(644,root,root,755)
514 %doc AUTHORS ChangeLog README
515 %attr(755,root,root) %{_bindir}/zabbix_get
516 %attr(755,root,root) %{_bindir}/zabbix_js
517 %attr(755,root,root) %{_bindir}/zabbix_sender
518 %attr(751,root,zabbix) %dir %{_sysconfdir}
519 %attr(751,root,http) %dir %{_sysconfdir}/web
520 %dir %{_appdir}
521 %dir %attr(770,root,zabbix) /var/run/zabbix
522 %dir %attr(775,root,zabbix) /var/log/zabbix
523 %{_mandir}/man1/zabbix_get*
524 %{_mandir}/man1/zabbix_sender*
525
526 %files agentd
527 %defattr(644,root,root,755)
528 %doc conf/zabbix_agentd/*.conf
529 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
530 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
531 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
532 %attr(755,root,root) %{_sbindir}/zabbix_agentd
533 %{_mandir}/man8/zabbix_agentd*
534
535 %if %{with agent2}
536 %files agent2
537 %defattr(644,root,root,755)
538 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
539 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d
540 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d/plugins.d
541 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/ceph.conf
542 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/docker.conf
543 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/memcached.conf
544 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/modbus.conf
545 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/mqtt.conf
546 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/mysql.conf
547 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/oracle.conf
548 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/redis.conf
549 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/smart.conf
550 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
551 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/zabbix_agent2
552 %attr(755,root,root) %{_sbindir}/zabbix_agent2
553 %{_mandir}/man8/zabbix_agent2*
554 %endif
555
556 %files web
557 %defattr(644,root,root,755)
558 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
561 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/zabbix.conf.php
562 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/.htaccess
563 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/maintenance.inc.php
564 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/zabbix.conf.php.example
565 %{_appdir}/ui
566
567 %if %{any_database}
568 %files proxy
569 %defattr(644,root,root,755)
570 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
571 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
572 %attr(754,root,root) /etc/rc.d/init.d/zabbix_proxy
573 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
574 %{_mandir}/man8/zabbix_proxy*
575 %endif
576
577 %if %{with mysql}
578 %files proxy-mysql
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
581 %endif
582
583 %if %{with pgsql}
584 %files proxy-postgresql
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
587 %endif
588
589 %if %{with sqlite3}
590 %files proxy-sqlite3
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
593 %endif
594
595
596 %if %{any_database}
597 %files server
598 %defattr(644,root,root,755)
599 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
600 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
601 %attr(754,root,root) /etc/rc.d/init.d/zabbix_server
602 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
603 %{_mandir}/man8/zabbix_server*
604 %endif
605
606 %if %{with mysql}
607 %files server-mysql
608 %defattr(644,root,root,755)
609 %doc database/mysql/*.sql
610 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
611 %endif
612
613 %if %{with pgsql}
614 %files server-postgresql
615 %defattr(644,root,root,755)
616 %doc database/postgresql/*.sql
617 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
618 %endif
619
620 %if %{with java}
621 %files java
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_sbindir}/zabbix_java-start
624 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
625 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
626 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
627 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
628 %dir %{_datadir}/zabbix_java
629 %{_datadir}/zabbix_java/bin
630 %{_datadir}/zabbix_java/lib
631 %{_datadir}/zabbix_java/settings.sh
632 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
633 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
634 %endif