]> TLD Linux GIT Repositories - packages/zabbix.git/blob - zabbix.spec
- updated to 6.0.29
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  agent2  # build Zabbix Agent 2
6 %bcond_without  pgsql   # enable PostgreSQL support
7 %bcond_without  sqlite3 # enable sqlite3 support
8 %bcond_without  mysql   # enable MySQL support
9 %bcond_without  java    # disable java support
10
11 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
12 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
13
14 %define         _noautoreq 'pear(.*\.php)'
15
16 %define         php_min_version 7.2.5
17
18 %ifnarch %{go_arches}
19 %undefine       with_agent2
20 %endif
21
22 %{?with_java:%{?use_default_jdk}}
23
24 Summary:        Zabbix - network monitoring software
25 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
26 Name:           zabbix
27 Version:        6.0.28
28 Release:        1
29 License:        GPL v2+
30 Group:          Networking/Utilities
31 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/6.0/%{name}-%{version}.tar.gz
32 # Source0-md5:  7c73d9ebf24c1a97c5201c10464e5160
33 Source1:        %{name}-apache.conf
34 Source2:        %{name}_agentd.init
35 Source3:        %{name}_server.init
36 Source4:        %{name}_proxy.init
37 Source5:        %{name}_agent2.init
38 Source6:        %{name}_agent2.sysconfig
39 Patch0:         tld.patch
40 Patch1:         sqlite3_dbname.patch
41 Patch2:         always_compile_ipc.patch
42 Patch3:         agent2.patch
43 Patch4:         go.patch
44 URL:            https://www.zabbix.com/
45 BuildRequires:  OpenIPMI-devel
46 BuildRequires:  autoconf
47 BuildRequires:  automake >= 1:1.15
48 BuildRequires:  curl-devel
49 %{?with_agent2:BuildRequires:   golang >= 1.13}
50 %{?with_java:%buildrequires_jdk}
51 BuildRequires:  libevent-devel
52 BuildRequires:  libssh2-devel
53 BuildRequires:  libtool
54 BuildRequires:  libxml2-devel
55 %{?with_mysql:BuildRequires:    mysql-devel}
56 BuildRequires:  net-snmp-devel
57 BuildRequires:  openldap-devel >= 2.4.6
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 %{?with_pgsql:BuildRequires:    postgresql-devel}
61 BuildRequires:  rpmbuild(macros) >= 1.671
62 %{?with_java:BuildRequires:     rpm-tld-macros-javaprov}
63 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
64 BuildRequires:  unixODBC-devel
65 BuildRequires:  zlib-devel
66 Requires(postun):       /usr/sbin/groupdel
67 Requires(postun):       /usr/sbin/userdel
68 Requires(pre):  /bin/id
69 Requires(pre):  /usr/bin/getgid
70 Requires(pre):  /usr/sbin/groupadd
71 Requires(pre):  /usr/sbin/useradd
72 Provides:       group(zabbix)
73 Provides:       user(zabbix)
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/%{name}
77 %define         _appdir         %{_datadir}/%{name}
78 %define         _webapps        /etc/webapps
79 %define         _webapp         %{name}
80
81 %description
82 Zabbix is software that monitors numerous parameters of a network and
83 the servers on that network. It is a useful tool for monitoring the
84 health and integrity of servers. Zabbix uses a flexible notification
85 mechanism that allows users to configure email based alerts for
86 virtually any event. All monitored parameters are stored in a
87 database. Zabbix offers excellent reporting and data visualisation
88 features based on the stored data. Zabbix supports both polling and
89 trapping. All Zabbix reports and statistics, as well as configuration
90 parameters, are accessed through a web-based front end.
91
92 %description -l pl.UTF-8
93 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
94 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
95 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
96 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
97 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
98 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
99 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
100 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
101 statystyk Zabbixa jest możliwy poprzez interfejs oparty o WWW.
102
103 %package agentd
104 Summary:        Zabbix Agent
105 Summary(pl.UTF-8):      Agenta Zabbixa
106 Group:          Networking/Utilities
107 Requires:       %{name} = %{version}-%{release}
108 Obsoletes:      zabbix-agent-inetd
109 Obsoletes:      zabbix-agent-standalone
110 Requires(post,preun):   /sbin/chkconfig
111 Requires:       rc-scripts
112
113 %description agentd
114 Zabbix agent collects data from the local system for a Zabbix server.
115
116 %description agentd -l pl.UTF-8
117 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
118
119 %package agent2
120 Summary:        Zabbix Agent 2
121 Summary(pl.UTF-8):      Agent 2 Zabbixa
122 Group:          Networking/Utilities
123 Requires:       %{name} = %{version}-%{release}
124 Requires(post,preun):   /sbin/chkconfig
125 Requires:       rc-scripts
126
127 %description agent2
128 Zabbix agent collects data from the local system for a Zabbix server.
129
130 %description agent2 -l pl.UTF-8
131 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
132
133 %package web
134 Summary:        Web frontend for Zabbix
135 Summary(pl.UTF-8):      Interfejs Web dla Zabbixa
136 Group:          Applications/WWW
137 Requires:       php(bcmath)
138 Requires:       php(core) >= %{php_min_version}
139 Requires:       php(ctype)
140 Requires:       php(filter)
141 Requires:       php(gd)
142 Requires:       php(gettext)
143 Requires:       php(json)
144 Requires:       php(mbstring)
145 Requires:       php(openssl)
146 Requires:       php(pcre)
147 Requires:       php(session)
148 Requires:       php(sockets)
149 Requires:       php(xml)
150 Requires:       php(xmlreader)
151 Requires:       php(xmlwriter)
152 Requires:       webapps
153 Requires:       webserver(alias)
154 Requires:       webserver(indexfile)
155 Requires:       webserver(php)
156 Suggests:       php(mysql)
157 Suggests:       php(pgsql)
158 Suggests:       php(sqlite3)
159 # used with sqlite3
160 Suggests:       php(sysvsem)
161 BuildArch:      noarch
162
163 %description web
164 This package provides web based (PHP) frontend for Zabbix.
165
166 %description web -l pl.UTF-8
167 Ten pakiet dostarcza napisany w PHP frontend dla Zabbixa.
168
169 %package proxy
170 Summary:        Zabbix proxy
171 Summary(pl.UTF-8):      Proxy do Zabbixa
172 Group:          Networking/Utilities
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       zabbix-proxy(db) = %{version}-%{release}
175
176 %description proxy
177 This package provides the Zabbix proxy.
178
179 %description proxy -l pl.UTF-8
180 Ten pakiet zawiera proxy Zabbix.
181
182 %package proxy-mysql
183 Summary:        MySQL support for Zabbix proxy
184 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbixa
185 Group:          Networking/Utilities
186 Provides:       %{name}-proxy(db) = %{version}-%{release}
187 Obsoletes:      zabbix-proxy-postgresql
188 Obsoletes:      zabbix-proxy-sqlite3
189
190 %description proxy-mysql
191 This package provides the Zabbix proxy binary with MySQL support.
192
193 %description proxy-mysql -l pl.UTF-8
194 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
195
196 %package proxy-postgresql
197 Summary:        PostgreSQL support for Zabbix proxy
198 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbixa
199 Group:          Networking/Utilities
200 Provides:       %{name}-proxy(db) = %{version}-%{release}
201 Obsoletes:      zabbix-proxy-mysql
202 Obsoletes:      zabbix-proxy-sqlite3
203
204 %description proxy-postgresql
205 This package provides the Zabbix proxy binary with PostgreSQL support.
206
207 %description proxy-postgresql -l pl.UTF-8
208 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
209
210 %package proxy-sqlite3
211 Summary:        SQLite 3 support for Zabbix proxy
212 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbixa
213 Group:          Networking/Utilities
214 Provides:       %{name}-proxy(db) = %{version}-%{release}
215 Obsoletes:      zabbix-proxy-mysql
216 Obsoletes:      zabbix-proxy-postgresql
217
218 %description proxy-sqlite3
219 This package provides the Zabbix proxy binary with SQLite 3 support.
220
221 %description proxy-sqlite3 -l pl.UTF-8
222 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
223
224 %package server
225 Summary:        Zabbix server
226 Summary(pl.UTF-8):      Serwer Zabbixa
227 Group:          Networking/Utilities
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       %{name}-server(db) = %{version}-%{release}
230 Obsoletes:      zabbix-suckerd
231 Obsoletes:      zabbix-trapper-inetd
232 Obsoletes:      zabbix-trapper-standalone
233
234 %description server
235 This package provides the Zabbix server.
236
237 %description server -l pl.UTF-8
238 Ten pakiet zawiera serwer Zabbixa.
239
240 %package server-mysql
241 Summary:        MySQL support for Zabbix server
242 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbixa
243 Group:          Networking/Utilities
244 Provides:       %{name}-server(db) = %{version}-%{release}
245 Obsoletes:      zabbix-server-postgresql
246 Obsoletes:      zabbix-server-sqlite3
247
248 %description server-mysql
249 This package provides the Zabbix server binary for use with MySQL
250 database.
251
252 %description server-mysql -l pl.UTF-8
253 Ten pakiet zawiera serwer Zabbixa z obsługą bazy danych MySQL.
254
255 %package server-postgresql
256 Summary:        PostgreSQL support for Zabbix server
257 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbixa
258 Group:          Networking/Utilities
259 Provides:       %{name}-server(db) = %{version}-%{release}
260 Obsoletes:      zabbix-server-mysql
261 Obsoletes:      zabbix-server-sqlite3
262
263 %description server-postgresql
264 This package provides the Zabbix server binary for use with PostgreSQL
265 database.
266
267 %description server-postgresql -l pl.UTF-8
268 Ten pakiet zawiera serwer Zabbixa z obsługą bazy danych PostgreSQL.
269
270 %package java
271 Summary:        Zabbix Java Gateway
272 Group:          Networking/Utilities
273 Requires:       %{name} = %{version}-%{release}
274
275 %description java
276 This package provides the Zabbix Java Gateway.
277
278 %prep
279 %setup -q
280
281 %patch0 -p1
282 %patch1 -p1
283 %patch2 -p1
284 %patch3 -p1
285 %patch4 -p1
286
287 %build
288 %{__libtoolize}
289 %{__aclocal} -I m4
290 %{__autoconf}
291 %{__autoheader}
292 %{__automake}
293
294 configure() {
295         %configure \
296         %{?with_java:ac_cv_prog_JAVAC=%{java_home}/bin/javac} \
297         %{?with_java:ac_cv_prog_JAR=%{java_home}/bin/jar} \
298         --enable-agent \
299         %{__enable_disable agent2} \
300         --enable-ipv6 \
301         %{__enable_disable java} \
302         --with-ldap \
303         --with-libcurl \
304         --with-libevent \
305         --with-libpcre2 \
306         --with-libxml2 \
307         --with-net-snmp \
308         --with-openipmi \
309         --with-openssl \
310         --with-ssh2 \
311         --with-unixodbc \
312         "$@"
313 }
314
315 configure \
316         --disable-server \
317         --disable-proxy
318
319 %{__make}
320
321 for database in %{databases} ; do
322         if [ "$database" = "sqlite3" ] ; then
323                 enable_server=""
324         else
325                 enable_server="--enable-server"
326         fi
327         configure \
328                 --with-$database \
329                 $enable_server \
330                 --enable-proxy
331
332         %{__make}
333
334         if [ "$enable_server" ] ; then
335                 %{__make} install \
336                         -C src/zabbix_server \
337                         DESTDIR=$PWD/install-${database}
338         fi
339
340         %{__make} install \
341                 -C src/zabbix_proxy \
342                 DESTDIR=$PWD/install-${database}
343 done
344
345 %install
346 rm -rf $RPM_BUILD_ROOT
347 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_agent2.conf.d,/etc/{rc.d/init.d,sysconfig},/etc/webapps/%{_webapp},%{_appdir}} \
348         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix}
349
350 %{__make} install \
351         DESTDIR=$RPM_BUILD_ROOT \
352         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
353
354 for database in %{databases} ; do
355         if [ "$database" != "sqlite3" ] ; then
356                 cp -p install-$database/%{_sbindir}/zabbix_server \
357                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
358         fi
359         cp -p install-$database/%{_sbindir}/zabbix_proxy \
360                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
361 done
362
363 if [ -n "$database" ] ; then
364         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
365         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
366 fi
367
368 cp -r ui $RPM_BUILD_ROOT%{_appdir}
369
370 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
371 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
372
373 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
374 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_server
375 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_proxy
376 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
377 install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/zabbix_agent2
378
379 mv $RPM_BUILD_ROOT%{_appdir}/ui/conf $RPM_BUILD_ROOT%{_sysconfdir}/web
380 ln -s %{_sysconfdir}/web $RPM_BUILD_ROOT%{_appdir}/ui/conf
381 touch $RPM_BUILD_ROOT%{_sysconfdir}/web/zabbix.conf.php
382
383 %if %{with java}
384 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
385 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
386 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
387 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
388 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
389 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
390
391 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
392 #!/bin/sh
393
394 exec %{_datadir}/zabbix_java/startup.sh "$@"
395 EOF
396
397 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
398 #!/bin/sh
399
400 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
401 EOF
402 %endif
403
404 %clean
405 rm -rf $RPM_BUILD_ROOT
406
407 %triggerin web -- apache < 2.2.0, apache-base
408 %webapp_register httpd %{_webapp}
409
410 %triggerun web -- apache < 2.2.0, apache-base
411 %webapp_unregister httpd %{_webapp}
412
413 %pre
414 %groupadd -g 111 zabbix
415 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
416 %addusertogroup -q zabbix proc
417
418 %postun
419 if [ "$1" = "0" ]; then
420         %userremove zabbix
421         %groupremove zabbix
422 fi
423
424 %post server-mysql
425 if [ "$1" = 1 ]; then
426         %banner -e %{name}-server <<-EOF
427         You should create database for Zabbix.
428
429         Running these should be fine in most cases:
430
431         mysqladmin create zabbix
432         cat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql | mysql zabbix
433         cat %{_docdir}/%{name}-server-mysql-%{version}/images.sql | mysql zabbix
434         cat %{_docdir}/%{name}-server-mysql-%{version}/data.sql | mysql zabbix
435 EOF
436 fi
437 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
438
439 %post server-postgresql
440 if [ "$1" = 1 ]; then
441         %banner -e %{name}-server <<-EOF
442         You should create database for Zabbix.
443
444         Running these should be fine in most cases:
445
446         createuser -U postgres zabbix
447         createdb -U postgres -O zabbix zabbix
448         cat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql | psql -U zabbix zabbix
449         cat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql | psql -U zabbix zabbix
450         cat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql | psql -U zabbix zabbix
451 EOF
452 fi
453 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
454
455 %post server
456 /sbin/chkconfig --add zabbix_server
457 %service zabbix_server restart
458
459 %postun server
460 if [ "$1" = "0" ]; then
461         %service -q zabbix_server stop
462         /sbin/chkconfig --del zabbix_server
463 fi
464 if [ "$1" = "0" ]; then
465         if [ -L %{_sbindir}/zabbix_server ] ; then
466                 rm -f %{_sbindir}/zabbix_server || :
467         fi
468 fi
469
470 %post agentd
471 /sbin/chkconfig --add zabbix_agentd
472 %service zabbix_agentd restart
473
474 %preun agentd
475 if [ "$1" = "0" ]; then
476         %service -q zabbix_agentd stop
477         /sbin/chkconfig --del zabbix_agentd
478 fi
479
480 %post agent2
481 /sbin/chkconfig --add zabbix_agent2
482 %service zabbix_agent2 restart
483
484 %preun agent2
485 if [ "$1" = "0" ]; then
486         %service -q zabbix_agent2 stop
487         /sbin/chkconfig --del zabbix_agent2
488 fi
489
490 %post proxy-mysql
491 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
492
493 %post proxy-postgresql
494 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
495
496 %post proxy-sqlite3
497 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
498
499 %post proxy
500 /sbin/chkconfig --add zabbix_server
501 %service zabbix_server restart
502
503 %postun proxy
504 if [ "$1" = "0" ]; then
505         %service -q zabbix_proxy stop
506         /sbin/chkconfig --del zabbix_proxy
507 fi
508 if [ "$1" = "0" ]; then
509         if [ -L %{_sbindir}/zabbix_proxy ] ; then
510                 rm -f %{_sbindir}/zabbix_proxy || :
511         fi
512 fi
513
514 %files
515 %defattr(644,root,root,755)
516 %doc AUTHORS ChangeLog README
517 %attr(755,root,root) %{_bindir}/zabbix_get
518 %attr(755,root,root) %{_bindir}/zabbix_js
519 %attr(755,root,root) %{_bindir}/zabbix_sender
520 %attr(751,root,zabbix) %dir %{_sysconfdir}
521 %attr(751,root,http) %dir %{_sysconfdir}/web
522 %dir %{_appdir}
523 %dir %attr(770,root,zabbix) /var/run/zabbix
524 %dir %attr(775,root,zabbix) /var/log/zabbix
525 %{_mandir}/man1/zabbix_get*
526 %{_mandir}/man1/zabbix_sender*
527
528 %files agentd
529 %defattr(644,root,root,755)
530 %doc conf/zabbix_agentd/*.conf
531 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
532 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
533 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
534 %attr(755,root,root) %{_sbindir}/zabbix_agentd
535 %{_mandir}/man8/zabbix_agentd*
536
537 %if %{with agent2}
538 %files agent2
539 %defattr(644,root,root,755)
540 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
541 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d
542 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d/plugins.d
543 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.conf.d
544 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/ceph.conf
545 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/docker.conf
546 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/memcached.conf
547 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/modbus.conf
548 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/mqtt.conf
549 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/mysql.conf
550 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/oracle.conf
551 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/redis.conf
552 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/smart.conf
553 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/zabbix_agent2
555 %attr(755,root,root) %{_sbindir}/zabbix_agent2
556 %{_mandir}/man8/zabbix_agent2*
557 %endif
558
559 %files web
560 %defattr(644,root,root,755)
561 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
564 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/zabbix.conf.php
565 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/.htaccess
566 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/maintenance.inc.php
567 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/zabbix.conf.php.example
568 %{_appdir}/ui
569
570 %if %{any_database}
571 %files proxy
572 %defattr(644,root,root,755)
573 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
574 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
575 %attr(754,root,root) /etc/rc.d/init.d/zabbix_proxy
576 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
577 %{_mandir}/man8/zabbix_proxy*
578 %endif
579
580 %if %{with mysql}
581 %files proxy-mysql
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
584 %endif
585
586 %if %{with pgsql}
587 %files proxy-postgresql
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
590 %endif
591
592 %if %{with sqlite3}
593 %files proxy-sqlite3
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
596 %endif
597
598
599 %if %{any_database}
600 %files server
601 %defattr(644,root,root,755)
602 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
603 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
604 %attr(754,root,root) /etc/rc.d/init.d/zabbix_server
605 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
606 %{_mandir}/man8/zabbix_server*
607 %endif
608
609 %if %{with mysql}
610 %files server-mysql
611 %defattr(644,root,root,755)
612 %doc database/mysql/*.sql
613 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
614 %endif
615
616 %if %{with pgsql}
617 %files server-postgresql
618 %defattr(644,root,root,755)
619 %doc database/postgresql/*.sql
620 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
621 %endif
622
623 %if %{with java}
624 %files java
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_sbindir}/zabbix_java-start
627 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
628 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
629 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
630 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
631 %dir %{_datadir}/zabbix_java
632 %{_datadir}/zabbix_java/bin
633 %{_datadir}/zabbix_java/lib
634 %{_datadir}/zabbix_java/settings.sh
635 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
636 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
637 %endif