]> TLD Linux GIT Repositories - packages/zabbix.git/blob - zabbix.spec
42904450224590071d17aac1e7d3f3edff60d26b
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  pgsql   # enable PostgreSQL support
6 %bcond_without  sqlite3 # enable sqlite3 support
7 %bcond_without  mysql   # enable MySQL support
8 %bcond_without  java    # disable java support
9
10 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
11 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
12
13 %define         php_min_version 5.4.0
14 Summary:        Zabbix - network monitoring software
15 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
16 Name:           zabbix
17 Version:        6.0.5
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/6.0/%{name}-%{version}.tar.gz
22 # Source0-md5:  9151f516132d7219a0cda09ddd79697d
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}_agentd.init
25 Source3:        %{name}_server.init
26 Source4:        %{name}_proxy.init
27 Patch0:         tld.patch
28 Patch1:         sqlite3_dbname.patch
29 Patch2:         always_compile_ipc.patch
30 URL:            https://www.zabbix.com/
31 BuildRequires:  OpenIPMI-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake >= 1:1.15
34 BuildRequires:  curl-devel
35 #BuildRequires: iksemel-devel
36 %{?with_java:BuildRequires:     jdk}
37 BuildRequires:  libevent-devel
38 BuildRequires:  libssh2-devel
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel
41 %{?with_mysql:BuildRequires:    mysql-devel}
42 BuildRequires:  net-snmp-devel
43 BuildRequires:  openldap-devel >= 2.4.6
44 BuildRequires:  openssl-devel >= 0.9.7d
45 BuildRequires:  pcre-devel
46 %{?with_pgsql:BuildRequires:    postgresql-devel}
47 BuildRequires:  rpmbuild(macros) >= 1.671
48 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
49 BuildRequires:  unixODBC-devel
50 BuildRequires:  zlib-devel
51 Requires(postun):       /usr/sbin/groupdel
52 Requires(postun):       /usr/sbin/userdel
53 Requires(pre):  /bin/id
54 Requires(pre):  /usr/bin/getgid
55 Requires(pre):  /usr/sbin/groupadd
56 Requires(pre):  /usr/sbin/useradd
57 Provides:       group(zabbix)
58 Provides:       user(zabbix)
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _sysconfdir     /etc/%{name}
62 %define         _appdir         %{_datadir}/%{name}
63 %define         _webapps        /etc/webapps
64 %define         _webapp         %{name}
65
66 %description
67 Zabbix is software that monitors numerous parameters of a network and
68 the servers on that network. It is a useful tool for monitoring the
69 health and integrity of servers. Zabbix uses a flexible notification
70 mechanism that allows users to configure email based alerts for
71 virtually any event. All monitored parameters are stored in a
72 database. Zabbix offers excellent reporting and data visualisation
73 features based on the stored data. Zabbix supports both polling and
74 trapping. All Zabbix reports and statistics, as well as configuration
75 parameters, are accessed through a web-based front end.
76
77 %description -l pl.UTF-8
78 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
79 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
80 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
81 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
82 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
83 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
84 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
85 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
86 statystyk Zabbixa jest możliwy poprzez interfejs oparty o WWW.
87
88 %package agentd
89 Summary:        Zabbix Agent
90 Summary(pl.UTF-8):      Agenta Zabbixa
91 Group:          Networking/Utilities
92 Requires:       %{name} = %{version}-%{release}
93 Obsoletes:      zabbix-agent-inetd
94 Obsoletes:      zabbix-agent-standalone
95 Requires(post,preun):   /sbin/chkconfig
96 Requires:       rc-scripts
97
98 %description agentd
99 Zabbix agent collects data from the local system for a Zabbix server.
100
101 %description agentd -l pl.UTF-8
102 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
103
104 %package web
105 Summary:        Web frontend for Zabbix
106 Summary(pl.UTF-8):      Interfejs Web dla Zabbixa
107 Group:          Applications/WWW
108 Requires:       php(bcmath)
109 Requires:       php(core) >= %{php_min_version}
110 Requires:       php(ctype)
111 Requires:       php(gd)
112 Requires:       php(gettext)
113 Requires:       php(json)
114 Requires:       php(mbstring)
115 Requires:       php(pcre)
116 Requires:       php(session)
117 Requires:       php(sockets)
118 Requires:       php(xml)
119 Requires:       php(xmlreader)
120 Requires:       php(xmlwriter)
121 Requires:       webapps
122 Requires:       webserver(alias)
123 Requires:       webserver(indexfile)
124 Requires:       webserver(php)
125 Suggests:       php(mysql)
126 Suggests:       php(pgsql)
127 Suggests:       php(sqlite3)
128 # used with sqlite3
129 Suggests:       php(sysvsem)
130 BuildArch:      noarch
131
132 %description web
133 This package provides web based (PHP) frontend for Zabbix.
134
135 %description web -l pl.UTF-8
136 Ten pakiet dostarcza napisany w PHP frontend dla Zabbixa.
137
138 %package proxy
139 Summary:        Zabbix proxy
140 Summary(pl.UTF-8):      Proxy do Zabbixa
141 Group:          Networking/Utilities
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       zabbix-proxy(db) = %{version}-%{release}
144
145 %description proxy
146 This package provides the Zabbix proxy.
147
148 %description proxy -l pl.UTF-8
149 Ten pakiet zawiera proxy Zabbix.
150
151 %package proxy-mysql
152 Summary:        MySQL support for Zabbix proxy
153 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbixa
154 Group:          Networking/Utilities
155 Provides:       %{name}-proxy(db) = %{version}-%{release}
156 Obsoletes:      zabbix-proxy-postgresql
157 Obsoletes:      zabbix-proxy-sqlite3
158
159 %description proxy-mysql
160 This package provides the Zabbix proxy binary with MySQL support.
161
162 %description proxy-mysql -l pl.UTF-8
163 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
164
165 %package proxy-postgresql
166 Summary:        PostgreSQL support for Zabbix proxy
167 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbixa
168 Group:          Networking/Utilities
169 Provides:       %{name}-proxy(db) = %{version}-%{release}
170 Obsoletes:      zabbix-proxy-mysql
171 Obsoletes:      zabbix-proxy-sqlite3
172
173 %description proxy-postgresql
174 This package provides the Zabbix proxy binary with PostgreSQL support.
175
176 %description proxy-postgresql -l pl.UTF-8
177 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
178
179 %package proxy-sqlite3
180 Summary:        SQLite 3 support for Zabbix proxy
181 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbixa
182 Group:          Networking/Utilities
183 Provides:       %{name}-proxy(db) = %{version}-%{release}
184 Obsoletes:      zabbix-proxy-mysql
185 Obsoletes:      zabbix-proxy-postgresql
186
187 %description proxy-sqlite3
188 This package provides the Zabbix proxy binary with SQLite 3 support.
189
190 %description proxy-sqlite3 -l pl.UTF-8
191 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
192
193 %package server
194 Summary:        Zabbix server
195 Summary(pl.UTF-8):      Serwer Zabbixa
196 Group:          Networking/Utilities
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       %{name}-server(db) = %{version}-%{release}
199 Obsoletes:      zabbix-suckerd
200 Obsoletes:      zabbix-trapper-inetd
201 Obsoletes:      zabbix-trapper-standalone
202
203 %description server
204 This package provides the Zabbix server.
205
206 %description server -l pl.UTF-8
207 Ten pakiet zawiera serwer Zabbixa.
208
209 %package server-mysql
210 Summary:        MySQL support for Zabbix server
211 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbixa
212 Group:          Networking/Utilities
213 Provides:       %{name}-server(db) = %{version}-%{release}
214 Obsoletes:      zabbix-server-postgresql
215 Obsoletes:      zabbix-server-sqlite3
216
217 %description server-mysql
218 This package provides the Zabbix server binary for use with MySQL
219 database.
220
221 %description server-mysql -l pl.UTF-8
222 Ten pakiet zawiera serwer Zabbixa z obsługą bazy danych MySQL.
223
224 %package server-postgresql
225 Summary:        PostgreSQL support for Zabbix server
226 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbixa
227 Group:          Networking/Utilities
228 Provides:       %{name}-server(db) = %{version}-%{release}
229 Obsoletes:      zabbix-server-mysql
230 Obsoletes:      zabbix-server-sqlite3
231
232 %description server-postgresql
233 This package provides the Zabbix server binary for use with PostgreSQL
234 database.
235
236 %description server-postgresql -l pl.UTF-8
237 Ten pakiet zawiera serwer Zabbixa z obsługą bazy danych PostgreSQL.
238
239 %package java
240 Summary:        Zabbix Java Gateway
241 Group:          Networking/Utilities
242 Requires:       %{name} = %{version}-%{release}
243
244 %description java
245 This package provides the Zabbix Java Gateway.
246
247 %prep
248 %setup -q
249
250 %patch0 -p1
251 %patch1 -p1
252 %patch2 -p1
253
254 %build
255 %{__libtoolize}
256 %{__aclocal} -I m4
257 %{__autoconf}
258 %{__autoheader}
259 %{__automake}
260
261 configure() {
262         %configure \
263         --enable-agent \
264         --enable-agent2 \
265         --enable-ipv6 \
266         %{__enable_disable java} \
267         --with-jabber \
268         --with-ldap \
269         --with-libcurl \
270         --with-libxml2 \
271         --with-net-snmp \
272         --with-openipmi \
273         --with-openssl \
274         --with-ssh2 \
275         --with-unixodbc \
276         "$@"
277 }
278
279 configure \
280         --disable-server \
281         --disable-proxy
282
283 %{__make}
284
285 for database in %{databases} ; do
286         if [ "$database" = "sqlite3" ] ; then
287                 enable_server=""
288         else
289                 enable_server="--enable-server"
290         fi
291         configure \
292                 --with-$database \
293                 $enable_server \
294                 --enable-proxy
295
296         %{__make}
297
298         if [ "$enable_server" ] ; then
299                 %{__make} install \
300                         -C src/zabbix_server \
301                         DESTDIR=$PWD/install-${database}
302         fi
303
304         %{__make} install \
305                 -C src/zabbix_proxy \
306                 DESTDIR=$PWD/install-${database}
307 done
308
309 %install
310 rm -rf $RPM_BUILD_ROOT
311 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d,/etc/webapps/%{_webapp},%{_appdir}} \
312         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix}
313
314 %{__make} install \
315         DESTDIR=$RPM_BUILD_ROOT \
316         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
317
318 for database in %{databases} ; do
319         if [ "$database" != "sqlite3" ] ; then
320                 cp -p install-$database/%{_sbindir}/zabbix_server \
321                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
322         fi
323         cp -p install-$database/%{_sbindir}/zabbix_proxy \
324                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
325 done
326
327 if [ -n "$database" ] ; then
328         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
329         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
330 fi
331
332 cp -r ui $RPM_BUILD_ROOT%{_appdir}
333
334 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
335 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
336
337 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
338 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_server
339 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_proxy
340
341 mv $RPM_BUILD_ROOT%{_appdir}/ui/conf $RPM_BUILD_ROOT%{_sysconfdir}/web
342 ln -s %{_sysconfdir}/web $RPM_BUILD_ROOT%{_appdir}/ui/conf
343 touch $RPM_BUILD_ROOT%{_sysconfdir}/web/zabbix.conf.php
344
345 %if %{with java}
346 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
347 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
348 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
349 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
350 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
351 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
352
353 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
354 #!/bin/sh
355
356 exec %{_datadir}/zabbix_java/startup.sh "$@"
357 EOF
358
359 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
360 #!/bin/sh
361
362 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
363 EOF
364 %endif
365
366 %clean
367 rm -rf $RPM_BUILD_ROOT
368
369 %triggerin web -- apache < 2.2.0, apache-base
370 %webapp_register httpd %{_webapp}
371
372 %triggerun web -- apache < 2.2.0, apache-base
373 %webapp_unregister httpd %{_webapp}
374
375 %pre
376 %groupadd -g 111 zabbix
377 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
378 %addusertogroup -q zabbix proc
379
380 %postun
381 if [ "$1" = "0" ]; then
382         %userremove zabbix
383         %groupremove zabbix
384 fi
385
386 %post server-mysql
387 if [ "$1" = 1 ]; then
388         %banner -e %{name}-server <<-EOF
389         You should create database for Zabbix.
390
391         Running these should be fine in most cases:
392
393         mysqladmin create zabbix
394         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
395         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
396         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
397 EOF
398 fi
399 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
400
401 %post server-postgresql
402 if [ "$1" = 1 ]; then
403         %banner -e %{name}-server <<-EOF
404         You should create database for Zabbix.
405
406         Running these should be fine in most cases:
407
408         createuser -U postgres zabbix
409         createdb -U postgres -O zabbix zabbix
410         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -U zabbix zabbix
411         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -U zabbix zabbix
412         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -U zabbix zabbix
413 EOF
414 fi
415 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
416
417 %post server
418 /sbin/chkconfig --add zabbix_server
419 %service zabbix_server restart
420
421 %postun server
422 if [ "$1" = "0" ]; then
423         %service -q zabbix_server stop
424         /sbin/chkconfig --del zabbix_server
425 fi
426 if [ "$1" = "0" ]; then
427         if [ -L %{_sbindir}/zabbix_server ] ; then
428                 rm -f %{_sbindir}/zabbix_server || :
429         fi
430 fi
431
432 %post agentd
433 /sbin/chkconfig --add zabbix_agentd
434 %service zabbix_agentd restart
435
436 %preun agentd
437 if [ "$1" = "0" ]; then
438         %service -q zabbix_agentd stop
439         /sbin/chkconfig --del zabbix_agentd
440 fi
441
442 %post proxy-mysql
443 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
444
445 %post proxy-postgresql
446 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
447
448 %post proxy-sqlite3
449 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
450
451 %post proxy
452 /sbin/chkconfig --add zabbix_server
453 %service zabbix_server restart
454
455 %postun proxy
456 if [ "$1" = "0" ]; then
457         %service -q zabbix_proxy stop
458         /sbin/chkconfig --del zabbix_proxy
459 fi
460 if [ "$1" = "0" ]; then
461         if [ -L %{_sbindir}/zabbix_proxy ] ; then
462                 rm -f %{_sbindir}/zabbix_proxy || :
463         fi
464 fi
465
466 %files
467 %defattr(644,root,root,755)
468 %doc AUTHORS ChangeLog README
469 %attr(755,root,root) %{_bindir}/zabbix_get
470 %attr(755,root,root) %{_bindir}/zabbix_js
471 %attr(755,root,root) %{_bindir}/zabbix_sender
472 %attr(751,root,zabbix) %dir %{_sysconfdir}
473 %attr(751,root,http) %dir %{_sysconfdir}/web
474 %dir %{_appdir}
475 %dir %attr(770,root,zabbix) /var/run/zabbix
476 %dir %attr(775,root,zabbix) /var/log/zabbix
477 %{_mandir}/man1/zabbix_get*
478 %{_mandir}/man1/zabbix_sender*
479
480 %files agentd
481 %defattr(644,root,root,755)
482 %doc conf/zabbix_agentd/*.conf
483 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
484 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
485 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
486 %attr(755,root,root) %{_sbindir}/zabbix_agentd
487 %{_mandir}/man8/zabbix_agentd*
488
489 %files web
490 %defattr(644,root,root,755)
491 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
492 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
493 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
494 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/zabbix.conf.php
495 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/.htaccess
496 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/maintenance.inc.php
497 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/web/zabbix.conf.php.example
498 %{_appdir}/ui
499
500 %if %{any_database}
501 %files proxy
502 %defattr(644,root,root,755)
503 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
504 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
505 %attr(754,root,root) /etc/rc.d/init.d/zabbix_proxy
506 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
507 %{_mandir}/man8/zabbix_proxy*
508 %endif
509
510 %if %{with mysql}
511 %files proxy-mysql
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
514 %endif
515
516 %if %{with pgsql}
517 %files proxy-postgresql
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
520 %endif
521
522 %if %{with sqlite3}
523 %files proxy-sqlite3
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
526 %endif
527
528
529 %if %{any_database}
530 %files server
531 %defattr(644,root,root,755)
532 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
533 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
534 %attr(754,root,root) /etc/rc.d/init.d/zabbix_server
535 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
536 %{_mandir}/man8/zabbix_server*
537 %endif
538
539 %if %{with mysql}
540 %files server-mysql
541 %defattr(644,root,root,755)
542 %doc database/mysql/*.sql
543 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
544 %endif
545
546 %if %{with pgsql}
547 %files server-postgresql
548 %defattr(644,root,root,755)
549 %doc database/postgresql/*.sql
550 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
551 %endif
552
553 %if %{with java}
554 %files java
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_sbindir}/zabbix_java-start
557 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
558 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
559 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
560 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
561 %dir %{_datadir}/zabbix_java
562 %{_datadir}/zabbix_java/bin
563 %{_datadir}/zabbix_java/lib
564 %{_datadir}/zabbix_java/settings.sh
565 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
566 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
567 %endif