]> TLD Linux GIT Repositories - packages/mksh.git/commitdiff
- update to 53a, apply missed circumflex patch
authorMarcin Krol <hawk@tld-linux.org>
Thu, 18 Aug 2016 06:56:08 +0000 (06:56 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 18 Aug 2016 06:56:08 +0000 (06:56 +0000)
mksh-circumflex.patch
mksh-cmdline-length.patch [deleted file]
mksh-mkshrc_support.patch
mksh.spec

index f52bbed77c3a945c3a6a51ea8028b7893f7dfd65..97ddc42feb9186673efc120862a8c4bc94be383f 100644 (file)
@@ -1,7 +1,19 @@
-diff -ur mksh-40.org//eval.c mksh-40/eval.c
---- mksh-40.org//eval.c        2011-06-12 16:45:57.000000000 +0200
-+++ mksh-40/eval.c     2011-07-07 18:27:58.891492090 +0200
-@@ -887,6 +887,7 @@
+diff -urp mksh.orig/check.t mksh/check.t
+--- mksh.orig/check.t  2016-08-12 16:48:28.000000000 +0000
++++ mksh/check.t       2016-08-18 06:51:31.069554000 +0000
+@@ -2274,7 +2274,7 @@ expected-stdout:
+       cbc
+       -bc cbc
+       abc bbc
+-      ^bc abc bbc
++      !bc -bc ^bc cbc
+       !bc -bc ^bc cbc
+ ---
+ name: glob-range-2
+diff -urp mksh.orig/eval.c mksh/eval.c
+--- mksh.orig/eval.c   2016-08-01 21:38:27.000000000 +0000
++++ mksh/eval.c        2016-08-18 06:51:31.063554000 +0000
+@@ -972,6 +972,7 @@ expand(
                                switch (c) {
                                case '[':
                                case '!':
@@ -9,10 +21,10 @@ diff -ur mksh-40.org//eval.c mksh-40/eval.c
                                case '-':
                                case ']':
                                        /*
-diff -ur mksh-40.org//misc.c mksh-40/misc.c
---- mksh-40.org//misc.c        2011-06-12 16:45:58.000000000 +0200
-+++ mksh-40/misc.c     2011-07-07 18:28:39.015826686 +0200
-@@ -843,7 +843,7 @@
+diff -urp mksh.orig/misc.c mksh/misc.c
+--- mksh.orig/misc.c   2016-08-01 18:43:08.000000000 +0000
++++ mksh/misc.c        2016-08-18 06:51:31.064554000 +0000
+@@ -902,7 +902,7 @@ gmatch_cclass(const unsigned char *p, un
        bool notp, found = false;
        const unsigned char *orig_p = p;
  
@@ -21,25 +33,14 @@ diff -ur mksh-40.org//misc.c mksh-40/misc.c
                p++;
        do {
                c = *p++;
-diff -ur mksh-40.org//sh.h mksh-40/sh.h
---- mksh-40.org//sh.h  2011-06-12 16:59:09.000000000 +0200
-+++ mksh-40/sh.h       2011-07-07 18:29:16.346761511 +0200
-@@ -380,5 +380,6 @@
+diff -urp mksh.orig/sh.h mksh/sh.h
+--- mksh.orig/sh.h     2016-08-12 16:48:31.000000000 +0000
++++ mksh/sh.h  2016-08-18 06:51:31.066554000 +0000
+@@ -501,6 +501,7 @@ extern int __cdecl setegid(gid_t);
+  */
  #define MAGIC         (7)     /* prefix for *?[!{,} during expand */
  #define ISMAGIC(c)    ((unsigned char)(c) == MAGIC)
 +#define NOT2          '^'
  
#define LINE          4096    /* input line size */
EXTERN const char *safe_prompt; /* safe prompt if PS1 substitution fails */
  
-diff -urN mksh.org/check.t mksh/check.t
---- mksh.org/check.t   2014-01-11 19:10:02.000000000 +0100
-+++ mksh/check.t       2014-01-20 14:12:37.924222697 +0100
-@@ -2085,7 +2085,7 @@
-       cbc
-       -bc cbc
-       abc bbc
--      ^bc abc bbc
-+      !bc -bc ^bc cbc
-       !bc -bc ^bc cbc
- ---
- name: glob-range-2
diff --git a/mksh-cmdline-length.patch b/mksh-cmdline-length.patch
deleted file mode 100644 (file)
index 0225f51..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- mksh-48b/sh.h~     2013-10-15 09:18:13.000000000 +0200
-+++ mksh-48b/sh.h      2013-10-15 09:18:46.706838235 +0200
-@@ -985,7 +985,7 @@
- EXTERN char   *current_wd;
- /* input line size */
--#define LINE          (4096 - ALLOC_OVERHEAD)
-+#define LINE          (16384 - ALLOC_OVERHEAD)
- /*
-  * Minimum required space to work with on a line - if the prompt leaves
-  * less space than this on a line, the prompt is truncated.
index 15465a635bbf2e78e19492d5f59f988b3ee46529..38baf33fc1117a5c8071c7828bdc0b9549266fd0 100644 (file)
@@ -1,6 +1,7 @@
---- mksh-50/main.c.orig        2014-08-21 18:13:38.072682886 +0200
-+++ mksh-50/main.c     2014-08-21 18:29:13.715976954 +0200
-@@ -591,10 +591,14 @@
+diff -urp mksh.orig/main.c mksh/main.c
+--- mksh.orig/main.c   2016-08-04 20:52:01.000000000 +0000
++++ mksh/main.c        2016-08-18 06:47:50.115554000 +0000
+@@ -611,10 +611,14 @@ main_init(int argc, const char *argv[],
                if (Flag(FLOGIN))
                        include(substitute("$HOME/.profile", 0), 0, NULL, true);
                if (Flag(FTALKING)) {
index 7114292122b1dea52200c880cb2c2ee90e0b3362..d10d1f134d7642645e2b916188843d1fdffacac4 100644 (file)
--- a/mksh.spec
+++ b/mksh.spec
@@ -6,15 +6,15 @@
 Summary:       MirBSD Korn Shell
 Summary(pl.UTF-8):     Powłoka Korna z MirBSD
 Name:          mksh
-Version:       52c
+Version:       53a
 Release:       1
 License:       BSD
 Group:         Applications/Shells
 Source0:       http://www.mirbsd.org/MirOS/dist/mir/mksh/%{name}-R%{version}.tgz
-# Source0-md5: cc3884e02314447e7b4a3073b8d65d1e
+# Source0-md5: 43fc3e32963cc1795a299bcec531d770
 Source1:       %{name}-mkshrc
 Patch0:                %{name}-mkshrc_support.patch
-Patch1:                %{name}-cmdline-length.patch
+Patch1:                %{name}-circumflex.patch
 URL:           https://www.mirbsd.org/mksh.htm
 %if %{with tests}
 BuildRequires: ed