]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- updated to 2.02.140
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_with     initrd          # build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_without  lvmetad         # disable lvmetad (and lvmlockd)
12 %bcond_without  lvmpolld        # disable lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # disable lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 %bcond_with     replicator      # internal replicator support
16 %bcond_without  selinux         # SELinux support
17 %bcond_without  python          # Python binding
18
19 # lvmlockd requires lvmetad and lvmpolld
20 %if %{without lvmetad} || %{without lvmpolld}
21 %undefine       with_lvmpolld
22 %endif
23
24 # if one of the *libc is enabled disable default dietlibc
25 %if %{with dietlibc} && %{with uClibc}
26 %undefine       with_dietlibc
27 %endif
28
29 # with glibc disables default dietlibc
30 %if %{with glibc} && %{with dietlibc}
31 %undefine       with_dietlibc
32 %endif
33
34 # fallback is glibc if neither alternatives are enabled
35 %if %{without dietlibc} && %{without uClibc}
36 %define         with_glibc      1
37 %endif
38
39 Summary:        The new version of Logical Volume Manager for Linux
40 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
41 Name:           lvm2
42 Version:        2.02.140
43 Release:        1
44 License:        GPL v2 and LGPL v2.1
45 Group:          Applications/System
46 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
47 # Source0-md5:  f2191c4798c8927a6d31a96010b9f568
48 Source1:        clvmd.sysconfig
49 Patch0:         %{name}-selinux.patch
50 Patch1:         %{name}-diet.patch
51 Patch2:         device-mapper-dmsetup-export.patch
52 Patch3:         %{name}-tld_init.patch
53 Patch4:         dl-dlsym.patch
54 Patch6:         %{name}-lvm_path.patch
55 Patch7:         %{name}-clvmd_cmd_timeout.patch
56 Patch8:         device-mapper-dmsetup-deps-export.patch
57 Patch9:         %{name}-run-dir.patch
58 URL:            http://www.sourceware.org/lvm2/
59 BuildRequires:  autoconf >= 2.61
60 BuildRequires:  automake
61 # for /run detection
62 BuildRequires:  filesystem >= 3.0-43
63 BuildRequires:  libblkid-devel >= 2.24
64 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
65 %{?with_selinux:BuildRequires:  libsepol-devel}
66 BuildRequires:  ncurses-devel
67 BuildRequires:  pkgconfig
68 %{?with_python:BuildRequires:   python-devel >= 2}
69 BuildRequires:  readline-devel
70 BuildRequires:  rpmbuild(macros) >= 1.647
71 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.2.4}
72 BuildRequires:  udev-devel >= 1:176
73 %if %{with initrd}
74 %if %{with dietlibc}
75 BuildRequires:  dietlibc-static >= 2:0.32-7
76 BuildConflicts: device-mapper-dietlibc
77 %endif
78 %if %{with glibc}
79 %{?with_selinux:BuildRequires:  libselinux-static}
80 %{?with_selinux:BuildRequires:  libsepol-static}
81 %endif
82 %{?with_glibc:BuildRequires:    glibc-static}
83 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
84 %endif
85 %if %{with cluster}
86 BuildRequires:  corosync-devel
87 BuildRequires:  dlm-devel >= 3.99.5
88 %endif
89 Requires(post,postun):  /sbin/chkconfig
90 Requires:       device-mapper >= %{version}-%{release}
91 %{?with_selinux:Requires:       libselinux >= 1.10}
92 # doesn't work with 2.4 kernels
93 Requires:       uname(release) >= 2.6
94 Suggests:       thin-provisioning-tools >= 0.5.4
95 Obsoletes:      lvm
96 Obsoletes:      lvm2-systemd
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         _sbindir        /sbin
100 %define         _usrsbindir     /usr/sbin
101
102 # changing CFLAGS in the middle confuses confcache
103 %undefine       configure_cache
104
105 # borken on AC
106 %define         filterout_ld    -Wl,--as-needed
107
108 # causes: undefined reference to `__stack_chk_fail_local'
109 %define         filterout_c     -fstack-protector
110
111 # for some reason known only to rpm there must be "\\|" not "\|" here
112 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
113 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
114
115 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
116
117 %description
118 This package includes a number of utilities for creating, checking,
119 and repairing logical volumes.
120
121 %description -l pl.UTF-8
122 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
123 logicznych wolumenów dyskowych (LVM2).
124
125 %package initrd
126 Summary:        The new version of Logical Volume Manager for Linux - initrd version
127 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
128 Group:          Base
129 Conflicts:      geninitrd < 10000.18
130
131 %description initrd
132 This package includes a number of utilities for creating, checking,
133 and repairing logical volumes - staticaly linked for initrd.
134
135 %description initrd -l pl.UTF-8
136 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
137 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
138 potrzeby initrd.
139
140 %package clvmd
141 Summary:        Cluster LVM daemon
142 Summary(pl.UTF-8):      Demon clustra LVM
143 Group:          Applications/System
144 Requires:       %{name} = %{version}-%{release}
145
146 %description clvmd
147 clvmd is the daemon that distributes LVM metadata updates around a
148 cluster. It must be running on all nodes in the cluster and will give
149 an error if a node in the cluster does not have this daemon running.
150
151 %description clvmd -l pl.UTF-8
152 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
153 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
154 węzeł w klastrze nie ma tego demona uruchomionego.
155
156 %package cmirrord
157 Summary:        Cluster mirror log daemon
158 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
159 Group:          Applications/System
160 Requires:       %{name} = %{version}-%{release}
161
162 %description cmirrord
163 cmirrord is the daemon that tracks mirror log information in a
164 cluster. It is specific to device-mapper based mirrors (and by
165 extension, LVM cluster mirrors). Cluster mirrors are not possible
166 without this daemon running.
167
168 This daemon relies on the cluster infrastructure provided by the
169 Cluster MANager (CMAN), which must be set up and running in order for
170 cmirrord to function.
171
172 %description cmirrord
173 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
174 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
175 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
176 lustrzanych ten demon jest niezbędny.
177
178 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
179 (Cluster MANager), który musi być skonfigurowany i działający, aby
180 działał cmirrord.
181
182 %package resource-agents
183 Summary:        OCF Resource Agents for LVM2 processes
184 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
185 Group:          Applications/System
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       resource-agents
188
189 %description resource-agents
190 OCF Resource Agents for LVM2 processes.
191
192 %description resource-agents -l pl.UTF-8
193 Agenci OCF do monitorowania procesów LVM2.
194
195 %package -n python-lvm
196 Summary:        Python interface to LVM2
197 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
198 Group:          Libraries/Python
199 Requires:       device-mapper-libs = %{version}-%{release}
200
201 %description -n python-lvm
202 Python interface to LVM2.
203
204 %description -n python-lvm -l pl.UTF-8
205 Interfejs Pythona do LVM2.
206
207 %package -n device-mapper
208 Summary:        Userspace support for the device-mapper
209 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
210 Group:          Base
211 Requires(post,postun):  /sbin/ldconfig
212 Requires:       device-mapper-libs = %{version}-%{release}
213
214 %description -n device-mapper
215 The goal of this driver is to support volume management. The driver
216 enables the definition of new block devices composed of ranges of
217 sectors of existing devices. This can be used to define disk
218 partitions - or logical volumes. This light-weight kernel component
219 can support user-space tools for logical volume management.
220
221 %description -n device-mapper -l pl.UTF-8
222 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
223 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
224 sektorów na istniejących urządzeniach. Może to być wykorzystane do
225 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
226 składnik jądra może wspierać działające w przestrzeni użytkownika
227 narzędzia do zarządzania logicznymi wolumenami.
228
229 %package -n device-mapper-libs
230 Summary:        Device-mapper shared libraries
231 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
232 Group:          Libraries
233 Conflicts:      device-mapper < 2.02.119-1
234 Requires:       libblkid >= 2.24
235 Requires:       udev-libs >= 1:176
236
237 %description -n device-mapper-libs
238 Device-mapper shared libraries.
239
240 %description -n device-mapper-libs -l pl.UTF-8
241 Biblioteki współdzielone device-mappera.
242
243 %package -n device-mapper-devel
244 Summary:        Header files for device-mapper libraries
245 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
246 Group:          Development/Libraries
247 Requires:       device-mapper-libs = %{version}-%{release}
248 Requires:       libblkid-devel >= 2.24
249 %if %{with selinux}
250 Requires:       libselinux-devel
251 Requires:       libsepol-devel
252 %endif
253 Requires:       udev-devel >= 1:176
254
255 %description -n device-mapper-devel
256 Header files for device-mapper libraries.
257
258 %description -n device-mapper-devel -l pl.UTF-8
259 Pliki nagłówkowe bibliotek device-mappera.
260
261 %package -n device-mapper-static
262 Summary:        Static devmapper library
263 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
264 License:        LGPL v2.1
265 Group:          Development/Libraries
266 Requires:       device-mapper-devel = %{version}-%{release}
267
268 %description -n device-mapper-static
269 Static devmapper library.
270
271 %description -n device-mapper-static -l pl.UTF-8
272 Statyczna biblioteka devmapper.
273
274 %package -n device-mapper-dietlibc
275 Summary:        Static devmapper library built with dietlibc
276 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
277 License:        LGPL v2.1
278 Group:          Development/Libraries
279 Requires:       device-mapper-devel = %{version}-%{release}
280
281 %description -n device-mapper-dietlibc
282 Static devmapper library built with dietlibc.
283
284 %description -n device-mapper-dietlibc -l pl.UTF-8
285 Statyczna biblioteka devmapper zbudowana z dietlibc.
286
287 %package -n device-mapper-initrd
288 Summary:        Userspace support for the device-mapper - initrd version
289 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
290 Group:          Base
291 Obsoletes:      device-mapper-initrd-devel
292 Conflicts:      geninitrd < 10000.10
293
294 %description -n device-mapper-initrd
295 The goal of this driver is to support volume management. The driver
296 enables the definition of new block devices composed of ranges of
297 sectors of existing devices. This can be used to define disk
298 partitions - or logical volumes. This light-weight kernel component
299 can support user-space tools for logical volume management.
300
301 This package contains dmsetup program linked staticaly for use in
302 initrd.
303
304 %description -n device-mapper-initrd -l pl.UTF-8
305 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
306 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
307 sektorów na istniejących urządzeniach. Może to być wykorzystane do
308 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
309 składnik jądra może wspierać działające w przestrzeni użytkownika
310 narzędzia do zarządzania logicznymi wolumenami.
311
312 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
313 potrzeby initrd.
314
315 %prep
316 %setup -q -n LVM2.%{version}
317 %{?with_selinux:%patch0 -p1}
318 %patch1 -p1
319 %patch2 -p1
320 %patch3 -p1
321 %patch4 -p1
322 %patch6 -p1
323 %patch7 -p1
324 %patch8 -p1
325 %patch9 -p1
326
327 # do not force --export-symbol linker option for e.g. statically linked executables
328 # -rdynamic compiler option drives linker in the right way.
329 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
330
331 %build
332 %if %{with initrd}
333 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
334 %endif
335 cp -f /usr/share/automake/config.sub autoconf
336 %{__aclocal}
337 %{__autoconf}
338
339 %if %{with initrd}
340 %{?with_glibc:export CC="%{__cc}"}
341 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
342 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
343
344 %configure \
345         ac_cv_lib_dl_dlopen=no \
346         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
347         %{?debug:--enable-debug} \
348         --disable-nls \
349         --disable-readline \
350         --enable-selinux%{!?with_glibc:=no} \
351         --enable-static_link \
352         --with-lvm1=internal \
353         --with-optimisation="%{rpmcflags} -Os"
354 # glibc version links with normal static libdevicemapper which has selinux enabled
355 # and we need to keep these in sync between device-mapper and lvm2
356
357 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
358 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
359
360 %{__make} -j1 -C include
361 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
362 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
363 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
364 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
365 mv -f tools/lvm.static initrd-lvm
366 mv -f tools/dmsetup.static initrd-dmsetup
367
368 # check if tools works
369 for tool in initrd-lvm initrd-dmsetup; do
370         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
371         if [ $rc -gt 127 ]; then
372                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
373                 exit 1
374         fi
375 done
376
377 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
378 %{__make} clean
379
380 unset CC
381 %endif
382
383 %configure \
384         --enable-applib \
385         --enable-cmdlib \
386         %{?debug:--enable-debug} \
387         --enable-dmeventd \
388         --enable-fsadm \
389 %if %{with lvmlockd}
390         %{?with_cluster:--enable-lockd-dlm} \
391         %{?with_sanlock:--enable-lockd-sanlock} \
392 %endif
393         %{?with_lvmetad:--enable-lvmetad} \
394         --enable-ocf \
395         %{?with_python:--enable-python_bindings} \
396         --enable-readline \
397         %{!?with_selinux:--disable-selinux} \
398         --enable-pkgconfig \
399         --enable-udev_sync \
400         --enable-udev_rules \
401         --with-cache=internal \
402         --with-cache-check=/usr/sbin/cache_check \
403         --with-cache-dump=/usr/sbin/cache_dump \
404         --with-cache-repair=/usr/sbin/cache_repair \
405         --with-cache-restore=/usr/sbin/cache_restore \
406         --with-cluster=internal \
407 %if %{with cluster}
408         --with-clvmd=corosync \
409         --enable-cmirrord \
410 %endif
411         --with-dmeventd-path=%{_sbindir}/dmeventd \
412         --with-interface=ioctl \
413         --with-lvm1=internal \
414         --with-mirrors=internal \
415         --with-optimisation="%{rpmcflags}" \
416         --with-pool=internal \
417         %{?with_replicator:--with-replicators=internal} \
418         --with-snapshots=internal \
419         --with-thin=internal \
420         --with-thin-check=/usr/sbin/thin_check \
421         --with-thin-dump=/usr/sbin/thin_dump \
422         --with-thin-repair=/usr/sbin/thin_repair \
423         --with-thin-restore=/usr/sbin/thin_restore \
424         --with-udev-prefix=/ \
425         --with-usrlibdir=%{_libdir}
426
427 %{__make} -j1
428 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
429
430 %install
431 rm -rf $RPM_BUILD_ROOT
432 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
433 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
434
435 %{__make} install install_system_dirs install_initscripts \
436         DESTDIR=$RPM_BUILD_ROOT \
437         OWNER="" \
438         GROUP=""
439
440 %{__make} -C scripts \
441         DESTDIR=$RPM_BUILD_ROOT \
442
443 %if %{with cluster}
444 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
445 %endif
446
447 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
448 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
449         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
450         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
451         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
452 done
453
454 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
455
456 %if %{with initrd}
457 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
458 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
459 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
460
461 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
462 %endif
463
464 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %post
470 /sbin/chkconfig --add lvm2-lvmetad
471 %service lvm2-lvmetad restart
472 /sbin/chkconfig --add lvm2-monitor
473 %service lvm2-monitor restart
474 /sbin/chkconfig --add lvm2-lvmpolld
475 %service lvm2-lvmpolld restart
476 # no service restart available
477 /sbin/chkconfig --add blk-availability
478
479 %preun
480 if [ "$1" = "0" ]; then
481         %service lvm2-lvmetad stop
482         /sbin/chkconfig --del lvm2-lvmetad
483         %service lvm2-lvmpolld stop
484         /sbin/chkconfig --del lvm2-lvmpolld
485         %service lvm2-monitor stop
486         /sbin/chkconfig --del lvm2-monitor
487         /sbin/chkconfig --del blk-availability
488 fi
489
490 %post   -n device-mapper-libs -p /sbin/ldconfig
491 %postun -n device-mapper-libs -p /sbin/ldconfig
492
493 %post clvmd
494 /sbin/chkconfig --add clvmd
495 # no service restart - it breaks current locks!
496 export NORESTART=1
497 # re-exec instead
498 /usr/sbin/clvmd -S 2>/dev/null || :
499
500 %preun clvmd
501 if [ "$1" = "0" ]; then
502         %service clvmd stop
503         /sbin/chkconfig --del clvmd
504 fi
505
506 %files
507 %defattr(644,root,root,755)
508 %doc README WHATS_NEW doc/*
509 %attr(755,root,root) %{_sbindir}/blkdeactivate
510 %attr(755,root,root) %{_sbindir}/fsadm
511 %attr(755,root,root) %{_sbindir}/lv*
512 %attr(755,root,root) %{_sbindir}/pv*
513 %attr(755,root,root) %{_sbindir}/vg*
514 %{_mandir}/man5/lvm.conf.5*
515 %{_mandir}/man7/lvmcache.7*
516 %{_mandir}/man7/lvmsystemid.7*
517 %{_mandir}/man7/lvmthin.7*
518 %{_mandir}/man8/blkdeactivate.8*
519 %{_mandir}/man8/fsadm.8*
520 %{_mandir}/man8/lv*.8*
521 %{_mandir}/man8/pv*.8*
522 %{_mandir}/man8/vg*.8*
523 %attr(750,root,root) %dir %{_sysconfdir}/lvm
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
526 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
527 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
528 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
529 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
530 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
531 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
532 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
533 %if %{with lvmetad}
534 /lib/udev/rules.d/69-dm-lvm-metad.rules
535 %endif
536 %dir %{_sysconfdir}/lvm/cache
537 %ghost %{_sysconfdir}/lvm/cache/.cache
538 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
539 %if %{with lvmetad}
540 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
541 %endif
542 %if %{with lvmpolld}
543 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
544 %endif
545 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
546 %attr(700,root,root) %dir /var/lock/lvm
547 %attr(700,root,root) %dir /var/run/lvm
548
549 %if %{with cluster}
550 %files clvmd
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_usrsbindir}/clvmd
553 %attr(754,root,root) /etc/rc.d/init.d/clvmd
554 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
555 %{_mandir}/man8/clvmd.8*
556
557 %files cmirrord
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_usrsbindir}/cmirrord
560 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
561 %{_mandir}/man8/cmirrord.8*
562 %endif
563
564 %files resource-agents
565 %defattr(644,root,root,755)
566 %dir %{_prefix}/lib/ocf/resource.d/lvm2
567 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
568
569 %if %{with python}
570 %files -n python-lvm
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{py_sitedir}/lvm.so
573 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
574 %endif
575
576 %files -n device-mapper
577 %defattr(644,root,root,755)
578 %doc *_DM
579 /lib/udev/rules.d/10-dm.rules
580 /lib/udev/rules.d/11-dm-lvm.rules
581 /lib/udev/rules.d/13-dm-disk.rules
582 /lib/udev/rules.d/95-dm-notify.rules
583 %attr(755,root,root) %{_sbindir}/dmeventd
584 %attr(755,root,root) %{_sbindir}/dmsetup
585 %attr(755,root,root) %{_sbindir}/dmstats
586 %dir %{_libdir}/device-mapper
587 %attr(755,root,root) %{_libdir}/device-mapper/*.so
588 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
589 %{_mandir}/man8/dmsetup.8*
590 %{_mandir}/man8/dmstats.8*
591 %{_mandir}/man8/dmeventd.8*
592
593 %files -n device-mapper-libs
594 %defattr(644,root,root,755)
595 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
596 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
597 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
598 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
599 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
600
601 %files -n device-mapper-devel
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/libdevmapper.so
604 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
605 %attr(755,root,root) %{_libdir}/liblvm2app.so
606 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
607 %{_includedir}/libdevmapper.h
608 %{_includedir}/libdevmapper-event.h
609 %{_includedir}/lvm2app.h
610 %{_includedir}/lvm2cmd.h
611 %{_pkgconfigdir}/devmapper.pc
612 %{_pkgconfigdir}/devmapper-event.pc
613 %{_pkgconfigdir}/lvm2app.pc
614
615 %files -n device-mapper-static
616 %defattr(644,root,root,755)
617 %{_libdir}/libdevmapper.a
618
619 %if %{with initrd}
620 %if %{with dietlibc}
621 %files -n device-mapper-dietlibc
622 %defattr(644,root,root,755)
623 %{dietlibdir}/libdevmapper.a
624 %endif
625
626 %files -n device-mapper-initrd
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/initrd/dmsetup
629
630 %files initrd
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/initrd/lvm
633 %endif