]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- fixed post/postun broken by PLD merge
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - spec default value for --with-replicators (=internal/shared/none, configure default is none)?
4 #   (also internal vs shared for lvm1,pool,cluster,snapshots,mirrors,raid,replicators,thin,cache;
5 #    note: dmeventd requires mirrors=internal)
6 #
7 # Conditional build:
8 # - initrd stuff
9 %bcond_with     initrd          # build initrd version
10 %bcond_without  uClibc          # link initrd version with uClibc
11 %bcond_with     dietlibc        # link initrd version with dietlibc
12 %bcond_with     glibc           # link initrd version with static GLIBC
13 # - functionality
14 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
15 %bcond_without  lvmetad         # lvmetad (and lvmlockd)
16 %bcond_without  lvmdbusd        # lvmdbusd
17 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
18 %bcond_without  lvmlockd        # lvmlockd
19 %bcond_with     sanlock         # sanlock support in lvmlockd
20 %bcond_with     replicator      # internal replicator support
21 # - additional features
22 %bcond_without  selinux         # SELinux support
23 # - bindings
24 %bcond_without  python          # Python bindings
25 %bcond_without  python2         # Python 2 binding
26 %bcond_without  python3         # Python 3 binding and lvmdbusd
27
28 # lvmlockd requires lvmetad and lvmpolld
29 %if %{without lvmetad} || %{without lvmpolld}
30 %undefine       with_lvmpolld
31 %endif
32
33 # if one of the *libc is enabled disable default dietlibc
34 %if %{with dietlibc} && %{with uClibc}
35 %undefine       with_dietlibc
36 %endif
37 # with glibc disables default dietlibc
38 %if %{with glibc} && %{with dietlibc}
39 %undefine       with_dietlibc
40 %endif
41 # fallback is glibc if neither alternatives are enabled
42 %if %{without dietlibc} && %{without uClibc}
43 %define         with_glibc      1
44 %endif
45 # for convenience
46 %if %{without python}
47 %undefine       with_python2
48 %undefine       with_python3
49 %endif
50 %if %{without python3}
51 %undefine       with_lvmdbusd
52 %endif
53
54 Summary:        The new version of Logical Volume Manager for Linux
55 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
56 Name:           lvm2
57 Version:        2.02.177
58 Release:        1
59 License:        GPL v2 and LGPL v2.1
60 Group:          Applications/System
61 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
62 # Source0-md5:  ee6cfbc5a0c5696ffae79dac04ee7a2b
63 Source3:        clvmd.sysconfig
64 Patch0:         %{name}-selinux.patch
65 Patch1:         %{name}-diet.patch
66 Patch2:         device-mapper-dmsetup-export.patch
67 Patch3:         %{name}-tld_init.patch
68 Patch4:         dl-dlsym.patch
69 Patch8:         %{name}-clvmd_cmd_timeout.patch
70 Patch9:         device-mapper-dmsetup-deps-export.patch
71 Patch11:        %{name}-thin.patch
72 URL:            http://www.sourceware.org/lvm2/
73 BuildRequires:  autoconf >= 2.69
74 BuildRequires:  automake
75 # for /run detection
76 BuildRequires:  filesystem >= 3.0-43
77 BuildRequires:  libblkid-devel >= 2.24
78 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
79 %{?with_selinux:BuildRequires:  libsepol-devel}
80 BuildRequires:  ncurses-devel
81 BuildRequires:  pkgconfig
82 %{?with_python2:BuildRequires:  python-devel >= 2}
83 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
84 %if %{with lvmdbusd}
85 BuildRequires:  python3-dbus
86 BuildRequires:  python3-pyudev
87 %endif
88 BuildRequires:  readline-devel
89 BuildRequires:  rpmbuild(macros) >= 1.647
90 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
91 BuildRequires:  udev-devel >= 1:176
92 %if %{with initrd}
93 %if %{with dietlibc}
94 BuildRequires:  dietlibc-static >= 2:0.32-7
95 BuildConflicts: device-mapper-dietlibc
96 %endif
97 %if %{with glibc}
98 %{?with_selinux:BuildRequires:  libselinux-static}
99 %{?with_selinux:BuildRequires:  libsepol-static}
100 %endif
101 %{?with_glibc:BuildRequires:    glibc-static}
102 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
103 %endif
104 %if %{with cluster}
105 BuildRequires:  corosync-devel
106 BuildRequires:  dlm-devel >= 3.99.5
107 %endif
108 Requires(post,postun):  /sbin/chkconfig
109 Requires:       device-mapper >= %{version}-%{release}
110 %{?with_selinux:Requires:       libselinux >= 1.10}
111 # doesn't work with 2.4 kernels
112 Requires:       uname(release) >= 2.6
113 Suggests:       thin-provisioning-tools >= 0.5.4
114 Obsoletes:      lvm
115 Obsoletes:      lvm2-systemd
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         _sbindir        /sbin
119 %define         _usrsbindir     /usr/sbin
120
121 # changing CFLAGS in the middle confuses confcache
122 %undefine       configure_cache
123
124 # borken on AC
125 %define         filterout_ld    -Wl,--as-needed
126
127 # causes: undefined reference to `__stack_chk_fail_local'
128 %define         filterout_c     -fstack-protector
129
130 # for some reason known only to rpm there must be "\\|" not "\|" here
131 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
132 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
133
134 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
135
136 %description
137 This package includes a number of utilities for creating, checking,
138 and repairing logical volumes.
139
140 %description -l pl.UTF-8
141 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
142 logicznych wolumenów dyskowych (LVM2).
143
144 %package initrd
145 Summary:        The new version of Logical Volume Manager for Linux - initrd version
146 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
147 Group:          Base
148 Conflicts:      geninitrd < 10000.18
149
150 %description initrd
151 This package includes a number of utilities for creating, checking,
152 and repairing logical volumes - staticaly linked for initrd.
153
154 %description initrd -l pl.UTF-8
155 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
156 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
157 potrzeby initrd.
158
159 %package clvmd
160 Summary:        Cluster LVM daemon
161 Summary(pl.UTF-8):      Demon clustra LVM
162 Group:          Applications/System
163 Requires:       %{name} = %{version}-%{release}
164
165 %description clvmd
166 clvmd is the daemon that distributes LVM metadata updates around a
167 cluster. It must be running on all nodes in the cluster and will give
168 an error if a node in the cluster does not have this daemon running.
169
170 %description clvmd -l pl.UTF-8
171 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
172 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
173 węzeł w klastrze nie ma tego demona uruchomionego.
174
175 %package cmirrord
176 Summary:        Cluster mirror log daemon
177 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
178 Group:          Applications/System
179 Requires:       %{name} = %{version}-%{release}
180
181 %description cmirrord
182 cmirrord is the daemon that tracks mirror log information in a
183 cluster. It is specific to device-mapper based mirrors (and by
184 extension, LVM cluster mirrors). Cluster mirrors are not possible
185 without this daemon running.
186
187 This daemon relies on the cluster infrastructure provided by the
188 Cluster MANager (CMAN), which must be set up and running in order for
189 cmirrord to function.
190
191 %description cmirrord
192 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
193 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
194 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
195 lustrzanych ten demon jest niezbędny.
196
197 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
198 (Cluster MANager), który musi być skonfigurowany i działający, aby
199 działał cmirrord.
200
201 %package dbusd
202 Summary:        LVM2 D-Bus daemon
203 Summary(pl.UTF-8):      Demon LVM2 D-Bus
204 Group:          Daemons
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       python3-dbus
207 Requires:       python3-pygobject3 >= 3
208 Requires:       python3-pyudev
209
210 %description dbusd
211 Daemon for access to LVM2 functionality through a D-Bus interface.
212
213 %description dbusd -l pl.UTF-8
214 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
215 D-Bus.
216
217 %package lockd
218 Summary:        LVM2 locking daemon
219 Summary(pl.UTF-8):      Demon blokad LVM2
220 Group:          Daemons
221 Requires:       %{name} = %{version}-%{release}
222 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
223 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
224
225 %description lockd
226 LVM commands use lvmlockd to coordinate access to shared storage.
227
228 %description lockd -l pl.UTF-8
229 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
230 współdzielonej pamięci masowej.
231
232 %package resource-agents
233 Summary:        OCF Resource Agents for LVM2 processes
234 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
235 Group:          Applications/System
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       resource-agents
238
239 %description resource-agents
240 OCF Resource Agents for LVM2 processes.
241
242 %description resource-agents -l pl.UTF-8
243 Agenci OCF do monitorowania procesów LVM2.
244
245 %package -n python-lvm
246 Summary:        Python 2 interface to LVM2
247 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
248 Group:          Libraries/Python
249 Requires:       device-mapper-libs = %{version}-%{release}
250
251 %description -n python-lvm
252 Python 2 interface to LVM2.
253
254 %description -n python-lvm -l pl.UTF-8
255 Interfejs Pythona 2 do LVM2.
256
257 %package -n python3-lvm
258 Summary:        Python 3 interface to LVM2
259 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
260 Group:          Libraries/Python
261 Requires:       device-mapper-libs = %{version}-%{release}
262
263 %description -n python3-lvm
264 Python 3 interface to LVM2.
265
266 %description -n python3-lvm -l pl.UTF-8
267 Interfejs Pythona 3 do LVM2.
268
269 %package -n device-mapper
270 Summary:        Userspace support for the device-mapper
271 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
272 Group:          Base
273 Requires(post,postun):  /sbin/ldconfig
274 Requires:       device-mapper-libs = %{version}-%{release}
275
276 %description -n device-mapper
277 The goal of this driver is to support volume management. The driver
278 enables the definition of new block devices composed of ranges of
279 sectors of existing devices. This can be used to define disk
280 partitions - or logical volumes. This light-weight kernel component
281 can support user-space tools for logical volume management.
282
283 %description -n device-mapper -l pl.UTF-8
284 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
285 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
286 sektorów na istniejących urządzeniach. Może to być wykorzystane do
287 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
288 składnik jądra może wspierać działające w przestrzeni użytkownika
289 narzędzia do zarządzania logicznymi wolumenami.
290
291 %package -n device-mapper-libs
292 Summary:        Device-mapper shared libraries
293 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
294 Group:          Libraries
295 Requires:       libblkid >= 2.24
296 Requires:       udev-libs >= 1:176
297 Conflicts:      device-mapper < 2.02.119-1
298
299 %description -n device-mapper-libs
300 Device-mapper shared libraries.
301
302 %description -n device-mapper-libs -l pl.UTF-8
303 Biblioteki współdzielone device-mappera.
304
305 %package -n device-mapper-devel
306 Summary:        Header files for device-mapper libraries
307 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
308 Group:          Development/Libraries
309 Requires:       device-mapper-libs = %{version}-%{release}
310 Requires:       libblkid-devel >= 2.24
311 %if %{with selinux}
312 Requires:       libselinux-devel
313 Requires:       libsepol-devel
314 %endif
315 Requires:       udev-devel >= 1:176
316
317 %description -n device-mapper-devel
318 Header files for device-mapper libraries.
319
320 %description -n device-mapper-devel -l pl.UTF-8
321 Pliki nagłówkowe bibliotek device-mappera.
322
323 %package -n device-mapper-static
324 Summary:        Static devmapper library
325 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
326 License:        LGPL v2.1
327 Group:          Development/Libraries
328 Requires:       device-mapper-devel = %{version}-%{release}
329
330 %description -n device-mapper-static
331 Static devmapper library.
332
333 %description -n device-mapper-static -l pl.UTF-8
334 Statyczna biblioteka devmapper.
335
336 %package -n device-mapper-dietlibc
337 Summary:        Static devmapper library built with dietlibc
338 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
339 License:        LGPL v2.1
340 Group:          Development/Libraries
341 Requires:       device-mapper-devel = %{version}-%{release}
342
343 %description -n device-mapper-dietlibc
344 Static devmapper library built with dietlibc.
345
346 %description -n device-mapper-dietlibc -l pl.UTF-8
347 Statyczna biblioteka devmapper zbudowana z dietlibc.
348
349 %package -n device-mapper-initrd
350 Summary:        Userspace support for the device-mapper - initrd version
351 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
352 Group:          Base
353 Obsoletes:      device-mapper-initrd-devel
354 Conflicts:      geninitrd < 10000.10
355
356 %description -n device-mapper-initrd
357 The goal of this driver is to support volume management. The driver
358 enables the definition of new block devices composed of ranges of
359 sectors of existing devices. This can be used to define disk
360 partitions - or logical volumes. This light-weight kernel component
361 can support user-space tools for logical volume management.
362
363 This package contains dmsetup program linked staticaly for use in
364 initrd.
365
366 %description -n device-mapper-initrd -l pl.UTF-8
367 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
368 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
369 sektorów na istniejących urządzeniach. Może to być wykorzystane do
370 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
371 składnik jądra może wspierać działające w przestrzeni użytkownika
372 narzędzia do zarządzania logicznymi wolumenami.
373
374 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
375 potrzeby initrd.
376
377 %prep
378 %setup -q -n LVM2.%{version}
379 %{?with_selinux:%patch0 -p1}
380 %patch1 -p1
381 %patch2 -p1
382 %patch3 -p1
383 %patch4 -p1
384 %patch8 -p1
385 %patch9 -p1
386 %patch11 -p1
387
388 # do not force --export-symbol linker option for e.g. statically linked executables
389 # -rdynamic compiler option drives linker in the right way.
390 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
391
392 %build
393 %if %{with initrd}
394 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
395 %endif
396 cp -f /usr/share/automake/config.sub autoconf
397 %{__aclocal}
398 %{__autoconf}
399
400 %if %{with initrd}
401 %{?with_glibc:export CC="%{__cc}"}
402 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
403 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
404
405 %configure \
406         ac_cv_lib_dl_dlopen=no \
407         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
408         %{?debug:--enable-debug} \
409         --disable-nls \
410         --disable-readline \
411         --enable-selinux%{!?with_glibc:=no} \
412         --enable-static_link \
413         --with-lvm1=internal \
414         --with-optimisation="%{rpmcflags} -Os"
415 # glibc version links with normal static libdevicemapper which has selinux enabled
416 # and we need to keep these in sync between device-mapper and lvm2
417
418 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
419 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
420
421 %{__make} -j1 -C include
422 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
423 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
424 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
425 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
426 %{__mv} tools/lvm.static initrd-lvm
427 %{__mv} tools/dmsetup.static initrd-dmsetup
428
429 # check if tools works
430 for tool in initrd-lvm initrd-dmsetup; do
431         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
432         if [ $rc -gt 127 ]; then
433                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
434                 exit 1
435         fi
436 done
437
438 %{?with_dietlibc:%{__mv} libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
439 %{__make} clean
440
441 unset CC
442 %endif
443
444 %configure \
445         --enable-applib \
446         --enable-cache_check_needs_check \
447         --enable-cmdlib \
448         %{?with_lvmdbusd:--enable-dbus-service} \
449         %{?debug:--enable-debug} \
450         --enable-dmeventd \
451         --enable-fsadm \
452         --with-default-locking-dir=/var/lock/lvm \
453 %if %{with lvmlockd}
454         %{?with_cluster:--enable-lvmlockd-dlm} \
455         %{?with_sanlock:--enable-lvmlockd-sanlock} \
456 %endif
457         %{?with_lvmetad:--enable-lvmetad} \
458         --enable-lvmpolld \
459         --enable-ocf \
460         %{?with_python2:--enable-python2_bindings} \
461         %{?with_python3:--enable-python3_bindings} \
462         --enable-readline \
463         %{!?with_selinux:--disable-selinux} \
464         --enable-pkgconfig \
465         --enable-thin_check_needs_check \
466         --enable-udev_sync \
467         --enable-udev_rules \
468         --with-cache=internal \
469         --with-cache-check=/usr/sbin/cache_check \
470         --with-cache-dump=/usr/sbin/cache_dump \
471         --with-cache-repair=/usr/sbin/cache_repair \
472         --with-cache-restore=/usr/sbin/cache_restore \
473         --with-cluster=internal \
474 %if %{with cluster}
475         --with-clvmd=corosync \
476         --enable-cmirrord \
477 %endif
478         --with-dmeventd-path=%{_sbindir}/dmeventd \
479         --with-interface=ioctl \
480         --with-lvm1=internal \
481         --with-mirrors=internal \
482         --with-optimisation="%{rpmcflags}" \
483         --with-pool=internal \
484         %{?with_replicator:--with-replicators=internal} \
485         --with-snapshots=internal \
486         --with-thin=internal \
487         --with-thin-check=/usr/sbin/thin_check \
488         --with-thin-dump=/usr/sbin/thin_dump \
489         --with-thin-repair=/usr/sbin/thin_repair \
490         --with-thin-restore=/usr/sbin/thin_restore \
491         --with-udev-prefix=/ \
492         --with-usrlibdir=%{_libdir}
493
494 # use bash because of "set -o pipefail"
495 %{__make} -j1 \
496         SHELL=/bin/bash
497 %{__make} -j1 -C libdm \
498         LIB_STATIC=libdevmapper.a
499
500 %install
501 rm -rf $RPM_BUILD_ROOT
502 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
503 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
504
505 %{__make} install install_system_dirs install_initscripts \
506         DESTDIR=$RPM_BUILD_ROOT \
507         OWNER="" \
508         GROUP="" \
509         python3dir=%{py3_sitescriptdir}
510
511 %if %{with cluster}
512 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
513 %endif
514
515 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
516 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
517         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
518         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
519         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
520 done
521
522 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
523
524 %if %{with initrd}
525 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
526 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
527 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
528
529 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
530 %endif
531
532 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
533
534 %clean
535 rm -rf $RPM_BUILD_ROOT
536
537 %post
538 /sbin/chkconfig --add lvm2-lvmetad
539 %service lvm2-lvmetad restart
540 /sbin/chkconfig --add lvm2-monitor
541 %service lvm2-monitor restart
542 /sbin/chkconfig --add lvm2-lvmpolld
543 %service lvm2-lvmpolld restart
544 # no service restart available
545 /sbin/chkconfig --add blk-availability
546 # no service blk-availability restart
547
548 %postun
549 if [ "$1" = "0" ]; then
550         %service lvm2-lvmetad stop
551         /sbin/chkconfig --del lvm2-lvmetad
552         %service lvm2-lvmpolld stop
553         /sbin/chkconfig --del lvm2-lvmpolld
554         %service lvm2-monitor stop
555         /sbin/chkconfig --del lvm2-monitor
556         #no service blk-availability stop
557         /sbin/chkconfig --del blk-availability
558 fi
559
560 %post   -n device-mapper-libs -p /sbin/ldconfig
561 %postun -n device-mapper-libs -p /sbin/ldconfig
562
563 %post clvmd
564 /sbin/chkconfig --add clvmd
565 # no service restart - it breaks current locks!
566 export NORESTART=1
567 # re-exec instead
568 /usr/sbin/clvmd -S 2>/dev/null || :
569
570 %preun clvmd
571 if [ "$1" = "0" ]; then
572         %service clvmd stop
573         /sbin/chkconfig --del clvmd
574 fi
575
576 %files
577 %defattr(644,root,root,755)
578 %doc README WHATS_NEW doc/*
579 %attr(755,root,root) %{_sbindir}/blkdeactivate
580 %attr(755,root,root) %{_sbindir}/fsadm
581 %attr(755,root,root) %{_sbindir}/lvchange
582 %attr(755,root,root) %{_sbindir}/lvconvert
583 %attr(755,root,root) %{_sbindir}/lvcreate
584 %attr(755,root,root) %{_sbindir}/lvdisplay
585 %attr(755,root,root) %{_sbindir}/lvextend
586 %attr(755,root,root) %{_sbindir}/lvm
587 %attr(755,root,root) %{_sbindir}/lvmconf
588 %attr(755,root,root) %{_sbindir}/lvmconfig
589 %attr(755,root,root) %{_sbindir}/lvmdiskscan
590 %attr(755,root,root) %{_sbindir}/lvmdump
591 %attr(755,root,root) %{_sbindir}/lvmsadc
592 %attr(755,root,root) %{_sbindir}/lvmsar
593 %attr(755,root,root) %{_sbindir}/lvreduce
594 %attr(755,root,root) %{_sbindir}/lvremove
595 %attr(755,root,root) %{_sbindir}/lvrename
596 %attr(755,root,root) %{_sbindir}/lvresize
597 %attr(755,root,root) %{_sbindir}/lvs
598 %attr(755,root,root) %{_sbindir}/lvscan
599 %attr(755,root,root) %{_sbindir}/pvchange
600 %attr(755,root,root) %{_sbindir}/pvck
601 %attr(755,root,root) %{_sbindir}/pvcreate
602 %attr(755,root,root) %{_sbindir}/pvdisplay
603 %attr(755,root,root) %{_sbindir}/pvmove
604 %attr(755,root,root) %{_sbindir}/pvremove
605 %attr(755,root,root) %{_sbindir}/pvresize
606 %attr(755,root,root) %{_sbindir}/pvs
607 %attr(755,root,root) %{_sbindir}/pvscan
608 %attr(755,root,root) %{_sbindir}/vgcfgbackup
609 %attr(755,root,root) %{_sbindir}/vgcfgrestore
610 %attr(755,root,root) %{_sbindir}/vgchange
611 %attr(755,root,root) %{_sbindir}/vgck
612 %attr(755,root,root) %{_sbindir}/vgconvert
613 %attr(755,root,root) %{_sbindir}/vgcreate
614 %attr(755,root,root) %{_sbindir}/vgdisplay
615 %attr(755,root,root) %{_sbindir}/vgexport
616 %attr(755,root,root) %{_sbindir}/vgextend
617 %attr(755,root,root) %{_sbindir}/vgimport
618 %attr(755,root,root) %{_sbindir}/vgimportclone
619 %attr(755,root,root) %{_sbindir}/vgmerge
620 %attr(755,root,root) %{_sbindir}/vgmknodes
621 %attr(755,root,root) %{_sbindir}/vgreduce
622 %attr(755,root,root) %{_sbindir}/vgremove
623 %attr(755,root,root) %{_sbindir}/vgrename
624 %attr(755,root,root) %{_sbindir}/vgs
625 %attr(755,root,root) %{_sbindir}/vgscan
626 %attr(755,root,root) %{_sbindir}/vgsplit
627 %{_mandir}/man5/lvm.conf.5*
628 %{_mandir}/man7/lvmcache.7*
629 %{_mandir}/man7/lvmraid.7*
630 %{_mandir}/man7/lvmreport.7*
631 %{_mandir}/man7/lvmsystemid.7*
632 %{_mandir}/man7/lvmthin.7*
633 %{_mandir}/man8/blkdeactivate.8*
634 %{_mandir}/man8/fsadm.8*
635 %{_mandir}/man8/lvchange.8*
636 %{_mandir}/man8/lvconvert.8*
637 %{_mandir}/man8/lvcreate.8*
638 %{_mandir}/man8/lvdisplay.8*
639 %{_mandir}/man8/lvextend.8*
640 %{_mandir}/man8/lvm-config.8*
641 %{_mandir}/man8/lvm-dumpconfig.8*
642 %{_mandir}/man8/lvm-fullreport.8*
643 %{_mandir}/man8/lvm-lvpoll.8*
644 %{_mandir}/man8/lvm.8*
645 %{_mandir}/man8/lvmconf.8*
646 %{_mandir}/man8/lvmconfig.8*
647 %{_mandir}/man8/lvmdiskscan.8*
648 %{_mandir}/man8/lvmdump.8*
649 %{_mandir}/man8/lvmsadc.8*
650 %{_mandir}/man8/lvmsar.8*
651 %{_mandir}/man8/lvreduce.8*
652 %{_mandir}/man8/lvremove.8*
653 %{_mandir}/man8/lvrename.8*
654 %{_mandir}/man8/lvresize.8*
655 %{_mandir}/man8/lvs.8*
656 %{_mandir}/man8/lvscan.8*
657 %{_mandir}/man8/pvchange.8*
658 %{_mandir}/man8/pvck.8*
659 %{_mandir}/man8/pvcreate.8*
660 %{_mandir}/man8/pvdisplay.8*
661 %{_mandir}/man8/pvmove.8*
662 %{_mandir}/man8/pvremove.8*
663 %{_mandir}/man8/pvresize.8*
664 %{_mandir}/man8/pvs.8*
665 %{_mandir}/man8/pvscan.8*
666 %{_mandir}/man8/vgcfgbackup.8*
667 %{_mandir}/man8/vgcfgrestore.8*
668 %{_mandir}/man8/vgchange.8*
669 %{_mandir}/man8/vgck.8*
670 %{_mandir}/man8/vgconvert.8*
671 %{_mandir}/man8/vgcreate.8*
672 %{_mandir}/man8/vgdisplay.8*
673 %{_mandir}/man8/vgexport.8*
674 %{_mandir}/man8/vgextend.8*
675 %{_mandir}/man8/vgimport.8*
676 %{_mandir}/man8/vgimportclone.8*
677 %{_mandir}/man8/vgmerge.8*
678 %{_mandir}/man8/vgmknodes.8*
679 %{_mandir}/man8/vgreduce.8*
680 %{_mandir}/man8/vgremove.8*
681 %{_mandir}/man8/vgrename.8*
682 %{_mandir}/man8/vgs.8*
683 %{_mandir}/man8/vgscan.8*
684 %{_mandir}/man8/vgsplit.8*
685 %attr(750,root,root) %dir %{_sysconfdir}/lvm
686 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
687 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
688 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
689 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
690 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
691 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
692 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
693 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
694 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
695 %dir %{_sysconfdir}/lvm/cache
696 %ghost %{_sysconfdir}/lvm/cache/.cache
697 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
698 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
699 %attr(700,root,root) %dir /run/lvm
700 %attr(700,root,root) %dir /var/lock/lvm
701 %if %{with lvmetad}
702 %attr(755,root,root) %{_sbindir}/lvmetad
703 /lib/udev/rules.d/69-dm-lvm-metad.rules
704 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
705 %{_mandir}/man8/lvmetad.8*
706 %endif
707 %if %{with lvmlockd}
708 %attr(755,root,root) %{_sbindir}/lvmlockctl
709 %attr(755,root,root) %{_sbindir}/lvmlockd
710 %{_mandir}/man8/lvmlockctl.8*
711 %{_mandir}/man8/lvmlockd.8*
712 %endif
713 %if %{with lvmpolld}
714 %attr(755,root,root) %{_sbindir}/lvmpolld
715 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
716 %{_mandir}/man8/lvmpolld.8*
717 %endif
718
719 %if %{with cluster}
720 %files clvmd
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_usrsbindir}/clvmd
723 %attr(754,root,root) /etc/rc.d/init.d/clvmd
724 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
725 %{_mandir}/man8/clvmd.8*
726
727 %files cmirrord
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_usrsbindir}/cmirrord
730 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
731 %{_mandir}/man8/cmirrord.8*
732 %endif
733
734 %if %{with lvmdbusd}
735 %files dbusd
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_sbindir}/lvmdbusd
738 %{py3_sitescriptdir}/lvmdbusd
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
740 #%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
741 #%{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
742 %{_mandir}/man8/lvmdbusd.8*
743 %endif
744
745 %files resource-agents
746 %defattr(644,root,root,755)
747 %dir %{_prefix}/lib/ocf/resource.d/lvm2
748 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
749
750 %if %{with python2}
751 %files -n python-lvm
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{py_sitedir}/lvm.so
754 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
755 %endif
756
757 %if %{with python3}
758 %files -n python3-lvm
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
761 %{py3_sitedir}/lvm-%{version}_*-py*.egg-info
762 %endif
763
764 %files -n device-mapper
765 %defattr(644,root,root,755)
766 %doc *_DM
767 /lib/udev/rules.d/10-dm.rules
768 /lib/udev/rules.d/11-dm-lvm.rules
769 /lib/udev/rules.d/13-dm-disk.rules
770 /lib/udev/rules.d/95-dm-notify.rules
771 %attr(755,root,root) %{_sbindir}/dmeventd
772 %attr(755,root,root) %{_sbindir}/dmsetup
773 %attr(755,root,root) %{_sbindir}/dmstats
774 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
775 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
776 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
777 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
778 %dir %{_libdir}/device-mapper
779 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
780 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
781 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
782 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
783 %{_mandir}/man8/dmsetup.8*
784 %{_mandir}/man8/dmstats.8*
785 %{_mandir}/man8/dmeventd.8*
786
787 %files -n device-mapper-libs
788 %defattr(644,root,root,755)
789 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
790 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
791 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
792 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
793 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
794
795 %files -n device-mapper-devel
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libdevmapper.so
798 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
799 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
800 %attr(755,root,root) %{_libdir}/liblvm2app.so
801 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
802 %{_includedir}/libdevmapper.h
803 %{_includedir}/libdevmapper-event.h
804 %{_includedir}/lvm2app.h
805 %{_includedir}/lvm2cmd.h
806 %{_pkgconfigdir}/devmapper.pc
807 %{_pkgconfigdir}/devmapper-event.pc
808 %{_pkgconfigdir}/lvm2app.pc
809
810 %files -n device-mapper-static
811 %defattr(644,root,root,755)
812 %{_libdir}/libdevmapper.a
813
814 %if %{with initrd}
815 %if %{with dietlibc}
816 %files -n device-mapper-dietlibc
817 %defattr(644,root,root,755)
818 %{dietlibdir}/libdevmapper.a
819 %endif
820
821 %files -n device-mapper-initrd
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/initrd/dmsetup
824
825 %files initrd
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_libdir}/initrd/lvm
828 %endif